Help! All data in mybook live gone and owner password unknown

Add me to the list… exactly the same as already described.

Found this on the WD site here: My Book Live or Duo Not Detected on Windows 10 Network
So maybe Microsoft is the problem… surprising? Never mind, it doesn’t fix the problem.

Windows 10 is not a supported and verified operating system for My Book Live and My Book Live Duo.
For a list of compatible operating systems, please refer to Answer ID 19060 Supported Operating Systems for My Book Live and Duo

The “Network Browse” function has been disabled on Windows 10 v1709 and higher.
SMB 1.0/CIFS File Sharing Support has been disabled on Windows 10 Windows 10 Fall Creators Update version 1709 and higher.

The Computer Browser service relies on the SMB 1.0 protocol to populate the Windows Explorer Network node (also known as “Network Neighborhood”). This legacy protocol is long deprecated, doesn’t route, and has limited security. Because the service cannot function without SMB 1.0, it is removed when SMB 1.0 is disabled.

IMPORTANT\ 35pxx45px Important: The change is not limited to WD Products.

For more details, please refer to the first link

That was an older issue, I remember turning on smb 1.0 but that was a good while ago.
I can see the folders in network, well the shared ones but they are all empty.

1 Like

Same issue, U.S. here. Getting an error using any of my mapped drives, and my admin password is not working. So frustrating.

I went through different support sites, enabling SMB1, etc. but nothing has fixed it. I don’t know how to tell if it was factory reset or anything. I saw a bunch of articles about resetting the admin password by doing a restore (without losing the data), but I’m wary of whether that will actually help, and I’m not all that tech savvy.

I hope someone from WD can help. I know I have a very old device, but it has been mostly reliable all these years…

Hi again everyone, I’ve created a post over at r/techsupport to see if the hive mind can help us out with what to do next.

I get the impression we aren’t going to get any answers out of WD…

1 Like

Good idea! Might generate some ideas. Also, the more publicity this gets, the more likely we are to get a response from WD.

Not being mean…just sayin’

Mine, so far, is OK. BUT…about a year ago I put a new 3TB Red in it. Wonder if that might be my saving grace. But my gosh, if your data are so important to you why not have it backed up? Better yet it might just be time to get a new NAS device. SMB1 is dead and might not be available on Windows AT ALL in the near future.

There is a member @nfodiz that’s pretty knowledgeable maybe he can help?
You can SSH into the MyBookLive. If you’re familiar with those commands maybe you could recover your data that way…but I’m not smart enough to help with that. HERE is a post which explains how to SSH into it.

Luckily I’ve probably got 95%+ of the data backed up elsewhere and the stuff I haven’t is generally just bits and bobs I’ve downloaded off the internet so can probably find again. It’ll be a pain to rebuild the drive though as I used it to back up a variety of other sources. I didn’t want to start messing about with it until we established what had happened and whether it was going to be possible to recover the files.

Just hope I don’t suffer any HDD failures in the meantime.

It is a timely reminder to keep on top of your backups though…

Some news -

Managed to speak to WD and they’ve confirmed a support ticket and receipt of my system logs. Also informed them if this thread and the fact that this is not an isolated incident.

They have engineers looking into it apparently. I will post any updates as soon as I get them.

Stay strong team - we’re on this!

8 Likes

No issues with my MyBookLive YET. Could someone do what flhthemi said and enable SSH and login to their MBL using PuTTY or WinSCP etc and browse to /DataVolume/shares and browse in to one of your shares there and see if they are now empty. If the data is still showing there then there is likely an easy fix and all hope is not lost. If the data does NOT show, this goes beyond anything a firmware update can fix and I dare not offer advice on data recovery, I’ll leave that up to the folks at Western Digital.

Thanks

Also, I forgot to mention, it appears WD released a firmware update recently for the MBL after all these years which seems quite odd BUT maybe they were trying to patch up the many many holes in the very outdated firmware.

A new version of firmware is available

A new version of the firmware has been released. Please update your device.

Thu 17 Jun 2021 03:00:08 AM EDT

Does anyone know if you can log into via SSH and recover files that way? If so where would the files be located?

Thanks

Check to see if the data is still in your shares via SSH at the following location

/DataVolume/shares

You’ll have to enter each of your shares from that point to see if the folders are indeed empty or not. Please report back your findings.

Using my GUI with browser all those shared are empty

1 Like

using SSH looks empty as well ):

yBookLive:/DataVolume/shares/Public# cd Shared Pictures
-bash: cd: Shared: No such file or directory
MyBookLive:/DataVolume/shares/Public# cd Shared\ Pictures/
MyBookLive:/DataVolume/shares/Public/Shared Pictures# ls
MyBookLive:/DataVolume/shares/Public/Shared Pictures# ls
MyBookLive:/DataVolume/shares/Public/Shared Pictures#

1 Like

That could be a firmware related issue “possibly”, you would need to enable SSH and use PuTTY or WinSCP or something similar to check the actual shares directly on the drive itself.

Ouch, that doesn’t sound promising. I’m gonna keep an eye on this thread but I’ll leave it to the folks at WD as far as Data Recovery goes as I don’t want to be the reason someone can’t recover their data because of some bad advice I may give by mistake as I’m not an expert in that regards.

Same for me in France with my 2 To MybookLive ! It is empty, 0 octet.
The file Shared document has disappeared, the only remaining files under Public are Shared Music, Shared pictures, Shared videos, and software, but all of them are empty !
All of those files have been created on the jun 24 at AM 00.23.35 Paris time
when I try to log into the control UI, I have the same as on your screancopy.
I have open a help ticket on WD website, everybody should do so !
Please excuse my poor english.
Hello from France !

2 Likes

I’m having the same issue! I reset my drive so I’m able to get in, but there’s absolutely nothing there. However, it still shows 3gb of data is on the drive…not sure if those are my files and I just can’t access them right now or if it’s something bigger. We use the drive at work to network between computers for simple word/excel docs, so it’s not a ton of storage on there. I just need to access the files again!

Same here. In my log there is a factory restore I didn’t do. And all data is gone. Anyway to recover it? Years of data gone!! :((((