Help! All data in mybook live gone and owner password unknown

Has anyone had any success with data recovery. Ive got mine connected to my pc via usb but struggling to find a suitable program

Same story here. What a loss of data!

Do not believe that this was due to malware I scan the entire system inc MBL monthly with an antivirus (this takes several hours) and back up all the files on the MBL onto a disk in a usb3 connected cradle every month so I have lost a months backups (and I have that data in other locations
). Fom new remote access was disabled.

Hi @Grokheim , I am Satyeshu from Stellar. I was going through your post and got to know that while recovering your WD using Stellar Data Recovery was unsuccessful. I am not sure which Edition of our Product you tried? Since this is a case of ext file format, you need to try Stellar Toolkit for Data Recovery which will help you in recovering your data: Data Recovery Toolkit – Recover Data from Windows, Mac & Linux

Let me know if this work for you. You can also contact our support team to get free Support and will help you to recover your data.

Ive just tried this software and is saying no data found

Hi @TruckerJoe Did you tried using the deep scan feature of the software? Please confirm. Also ensure you have admin access to the PC while using the software.

Im struggling with that software myself. Currently going out of my mind/ “IF” i manage to get anything back I think cloud storage else ware would be a wise investment

Yes i checked the deep scan but to no avail

Good morning Hazamel,
Have you had any success in restoring data?
Thank you, Jeff

“Pay the price for not renewing unsupported hardware.”

That sounds ridiculous. NAS drives are not like CPUs or GPUs that get updated every few years. Most NAS devices stay in service a very long time, and the drives within the NAS unit are upgraded rather than the entire NAS itself. After all, WD made access to the drives easy just for that purpose!

Most people need a simple and reliable storage solution, and nothing more, and therefore don’t need to replace NAS enclosures every time the manufacturer introduces a newer model.

You’ve already posted the same words of wisdom here in several posts. No need to keep repeating yourself.

7 Likes

Unfortunately wd abandoned you all. Vote with your wallet.

3 Likes

Its just another example of WDs could not care less attitude after just been caught last year using inferior SMR technology in their Red disks.

3 Likes

Nothing to do with it.

I finally bit the bullet and went with OneDrive.

1 Like

You can’t detect the malware in this way because it wasn’t running on your system. The attacker was the one running the malware, not you.

Disable UPnP when you get the chance if you haven’t already.

1 Like

MyBookLive user in North America, not affected (crossing fingers)

UPNP: turned ON at the router, for the last 20 years or so
MBL Remote Access: turned ON
MBL Auto Update: turned OFF

So could it be for others the auto update downloaded a mal script ?

1 Like

No, it was not from auto-update. I had auto-update disabled as well, and I also had cloud remote access disabled, and my MyBook Live Duo was still wiped out.

Nobody yet knows for sure exactly what the attack vector was, but if you absolutely need to use the drive, disabling UPNP and blocking the drive from the internet should be done immediately.

3 Likes

Yes, I was successful.

So far I can’t recommend testdisk/photorec because it’s just bad in this case and I had the least finds (and tons of Timemmachine spam).
Disk Genius went pretty good. I got solild results. Got Pictures I missed at my photorec-Run. But free version is very limited when it comes to filesize (guess everything bigger than 100kb is considered as “large file”). Only option here is to buy the professional version for 100$ because of the ext3/4-support.
I liked the preview-mode here to see how the files are and what it actually is.
Did a run with recuva over night but only checked for the images. It’s pretty slow (or buggy). Overnight wasn’t long enough to finish. Images look good. Found images I’ve deleted years ago.
Actual recovery of the data was pretty fast.

I’m currently pulling an image of the drive for further tests with DiskInternals Linux Recovery and to speed up things. After that I’ll see which tool I use for the Recovery.

No matter what tool: It’ll be a lot of work because no filenames, no folders. Things like eBooks get totally disintegrated by those tools. I’ve a mixture of images and html-pages. Some of these Books are no longer available so that’s a real loss. And it seems like old backup-Files got disintegrated too. I found images that look very much like the stuff you find in your temporary internet files.
All in all not everything is lost and hopeless. No matter what WD will do (or not) money can’t pay the time, grey hairs and cups of coffee.
As an IT professional I really feel sorry for those who aren’t and don’t have the knowledge or options to do this on their own. And I guess those are the majority of the victims because the MyBook-Series came at a reasonable price and about zero effort to use compared to a professional or semi-professional NAS-System.

2 Likes

Same thing in Norway, extreamly sad to see all my pictures of my kids are gone :sob:

Interesting, will disable UPnP now, I only used it to port forward it to transmission running on the MBL, can do that manually on a fixed port instead. Thanks for the data point, probably means there could be multiple attack vectors.

1 Like