Help! All data in mybook live gone and owner password unknown

I have a WD mybook live connected to my home LAN and worked fine for years. I have just found that somehow all the data on it is gone today, while the directories seems there but empty. Previously the 2T volume was almost full but now it shows full capacity.
The even strange thing is when I try to log into the control UI for diagnosis I was-only able to get to this landing page with an input box for “owner password”. I have tried the default password “admin” and also what I could set for it with no luck. There seems to be no change to retrieve or reset password on this landing page either.
Could anyone help to find what was going on to this drive? I am stuck at emptied data on it now…Thanks in dadvance!


sunpeak, I to am experiencing the exact same problem just started today, I hope someone has some answers. I will keep an eye on this thread while I look for a fix.

1 Like

Wow…That is actually a good news to me if this is a common issue. I was thinking to bring the drive for data recovery tomorrow.
Yes I have found all the folders has an edit date of 06/23 today around 3PM PDT.
So hopefully it is some kind of firmware problem WD pushed today?
I dare not to touch this drive anymore and hope my data is still safe and has not lost…


All my data is gone too. Message in GUI says it was “Factory reset” today! 06/23. I am totally screwed without that data…years of it.


good luck

This is kind of scary. Exact same issue I was able to reset my password and log into the GUI but all my data is gone.
There is no indication of firmware update. Not sure what to do…

Factory reset? How do you know about it? Is it a quick one or full one? If the later it is showing in the GUI that all the data will be unrecoverable…
BTW: I have used a pin to poke the reset hole at the back of the unit and successfully erased the unknown owner password. Now I can access the control panel. However, no clue on what to do to get my data back…

1 Like

Same. Is there anyone we can contact ?

I agree with you. No firmware update today by anybody.
Mine is still showing:
My Book Live Firmware

Version:MyBookLive 02.43.10-048 : Core F/W

Last Update:Tue 23 Jun 2015 03:36:19 AM PDT
So what the hell is going on here? Why all the data was gone?

I am trying to file a ticket using ask a question| SD support
This is an urgent issue and I want quick response and solutions!

When I couldn’t access any of the 4 Network drives I created, I went to Network and double clicked on the MyBookLive Icon, which took me to the GUI page. A message popped up in the upper right that said the drive was factory reset. I wasn’t near my computer when this happened as the time stamp was earlier in the day. All WD is going to ask if we created a “Safepoint” which we could then recover the data from the last saved point. There has to be some “User Intervention” on WD’s part for this to happen to more than one person today.

It is very scary that someone can do factory restore the drive without any permission granted from the end user…
I have found this in user.log of this drive today:
Jun 23 15:14:05 MyBookLive begin script:
Jun 23 15:14:05 MyBookLive shutdown[24582]: shutting down for system reboot
Jun 23 16:02:26 MyBookLive begin script: start
Jun 23 16:02:29 MyBookLive _: pkg: wd-nas
Jun 23 16:02:30 MyBookLive _: pkg: networking-general
Jun 23 16:02:30 MyBookLive _: pkg: apache-php-webdav
Jun 23 16:02:31 MyBookLive _: pkg: date-time
Jun 23 16:02:31 MyBookLive _: pkg: alerts
Jun 23 16:02:31 MyBookLive logger: hostname=MyBookLive
Jun 23 16:02:32 MyBookLive _: pkg: admin-rest-api
I believe this is the culprit of why this happens…No one was even home to use this drive at this time…
P.S. You can use support->create and save system report to get all the logs. Please check yours and see what happened.

1 Like

Here’s my log pertaining to today when it happened:
Jun 23 15:30:48 MyBookLive begin script:
Jun 23 15:30:48 MyBookLive shutdown[32260]: shutting down for system reboot
Jun 23 15:30:56 MyBookLive CommMgr: DaemonControl::disableRemoteAccess - remote access is disabled.
Jun 23 15:31:02 MyBookLive kernel: nfsd: last server has exited, flushing export cache

Exact same thing has happened to me. Tried to access some files via the iPhone app but got an error message saying “unable to connect”. Assumed it was just a Wi-Fi/network issue but when I tried to access the drive from my PC using a shortcut everything was gone except for (empty) default Public folders: Shared Music, Shared Pictures, Shared Videos and Software.

The time stamps on those folders say they were created at 00:16 (UK time) this morning.

There is also a .tickle file created at 00:17.

I can’t log into the UI on the device as it says my password is invalid.

1 Like

Same problem here !
It is a big issue! Please let us know what is going on.
We need help from WD

all data gone, what kind of security is this?

Hi another victim here, also in the UK.

Anyone had any luck yet?

Got a decade of life’s work and photos at stake so willing to do whatever it takes to recover.

I’ve sent a DM to WD’s customer support account (@WesternDigiCare) on Twitter and referred them to this thread.

1 Like

Good work - let us know the results!

Same problem Also
I kept all my documents on this drive. All files gone, four empty folders for: pictures, music, that I never used. My pictures are stored elsewhere. Unfortunately or fortunately my last backup was 4.5 months ago. I thought I had my backup program set for scheduled backups, but that is another problem to look into. If this turns out to be a WD problem, I will look elsewhere for future storage equipment. I wish everybody good luck and if someone finds a solution, please post it.

1 Like