Help! 2 WDTV Live SMPs locking up randomly

My WDTV Live SMP had been working pretty well for a few months (I purchased it in December) and slowly but surely it started locking up when I paused it. This lock up would freeze the entire unit and make the remote unresponsive. Then it started locking up when I tried to play files (usually MKVS that palyed fine previously). The spinning arrow would remain on the screen along with the info bar and the remote would lock up. Playback would continue behind these items. Movies will play fine once they are started. The player will not crash if you do not pause, menu back, etc. A whole movie will play absolutely fine and then the player will crash if you pause it, etc.

I’ve read through countless threads and have tried a few of the suggestions with no luck.

  • My network consists of a few gigabit switches along with an Asus AC66U router and a WD My Cloud 4tb nas.
  • I’m streaming to the WDTV Live SMPs (both of them) via an SMB share from the NAS. This seemed to also happen before I introduced the NAS when I was running the shares off my Windows 7 PC.
  • The router is newly in the picture, before that I had a Cisco EA6500.
  • UPNP is enabled on the router.
  • I’ve swapped all network cables and even tried connecting the WDTV to the switch directly.
  • Both players are running the latest firmware (I absoulely don’t want to loose the DTS-HD passthrough) :slight_smile:

I did realize that the running of Universal Media Server could possibly have something to do with it, so I’ve stopped that all together and will test today to see if that was causing some issues. (I have other devices that need transcoding or else I wouldn’t bother with it at all).

Does anyone have any suggestions that I might be missing? I don’t think turning off UPNP on the router level is an option as it’s only going to cause headaches with the Xboxs and other devices on the network that seem to rely on UPNP for everything.

Thank you guys!

I have had the odd freeze and found it helped to rebuild the media library. The other thing you may try is to use linux shares between your WD NAS and WDTV live, they are both linux boxes. My NAS is a Mybooklive and since I went over to linux shares the WDTV Live has worked well.

Since the WD My Cloud is already NFS then can I just turn on the NFS option on the WDTV Live?

I can definitely give that a try if it’s helped some people.

Right now I’m testing to make sure that my Media Server wasn’t affecting it since it is a upnp renderer and I’m assuming could be interefered with by a DLNA/UPNP server like that.

So the Universal Media Server was not the culprit. It just locked up on me while paused on an mkv episode of Orphan Black. Remote was unresponsive and I had to pull the power. It also drops off the network completely when this happens as I cannot access the WebGUI when it’s in this state.

My router is an AC66U. I have just turned off WAN uPNP and will run some more tests again to see if this alleviates my issue. I’m thinking it will introduce a bunch of other issues though :frowning:

You can just turn on Linux shares on your WDTV Live and you ought to see the ip address of your NAS listed when you browse the linux shares network. Because it seems to work on ip addresses you may need to set up your router so that the WDTV always has the same ip address. I have since installed haneWin NFS server on my desktop PC so that I use only linux shares throughout and havent experinced any network issues since. It’s worth a try…

I may have to try this tonight, especially if there’s a slim chance that it eliminates some of this extreme weirdness I’ve been seeing.

So far I’ve noticed that one of my computers has some affect on the player, even though it’s not where the player is streaming from. When I reboot the computer it seems to unfreeze the player for whatever reason. I just updated the NIC card drivers in hopes it was something to do with the driver, but I’m doubting it at this point.

if you read a few of the various posts here about network issues you’ll hear talk of “master browser” for windows shares. to me it seems that windows PCs can maintain network connections even when the master browser goes off-line but some other devices can loose connection. It doesnt seem to matter whether or not you are streaming from the machine that is the master browser, if the master browser goes off-line it can cause issues (great word) it seems. I notice that its only recently these issues seem to be causing a problem for some people, has there been a windows update that is causing this? Just a thought for those who know far more than I do.


I think you may be onto something there. If the WDTV Live gets “unfrozen” when I shut off a certain PC on the network then maybe the WDTV is having issues figuring out who the master browser is?

It’s a strange issue that I will attempt to circumvent by using the NFS shares, however that’s not going to be an option for most people unless they have a NAS or a linux machine.

I’m thinking these issues may have come into play with some type of windows update, i’ll look into it more.

Is your Asus router set to be the master browser?  Since it has that capability I would suggest turning it on.

This particular firmware does not have that option at all. One of the PCs is set to be the master browser, when the media player locks up I can reboot that PC and it seems to get the player going again.

I may look into Merlin’s firmware for this router, but the default firmware has no option for Master Browser anywhere unfortunately.

This is definitely a client side issue on the WDTV side though. I’m thinking that maybe…you know what, I’m not sure what to think but WD has a lot more resources than I do for troubleshooting. There’s definitely an issue here that needs to be resolved.

Doy you have the SAMBA server enabled in USB Services on the ASUS and workgroup set the same as the rest of you machines? You might have to atach an USB drive to one of the USB ports, a small thumb drive should do with or without files on it. I do believe when the SAMBA service is active it  (the ASUS) will try to be master Browser.  You might have to turn off the PCs and reboot the router for the router to assume the role.

Will this help because the router is on all the time? The PC that is currently the master browser is also on all the time and never goes into suspend.

I’m thinking changing it to NFS might solve my issue. I’m going to try that next I think as all the movies are stored on the NAS which supports NFS. I’ll probably end up giving it a static IP so it doesn’t change…but it would be worth a try.

I’m so frustrated with the issues this thing has streaming from another WD on a network they supposedly support.


Just roll back to 1.16 firmware.  The locking up issue will go away.