Help, 1.5TB Western Digital Green cannot be recognized by Thermaltake Blacx


#1

I just purchased a Western Digital WD15EADS Caviar Green 1.5TB SATA 32MB Cache 3.5IN HD and also an external docking Thermaltake Blacx. The docking seems not able to recognize the HD, but if I use an internal USB 2.0 enclosure (NexStar 3), either WinXP or Windows7 don’t have an issue with finding the HD.

If I use other type of SATA HD on the docking, they get recognized pretty easily, it is just this new HD that I am having trouble with.

From other forums I have done things like setting the HD speed limit to OPT1 and other things, but it does not seem to work.

Is this a firmware issue as some other people have got the same HD working on the docking station.


#2

Hi,

I haven’t played with one of these myself.  I use a  Generic Adapter . But yours looks nicer :smiley:

I assume the dock appears under disk drives when connected without a drive present…??

Is the drive formatted now?  And when you do have everything connected, does it appear in Disk Management?  If yes, can you assign a drive letter?


#3

The drive is formatted already in the factory format. When I connect it to the Blacx it does not get recognizeod, the enclosure will be shown as a windows device, but no HD, but as I soon as I plug it to another external USB enclosure it recognizes it and I can go to ‘Disk Management’ to change drive letters. I have also done ‘quick format’ in Windows7 with no issues, just that the bugger won’t be recognized in the thermaltake enclosure. I could try to do a full format, but that will take forever… so I don’t think that is the issue.


#4

I’m having the exact same issue with the same drive and the same thermaltake blacx box, except on a mac. Wish WD had a solution. Last drive (1.0) TB worked without problems.


#5

Maybe the 1.5TB is beyond tha capabilities of the thermaltake blacx box.


#6

I had the same problem. Windows7 did not recognize my WD 1.5 TB drive. Win7’s disk management program did see the drive. I used the disk management program to create a simple volume and did a quick format. That worked.