Hello fellow WD community users and experts. Please take this poll

Please take this poll.
Q: How familiar are you with adding multiple users with import users list file, and/or import groups list to manage things like users (user name), passwords, quotas, shares (read-write), shares (read-only), shares (access denied). Also similarly, how familiar are you with adding groups and managing them with the import groups list file.
Familiarity scale from 1 to 5:
1- I am not familiar with import users list text file at all, and never would use it;
2- I messed with it once and couldn’t get it to work so I gave up on it.
3- I got it to work somewhat but couldn’t get it to manage the shares, so I gave up on it.
4- I am pretty familiar with it and got it to work, but I rarely use it, so I kinda forgot how to use it.
5- I am very familiar with it, and it’s very useful in helping us manage and set up users and shares with their permissions.

So whatever you answer, please explain your situation.
Thanks for taking the poll.

I started a related topic placed under various devices, under the OS 5 NAS, and under the Home which basically explains that I am not getting it to work, and I wish there was someone here who had success with it. I hope this reaches some people here. I am guessing that perhaps folks posting under the MyCloud Home category might answer this more often than here, because perhaps Home users are more prevalent, and NAS users in work environments keep their secrets to themselves, or they don’t have time to share here in this community, I imagine, because I have not gotten much response with my issues in this WD Community, and I have not received much help, only been directed to place my issues and questions to WD Support, which I already had done months ago, and going by the voices I hear when I call WD Support, it seems to be populated by team of technicians in some far-away city in South Asia, sorry for my generalization and assumptions, I may be mistaken, for they might all be located in Silicon Valley California or something like that.

I have been in contact with WD Support through a case that I started back in April 26, and I get the impression that none of their dozen or so technicians knows how these import files work because they have never bothered to learn to use them. I have had emails back and forth with WD technicians Vincent S, Steve Y, Sophie G, and Robert C, and others, they are all doing the best they can but it sounds like they never get anyone with these issues and so they know nothing about it. That’s why I am requesting anyone who reads this to take this quick survey and tell me honestly how much experience you have with using import files to manage the users, shares, and groups.

Thank you,
Om Ah Hum,
Jairo Jamyang-Pawo Moreno
in Winter Park Florida.
Working for EWI, a construction subcontractor with scopes involving EIFS and related wall applications on commercial buildings.

Hi @jairowd,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:
https://support-en.wd.com/app/ask

Dear Keerti,
Yes, I have already opened such a case at WD Technical Support, at Support | Western Digital, since April 26, and it has generated quite a bit of response from their expert technicians, but I get the impression that no one there knows how to use it, as there has been no thorough investigation carried out to test the software to see if the importation and application of the administrator-created user list text file [and, similarly, of the administrator-created group list text file] to manage the users, shares, and their access is working correctly. It is as if nobody in WD Support knows how to use this function, a function and feature which should be considered a pretty convenient feature, as it provides instant settings change to the permissions. I venture to say that the Synology NAS OS doesn’t have this useful feature, but the MyCloud does have. This capability that MyCloud has, and Synology doesn’t have, is that with a text file that the administrator composes with seven parameters per user, the administrator is able to manage the permissions that can be given to the users as to whether any share is accessible to the user, and whether a share is accessible as a read-write folder, or as a read-only share, or, a folder blocked from view, that is, as a denied-access folder. Now of course, all of these settings can be done manually, one user at a time, but for a typical ten user network, there may be a need for 30 shares, so one would have to go through 30 shares per user to set them properly. So, wouldn’t it be nice if I, as an administrator, could do it all with a file containing a line for each user, with the user’s name, password, groups, read-write folders, read-only shares, denied access folders, and guota (storage space alotted to user)? Well, the MyCloud OS has that in the process of, first, composing a text file [I think of that file as a permissions configuration file], and, second, uploading and applying such a file to the users and shares, at the Users Page in the Dashboard. And the results could be verified in the Users page and in the Shares page at the dashboard, by going through each user and each share, one at a time.

At the place where the administrator uploads the text file that does all the magic, an example file can be downloaded, and that explains what order and how to separate the parameters. Here follows that example file:

#Input a user’s information in the following order and separate them by TAB, and the group and share must be created and existed.
#user_name password join_to_groups shared_name(rw) shared_name(ro) shared_name(deny) user_quota
#username pw g1:g2 share1:share2 share3:share4 share5:share6 0:0:0:0
#user quota settings: user quota not set or 0, quota = 0; user quota <= group quota, quota = user quota; user quota > group quota, quota = group quota

The only problem is that the only line that sort of is the closest to an example is the line: #username pw g1:g2 share1:share2 share3:share4 share5:share6 0:0:0:0

And yet, this line won’t work until you remove the #, perhaps the # was what used to work, until they made some change in the MyCloud OS when going from version 3 to version 5. But then they never made any update to the documentation. And also a true example would require a password of 8 characters or more, so the example given won’t work, as pw is only 2 characters. Also, the last parameter for quota setting, I have tried many possible and reasonable values, but the only value that worked for me to get 20 Gigabytes set for a user was to use a value of 20000:0:0 instead of what is given in the documentation as 0:0:0:0 for unlimited storage, but I don’t want that, so it would seem reasonable that 0:20:0:0 assuming that the place where I have the 20 is to set gigabytes.

The documentation, in my view is simply incorrect and caused me much waste of time, as it is, because what I have found to work is that the parameters must be separated by tab character, while the documentation says something else, that the parameters be separated by /. And you can check for yourself at My Cloud OS 5 Online User Manual (wdc.com)
Not only that, but the quota parameter won’t work as given in that help page. It says that to set quota to use 0:0:0:0 for unlimited, that may work, but what if I want 20 GBytes? Then, you would think 0:20:0:0 where the first position is for Terabytes, and the next position would be for Gigabytes, then megabytes, and finally kilobytes. But what worked for me was 20000:0:0 and that gives me 20 Gigabytes. So I should complain to WD Support until they update the help documentation page.

So what I am trying to state here is that I am very familiar with this feature, but I haven’t gotten it to work, and I get the impression that there is a bug in the system. I am assuming that there is a bug, because from what I gather from all my trials and errors in trying to get this to work, is that there may be a bug. I have told WD Support to investigate and test to see if there is a bug. It would seem like WD Support, given my reporting of a bug, would elevate and escalate this to a level where they would call on their best software engineers, perhaps even the engineer that was responsible for the feature to work on it and fix it. If it’s not a bug, then there may be something in my text file that would cause it to not work correctly.

One thing that I haven’t tried is to compose a complementary import group list file and import it and apply it at the Group tab page. Such a file is supposed to make it easier to manage shares by placing users in groups. And then all users in a group would get certain permissions all at once.

Thank you Keerti. Yes I have reached out to WD Support. I reach out here to see if any other users are having this experience. Or to see if anybody here is confident in using these import files.

Injoy your day,

Jairo Jamyang Pawo Moreno
Orlando Florida.

I never bothered as it is only me and my family. I turn off Cloud Access and block ALL ports at my router. Much much safer and much much faster as no indexing!!! I do use long password (14 character randomly generated password) to access data.

Thank you thetick.

I have a NAS that has operated under OS/3 and OS/5.
I have not tried to use something from the “HOME” line; but I believe the software is sufficiently limited such that I would not TRY to manage multiple user accounts with that product.

In OS/3 and OS/5; I have created/managed multiple user accounts using the dashboard interface only. Seems to work well enough. I have not tried to manage accounts using text files.

I am under the definite impression that if you have a business that requires a file server and 30 accounts. . .you probably need a more robust system than what WD provides. I am surprised the functionality you seek is not a feature of the Synology NAS’s. . .but to be honest those are also more “prosumer” level rather than “enterprise” level devices.

I am not overly surprised that the documentation is goofy.

I have to imagine that there is a text file somewhere that has all the settings for the users. . . that the dashboard would write settings to the file. . . .and that you can use that created file as a template for what you want to do?

Thank you for your thoughtful response. I get that perhaps I am doing something beyond its ability. And yet I have almost cracked it through trial and error, I have managed to overcome its limitations. And so what follows may not interest you but it may interest someone who wants to manage 4 or more users and shares. Keep in mind that when I create a user through the import file, I give a line per user, and then by blocking access of one user to all other users, in effect I have turned that user into a folder or a share. That’s why it’s important that I be able to set the permissions of a user to share by denying it access to all created users even itself. In effect I am able to multi-purpose the role of a user, I can turn a user into a share by denying it access to everything else. But then I can specify who [what real user] gets read-write read-only or denied access to that share.

The main thing that I learned is that I have to run the file twice to set the accessibility defined correctly as stated in the import file. I compose the import files on spreadsheets and then copy paste them into text on notepad. That creates the required tab character separation between parameters. And I also have to incrementally add the users in stages. I first start with an import file I name something like stage 01, because I will be creating a stage for each additional user or share until I get to about stage 21 or more to create some 17 users and some 6 special team folders as shares. The first stage I can get away with creating two users and six shares for a total of eight lines

I import stage 01 running it twice, as I have learned through trial and error that the permissions won’t get set correctly until the second pass… I have to import on top of that stage 01 import file, an expanded version of that file, named stage 02, that expands the number of users by a small incremental amount of users [best if only increases by one user, and one share] and shares and associated accessibility. In other words, from stage 01 import file, to stage 02 import file, I will add to it one more user, one more share, and I have to describe the accessibility for that user, while for the other user, I deny access to the new user, yet allow read-only access of the new share to the other user.

And so the second stage not only increases by one user and one associated share, but it also increases the items in the three parameters dealing with read-write, read-only, or denied access permissions respectively.

In the same manner, I create each stage, making the next higher stage a little bigger than the previous stage in terms of users, shares, and special folders, usually by one user, one associated share, or one special folder and its associated share.

After I have created all the import files, I have to make sure that when I import the files in stages, that I run each stage twice before proceeding with the next higher stage. I have created six stages that work so far, if they are entered in the stage sequence given, first I import stage 01, running it through twice, then I import stage 02, running it through twice, then I import stage 03, running it through twice, and so on, until as many stages as I need to create all the users [and configure the accessibility to their shares] that I need.

As I showed in the video that I uploaded to YouTube at the shortened link WD MyCloud NAS: Steps involved in adding users in stages: Screen recording and Word text to voice - YouTube I was able to get six stages to work. On the seventh stage, I noticed that I am getting some errors that I am troubleshooting now.

You run seven stages TWICE. . . .and have errors at the end?

Dude. . . it’s 2022. It shouldn’t be this hard. There is way-way-way too much fiddling involved here. The software is clearly broken.

And something is bound to break your process sooner or later. Then you will have a mess.

Thanks NAS user,
I am learning through trial and error and experience. And I am suspecting, or at least it seems to me that when going from one stage to the next, I have to make sure each stage is incrementally increased by two shares and no more than two, perhaps because when attempting more complexity than that, there’s a greater chance of error. But after I prove that a stage works, I can skip all previous stages to get there. That means if I know that Stage 09 works, then I can go from a stage 0 where there’s no users, no shares, which can be obtained by deleting all users and shares, leaving a clean slate, except for the admin user and the Public share.

When there is an error [that is, an unexpected result] after the running of the file, then I have to suspect a programming error, in other words, my error, the error caused by my composition of the file. From that point, I troubleshoot, I look for possible causes for the error. This is a painstaking process for me because this tool does not come with debugging tools, so there are no error messages to give me hints as to what the problem might be. Unless the error is very basic where the system detects something that is not allowed. The system only takes whatever is submitted to it, and it produces some output, usually new users and shares, or the users that were there get new rights to shares. In other words, garbage in results in garbage out, I must assume whenever the results turn out not what I wanted or expected. Sometimes it’s very obvious that things went bad, because the access to shares go from read-write, read-only to access denied, or even to public. So, to troubleshoot, I have to go through each user and each share to see if what came out makes sense and is what is described in the import file, which could have been called a “configuraton” file, but it’s not really a configuration file, it’s more like a definition file, a file that defines the users and shares and their permissions. The more common sources for strange output results could be where I repeat an item more than once, unnecessarily, in one of the parameters involving setting the permissions, or where I misspell the name of a user, or something like that, but sometimes even those kinds of errors may not cause much harm. And even when I do detect those kinds of mistakes and run the corrected file, overwriting the previous one, I sometimes don’t get any improvement. I had something like that to happen the other day, and so I looked carefully at the file I had submitted trying to find what might cause the strange output. And when I found one error, I fixed it and I ran the corrected file, but nothing happened, and so I tried deleting everything again to start with a clean slate, and then ran the file again to rebuild everything, and if that fixed everything then I kept the file as good, otherwise I would have to do some more troubleshooting.

I screen recorded my most recent attempt and managed to go from a stage 00 [a clean slate, no users, no shares] directly to a Stage 08, skipping all in between, and from there I went to see if I could go to Stage 09, with no wrong output.
So in the video up on YouTube I show that I apply the file representing Stage 08 and I proved that it does work, and from it, I built Stage 09, adding only one user and their share, and I got it to work, then from Stage 09, I built Stage 10 and got it to work, and so on, always keeping every stage and version of a file, both in its own spreadsheet and in the text file form.

However, Stage 11 failed and so I had to suspect that some error in my part was introduced in the composition of the file to cause that failure. So have to go back to Stage 10 file and from it rebuild Stage 11.

Here’s that running of stages 9 through 11 with the first two working but the last one producing some unexpected output. WD NAS Import user list 2022 07 11 20 39 51 stages09 10 11 - YouTube So that means I have to fix Stage 11.

At time 3:33 of that video, I show that I am about to upload the Stage 09 and apply it, but from experience in handling previous stages, Stage 01 to Stage 08, I know that after the first pass of any stage, in this case, Stage 09, the permissions would not be set for certain shares and/or users [and the ability to manually change permission was not available, as if the three possible settings were disabled, or at least inaccessible, and that’s because the share automatically remains left as Public, meaning that any user can gain access to it, and there’s no way to make a change for certain users unless you change the setting of a share from Public to “Private”] Therefore, I know that I have to run the same file a second time. So, after the second pass for Stage 09, everything gets corrected to per what was specified in the file, and the correct output may be seen some time after 3:43 where I quickly review the results of the second pass. And with such a clean slate, I simply run Stage 09 [twice] to get the desired users and shares and their permissions. I’m happy about that now. But I want to continue to see if I can get to Stage 20 or however many stages I want. I can’t simply go from Stage 09 to Stage 20 immediately, I have to go through Stage 10, Stage 11, etc, each one getting verified that it works. But once I get whatever last stage to work, I can use that as the first stage that gets all the users and shares for that stage created.