HDMI signal from WDTV Live Hub stopped working

Hi all, 

First time poster - so Hi! - and be gentle… :slight_smile:

I’ve owned a live hub for approx 3 weeks now and up until a few days ago everything was working OK via both HDMI and Component. I unplugged the machine to take around someone’s house (movies for the kids over the weekend) - and couldn’t get a picture from HDMI (well - only a rubbish pink overlay image of the start up screen - and then nothing).

I can still use the component plugs - but obviously the quality is not as good - and it’s not the point(!) So no HDMI (all I get is ‘no signal’ from that channel.

I’ve been reading many horror stories re: the WDTV Live box - and followed most of the fixes - to no avail.

Anyone else suffered this? Could it be hardware failure? Really disappointed - as I was looking forward to using this box (after a good few year use from a 1st Gen WDTV).

Sigh. Help!

Hmmm. The more posts I read - the more I feel this unit will need to go back to Amazon. 

I do wonder if I forcing a Firmware update might sort it - in which case I’ll look up how to do that first. In the meantime - if any of you long term users have any ideas - I’d be happy to hear them! :slight_smile:


Well - tried regressing the firmware back to Factory settings - 2.2.16, tried it, and each firmware release in between. No difference - TV say’s ‘Mode Not Supported’ (Samsung 42" LED).

Tried different cables etc - to no avail - and wouldn’t make a difference - as I believe ‘Mode Not Supported’ means that something was detected… … 

So - back to Amazon it goes. I’ll try one replacement. Quite frankly I am disappointed if you cannot unplug this device from a main TV and plug into a different TV (Panasonic in this case).

As nobody has got back to me here (is there anybody there… :wink: ) - I assume everyone else is able to move their Live Hub between sets at leisure without issue.

I sent the old unit back to Amazon.co.uk and was told due to a change of supplier it would be a month(!) for a replacement unit. No thank you - refund please… 

Bought it from another reseller - who amusingly sells via Amazon.co.uk for £25 less. Ordered and received next day. Bargain. No issues from the new unit (at the moment) - so can only assume the old unit was defective.

I’m surprised that no body else has experienced this problem. Ho hum.

Reading back through this thread - it looks like I’ve been speaking to myself. Which as nobody has replied - is true. :frowning:

Anybody there? 

Well, that shouldn’t surprise you.

It sounds like you experienced a specific type of hardware malfunction.

The fact that no one responded to your thread would imply that no one has seen that issue (which, again, would indicate it’s a very rare issue.)

So, don’t be insulted. :slight_smile:

Just experienced similar issue. I have had LIVE TV hub for about four months connected via HDMI to my big screen without a problem.

Today I have updated the firmware and had the LIVE TV hub plugged into different TV via composite and it worked fine.

Then when I connect  the LIVE TV hub to my big screen again the TV says mode not supported.

Have tried to isolate it by plugging other HDMI devices in via the same HDMI cable and same input on the big screen TV and they all work fine.

I then plugged the WD live TV hub in though same HDMI cable input etc and error message mode not supported displays.

However if I connect the TV hub via composite to my big screen the signal is accepted and displayed.

It would appear this definitely is an issue with the  LIVE HUB or the firmware upgrade

I have the WDTV Live Hub and output via HDMI. I noticed that after I upgraded to firmware version > 2.06.10, the HDMI signal output was no longer working.

I had not thought to check the output from the composite video and thought the unit was dead so I went through the whole RMA process.

Upon receiving the new one, I (stupidly), upgraded it to the latest firmware only to the face the same issue, except the HDMI was intermittent and the one time I did get the HDMI signal, I immediately downgraded the unit back to 2.06.10

I followed the info below to get firmware 2.06.10 which I know works for HDMI output. For some reason, all firmware versions that I have tried after this version have caused the HDMI signal to no longer output!


Firmware Ver. 2.06.10

I’m very surprised that WD has not found this issue with their latest firmwares. Perhaps they are not testing with HDMI output :slight_smile:

You certainly aren’t the only one with this issue.

My WDTV Live Hub was working perfectly fine until I took it away with me on holiday and started using it with other TVs.

No problem until I got home and plugged it back into my Samsung 40" LCD that it had been working on fine before I went way.

Now it won’t output to HDMI at all. I just get ‘no signal’.

Component video works fine. Other devices still output to the LCD fine in HDMI, so there’s no issue with the TV. It won’t output HDMI to my monitor either.

I’ve tried everything…firmware upgrades, rollbacks, cable changes, resetting the machine.

Nothing works and it’s driving me crazy.

What’s worse, is the warranty expired 2 days before xmas. It was a gift and I don’t have the receipt.

I’ve emailed WDTV for a warranty replacement. Hopefully they will come to the party or at least fix it for a small fee.

If not, I’ll be pretty disappointed.

Having read these forums, I’m amazed that quite a number of people seem to have had a similar issue with HDMI ‘no signal’, and yet there seems to be no response whatsoever from WD.

It seems to be purely ridiculous that you can’t freely swap the machine from one tv to another without a risk of this happening.

If it can’t be fixed or replaced, all I’m left with is a useless black brick.