HDMI Handshaking/Configuration memory issue

I have been using my product with no issues until this weekend, I took the unit away and plugged in to another TV using HDMI. It worked initially but after disconnecting and reconnecting, the HDMI out stopped displaying a picture. When I returned home, I plugged it back into the original configuration but the HDMI is not outputting a signal that my HDMI Matrix 4x4 box recognises anymore (it is clearly outputting something, because my Matrix switchbox switches correctly when the unit is switched on). If I plug directly into the TV - it works fine. So it seems to me that there is a HDMI handshaking issue??? Can you suggest a solution?


I have a similar issue, although with a different device. Try different combinations of powering on or off affected devices. Turn on the WDTV first, if it doesn’t output then start with the HDMI Matrix.

Hi there, thanks for your email. What I find bizarre is, it has been working flawlessly for a couple of years
it seems that by connecting to a different tv - the problem manifested itself. Looking through the threads here, it does seem to be a common fault. If I connect directly to the TV - the unit works ok Only by connecting to the matrix does it stop working. Having said that, when this problem first presented (when I took the unit with us on holiday) trying to connect to the TV where we were staying (after the first connection when it was fine) it would no longer receive an image from it.
Coming home - connecting direct to our TV works - connecting to the switcher doesnt.

Looking at the matrix switcher, I can see that it is receiving something, because it switches to the correct input when the unit is turned on and the switcher turns off when the unit is turned off… Someone else has suggested setting the HDMI out to 720p. So going to give that a try.

Tried adjusting the HDMI out setting… didnt work… reset device doesnt work either… I know the cables are all fine because they are the identical ones I was using before going away… but I changed them too… still not joy… it seems that connecting the WDTV to another TV has somehow affected the unit in a way that it will no longer output a signal that my Matrix Switcher or other TV’s will recognize… Very Odd

Does the manufacturer of the Matrix switch have a forum/support line? I’d try contacting them to see if they have any ideas - since the unit works by connecting directly to the TV, I’m thinking the fault most likely lies somewhere with the switch. I’m assuming you’ve tried different ports on the switch? Were the replacement cables shorter or longer?

Hi there, thanks for your email.
If you read all the thread you will see that the problem manifested itself by connecting the WDTV to another TV. The WDTV and switcher were working fine before I did this.
I have 3 other inputs into the switch all of which work fine. So it is something in the WDTV live that is causing the issue. Looking through lots of other threads on this forum it is clear that this is not that uncommon a fault… Does anyone have any suggestions???
One thing I may add, when I connected directly to another TV when I got home, I connected the composite RCA leads to the TV as I thought that the HDMI output had failed… then I connected the HDMI lead and the unit worked. So I am wondering if (even though the settings show that the unit is set to HDMI (Auto) the WDTV is outputting a signal via HDMI but not the full signal??? Unfortunately it is really difficult for me to run a composite cable to the main TV connected via the Matrix switcher. This is so frustrating… I wish I had never taken the stupid thing with us…

I did indeed read the entire thread and that’s why I’m pretty convinced the issue is with the switch (see below). From what I can see the switch works with the WD TV on one TV but not another. When the switch is taken out of the equation, the WD TV works without issue.

Do you have another device (not necessarily another WD TV) you can test the switch with and/or another switch you can test the WD TV with? Do you know the model and manufacturer of the Matrix switch?

One possibility I’m thinking here is that the WD TV is using one version of the HDMI specification (I don’t recall off hand which one we used but lets say HDMI 1.3c for example purposes), the switch is using another (for example lets say it was using HDMI 1.0), and the new TV is using a third (lets say (again for example purposes) HDMI 2.0 which came out (I think) almost a year after the last major model of the WD TV) - the switch could be having trouble “translating” the signal and could have an issue establishing a handshake with the TV running 2.0, wheras it doesn’t have an issue doing the same with the original TV (which let’s say was also on HDMI 1.3c).

Hi again,

Thanks for your email.

Yes I have other devices and tested with the matrix with no issues at all.
My point is… that the WDTV used to work fine with this configuration.
The problem only arose when I took the WDTV live and plugged it into another TV.

Whilst I see your logic re the different HDMI specs, it does not change the fact that the original config and cabling all worked fine up to the day that I removed the unit.

Clearly by connecting the device directly to the other TV, it has made some “changes” that are no longer compatible when using the HDMI matrix…

Am beginning to think the only sensible solution is to pull the plug and look at another media player.
I would also suggest you do a search on this forum as you will see that I am not the only one suffering from this with little success



I would be interested if anyone else who has experienced the same issues could shed some light on this subject.
Seems bizarre to me that by simply connecting to another TV has caused this.