HDD won't load, freezes whichever program that tries to open it

This is WD’s email to me after i filled in the answers:

I understand that you are facing issue with your WD Elements SE hard drive. I am sorry for the inconvenience caused to you.
I would request you to please provide us the following information in order to isolate the issue in a better manner:

  • What is the version of Windows or macOS you are using?
    Windows 10
  • Have you tried connecting the device with different USB cable/ports?
    Yes, tried different cables, different ports and different pc’s
  • Are you using any hub while connecting the hard drive to the computer? If yes, then please remove hub and connect the drive directly to your computer.
    No hub being used
  • Since how long you are facing this issue?
    Roughly 2 months or so
  • Is there any software or hardware update?
    No updates available
  • Is your drive recognized by Disk Management (for Windows OS) or Disk Utility (for macOS) after connecting the hard drive directly to your computer?
    Yes it’s recognised but as I said in my email, it shows up in dskmngr and my computer as Local Disk E: but as soon as i click on it, regardless of the location, the program freezes and won’t respond until hdd is removed.

WD takes over 24 hours to respond each email so i figured the community is probarbly alot more efficient. I assume their response will have more questions and that will be another 24 hours at least before any type of assistance. Any help would be greatly appreciated and im more than happy to answer any further questions

Hello Shboo,

I would suggest you to check the drive for any Virus or malware which might be freezing your computer.

I can’t access it with any program though, anti virus will read it but as soon as u click scan the program freezes and have to unplug hd to get it working again. I tried cmd ran as administrator and even that freezes