HDD waking up from sleep every hour

at least I got this
image

I tried everything, including turning off indexing and deleting every app, resetting etc., nothing really worked and my hard disks kept waking up several times a day and drive temperatures hovered in 35-40 range without any use. I picked up some commands from @dswv42 though I can’t recall the exact thread/post right now

/usr/sbin/restsdk.sh stop
/usr/sbin/otaclient.sh stop
killall ConnectivityService

My hard disks rarely wake up now and drive temperatures hover in lower 30s. I don’t use any apps other than plex occasionally which I turn off except for weekends (for some reason my hard disks never sleep with plex on though temp doesn’t rise). May be useful to someone fed up of getting their hard disks churned out for no reason by WD till they get their act together.

@htb Any ETA on when this issue will be fixed? You already have multiple users complaining about this even in the latest firmware.

I’m thinking about sending NAS to some youtuber to make review about new software that resolves waking up issue, and then return it under warranty. The information that the problem was solved in a given software version was a deliberate lie?

WD has lied multiple times on this. Release notes for at least 3 firmware releases claim to address this specific issue of hard disks waking up at random intervals. I recently brought a Synology and even relatively minor issues get a lot of heat so I’m assuming WD userbase is comparatively smaller and so may not be very attractive for a popular youtuber to highlight.

If I were in your place having the option to return my 8 month old PR4100, I would’ve without blinking. From where I stand, WD has given up on NAS, both from a hardware and software perspective.

mirge101 you fix the sleep mode ? You can give me instructions please ?

It’s a temporary fix, indexing and ota were the primary reasons HDDs were waking up randomly and turning off indexing in settings didn’t help. Only workaround is to end these processes through ssh (thanks to @dswv42), you may have to repeat these at every restart.

/usr/sbin/restsdk.sh stop
/usr/sbin/otaclient.sh stop
killall ConnectivityService

Now, HDDs wake up maybe once a day which is okay with me. As long as you don’t use WD’s apps, these will help your HDDs hopefully live a couple more years. Maybe someday WD will actually hire an actual engineer who will fix their severly broken indexing system.

Same situation here.
The problem has not been resolved. I installed version 5.10.122 but the wakeup/sleep cycle continues with nonsense. Many months have passed since the release of OS5 and still having problems of this type is really disappointing. To avoid damaging the HDDs I am forced to turn off the EX2 when I am not using it. I think I’ll be looking for another brand’s NAS soon.

Unfortunately I’ve tried also what you written here but nothing has resolved. As you said, I’ve tried everything but my HDD’s every 45 minutes or less wake up and stay active for 10 minutes and then again off…I’ve tried also uselessly to write to the support but after they asked to me the log’s zip they’re disappeared. Really really sad to see that the wd team doesn’t do nothing for this

Has anyone tested the new version of fw: 5.11.112? Does it solve the Wakeup-Sleep problem?

I don’t think so…

Hi. The new version 5.11.112 . The problem that wake’s up not only the nas hard drives but also the external hard drives that are connected via usb 3 remain when you have cloud access on. The hard drives never goes to sleep mode. But when you close cloud access the hard drives goes to sleep… but at random times for a little time of deriod the system wake’s up again the hard drives… let say about for 10 minutes and after goes to sleep again… I dont know if all this situation at os5 is normal… at os 3 the sleep mode was perfect…

I tried to update the FW to the latest version and I confirm what was described above by other users. The NAS restarts the disks several times per hour for no reason. Very frustrating and damaging problem for discs. The last try is to contact technical support hoping that it does not behave with other users, or without providing solutions. I will keep you updated.

This issue has always been there. I decommissioned my PR4100 to save my disks and data from incapable WD developers, still have an EX4100 which I use for offsite backup and turned on once a month.

I can understand a new software having bugs especially if beta period is rushed, what’s unacceptable is the issue remaining over several months and multiple firmware revisions. There’s still a way to move back to OS3 and everyone should move back to OS3 at the earliest before WD plugs that.

So this problem is not just about the My Cloud EX Series but about all the NAS that mount OS5?
If it is still possible to roll back to OS3 I will consider that option.

Thanks for your very helpful guide! If WD support won’t fix I will do the rollback.

Scroll up, this issue isn’t new and was reported in Nov-20. Several users have followed up via multiple channels and WD has claimed to have fixed this issue in at least 4-5 firmware releases. Anybody who places any value on their disks not getting crunched continuously should immediately upgrade to OS3 before WD blocks that route.

So seriously. . .any progress on this topic with the new firmware???

I am getting the impression that it is the same-old-same-old.

Hi: It’s my first time it this forum. I have the same problem: my HDD every hour more or less wake up. I done some changes and finally I found an answer. In my case, I had installed the android app “my cloud OS5” and I had activated the automatically backup option, to copy photos and videos to my personal folder. I have unistalled the app and for the moment the disk go to stand by without wake up again every time without reason. Could you try it and share your answer? Thanks to all.

Regards

This is the answer I got from WD support:
“We are extremely sorry for the inconvenience.
I understand that the error still persist after troubleshooting the issue. we are escalating the cases to the next level to assist you further.”

I don’t think we will have a solution anytime soon.