HDD(s) dropping from Media Library (but not player)

I have 3 x 6tb WD HDDs attached to my SMP - usually all through a USB hub attached to the SMP via the front USB port.

I have a 4th drive - a 3tb WD MBL NAS drive - in the Media Library.

Player set to folder view, so when I have the media lbrary on, and selected, if I go to videos I get 4 ‘folders’: the MBL first, followed by the 3 HDDs.

Recently the player has started dropping one of the HDDs from the library.  I’ve moved them round and it’s still doing it.

I go into Videos and one of the HDDs is missing.

But select ‘Local Storage’ as sourceand all 3 HDDs are there.  Back to Media lbrary and one is missing.  However, if I select the otherwise ‘missing’ HDD I get a message that there’s ‘no media in current folder’.

So, I’ve moved one of the HDDs from the hub to the rear USB port.  Delete all the media library files, etc, re-boot.  Everything shows up fine.

But then watch a film (the kids just watched Pixar’s Cars), press the home button, select videos again, and guess what?  One of the HDDs (the attached to the rear port, not one of the two in the hub) has disappeared.

Select Local Storage it’s still there.  Select Media Player and it’s missing.

Can anyone help?

I’ve had these HDDs attached like this for ages without a problem.  Why has this just started happening now?

Steve W

If you haven’t tried it yet, you can press the reset button on the bottom side of the WDTV. Check page 8 of the manual for the steps. 



I have the same issue, I have two different manufactured HDD’s One is a Seagate and the other is a Toshiba, both connected to a wall powered (AC) USB Hub and connected to the rear USB port on the SMP leaving the front port open to a wireless keyboard or thumbdrive. Upon starting up the SMP connects to both drives fine and work fine, after I shut it down (in standby mode) and later power it back up, sometimes the Toshiba drive will be gone. I have to manually unplug the power to it and then plug it back in then the SMP reconnects and re-compiles. The only thing I can think of is the Toshiba is some how going into sleep mode and not waking up maybe due to the SMP in standby mode. Most HDD’s go into sleep mode when not in use (built in timer) I’m not sure how to disable this function to keep this from doing this but I’m also afraid that the HDD should spin down when not in use to save energy and possible heat problems. So in other words, darn if you do and darn if you don’t. 


I don’t bother putting my SMPs into standby.  Really doesn’t save energy that I saw, so what is the point.  I recently got a WD drive to use with a non-networked SMP.  This drive “sleeps” after not being used for a while, and this occurs even without putting the SMP into standby.  As soon as the SMP accesses it again, the drive spins back up, with only a few seconds delay in response.  So, I would try leaving your SMP on rather than putting it into standby, and see if your drives spin down anyway.  If they do, then see if they spin back up when you start using the SMP to access them again (and without causing any hang issues).  While it certainly will save a bit of energy to have your drives spin down if you use them for only a while each day, the savings are not huge.  Note that some drive manufacturers have utilities available on their websites that you can get to change drive sleep settings, so you might explore that also.

By the way, I sorted the issue (I think).

I had to completely wipe the media library files from the drives and MBL, using both the player’s ‘clear library’ function and manually deleting them from my PC.

I think ejected everything turned the library off, removed the MBL from the library, full power down.  Re-connected the drives, switched on, waited from the drives to be found.  Library back on, wait for that to re-build.  Once done, add the MBL again to the library and wait for that.

Took absolutely ages, and I can’t do that every time I switch on and off, so hopefully the problem was a on-off, or at least pretty rare.

BTW, I tried all the above and didn’t turn the library off before the full power down, so it was on as soon as I switched back on, and the problem wasn’'t solved, so I had to do it again.

Everything appears to have been fine since, but it’s only been a couple of days, so I’m keeping an eye on it.

Steve W