HDD not getting detected sometimes in BIOS - WD20EURS


I bought a brand new HDD - WD20EURS as my old HDD was creating problems. I Installed Windows 7 and copied all my files from my old seagate HDD to this. Everything was fine for the first day, but today whenI restarted my system, WD HDD was not detected in BIOS. I tried unplugging the cables but did not help. Then I swapped the cable with my DVD drive, it worked but when I restarted again, it was gone. I unplugged, swapped etc. atlast it started working. Now it seems to be working, but not sure it happened. Can you please let me know what could be the reason for this? If you think it is HDD issue, the I may have to replace it at the earliest. Awaiting your reply.



i ran into this issue with the drive model number (my user name)

i ended up just RMA’ing the drive and that helped.

i went through this for about a year. this exact problem started from day 1

and i tell ya i went through some extremely weird measures to try and isolate the problem and never could.

to this day i don’t know why it was doing that but i do know other problems ended up happening quickly and gradually getting worse and worse…

From my experience i suggest considering RMA’ing your drive  (if you can ?)

you’ll probably get the usual response about this too…

Test drive for errors with DLG diag for example (can be used on a USB drive or from windows)

Check cables (this might help but i bet you will be back in the forum after a while saying …gues what)