HDD Locked

I was using Secure ATA Erase to permanently remove some files from my 1 TB WDC Blue HDD. But suddenly the power went out… when I again turned my system on. The harddisk was found locked.

I checked it using a linux live DVD executing the command hdparm, it shows that the drive is locked. I tried to unlock it… it was not possible.
The Output is a bit like this:

       Master password revision code = 65534
       not     locked
       not     frozen
       not     expired: security count
               supported: enhanced erase
       Security level high

I tried to format it again… but the drives shows I/O error… But the drive seems ok… its not harmed physically.

How to I unlock my drive… or remove the password… I don’t need my files… So if I need to wipe all files then its ok…

But show me a way to recover the drive.

The actual forum is in the link description

Even if there’s no “physical” damage, the hard drive could still have suffered logical/firmware damage during the power issue. There’s no “auto-lock” mechanism on WD’s end for internal drives. If it can’t be erased then it would be best to replace it under warranty.

I need to overwrite the firmware… Is it possible to write the firmware using the jumper pins? Can you teach me how to overwrite the firmware using the jumper pins?

See my drive isn’t even showing in the disk manager. but is visible in BIOS and Linux system…

Click for image of Disk Manager

The secure erase sequence requires at 3 steps:

  1. Create a dummy user password.
  2. Issue secure erase prep (this is a precautionary, but required step for secure erase).
  3. Issue secure erase with the dummy password.

If all 3 steps complete normally, the data will be erased and the dummy password will be cleared and the drive will be unlocked. Since you lost power, you need to unlock the drive with the same password used by the secure erase command, or re-issue steps 2 & 3 with the same password.

Hopefully, you know the dummy password or you find it in the documentation of the tool you used to issue the secure erase commands.

That’s the problem. I don’t know the password… then how to I wipe my drivee…

You need a program like HDAT2 for DOS or hdparm for Linux.
HDAT2: http://www.hdat2.com/

I personally recommend HDAT because it is easy to use. You will need a USB boot disk.
You can use Rufus to make one.
Rufus: https://rufus.akeo.ie/

Download HDAT2EXE_51.EXE and copy it to your boot-able USB disk that was made with Rufus.
Make sure to rename HDAT2EXE_51.EXE to HDAT2.EXE before booting.
All the functions you need are on the ‘Security Menu’ after you select the drive.
I recommend you unplug all the drives except the one your working on as to not mistakenly erase a good drive.

Good luck.

1 Like

HDAT2 doesn’t list any of my SATA drives… not even my SSD(which is working and I still use it for hosting OS).
There are lot of versions of HDAT@… so cant use it recommend something else… please…