HD drives only sporadically recognized by Win7


#1

I have a Caviar Blue WD5000AAKS 3.5" drive. Worked fine for about 3 years on a eVGA 680i motherboard. It was the data drive (boot drive was a 64GB Raptor). Then one day the motherboard stopped recognizing the Raptor. Reformatting and reinstalling Win7 didn’t cure the problem. I could get the drive to temporaily work by removing the clock battery from the motherboard waiting 30 mintues, replacing the battery and then rebooting. Then it’d work for an hour or so before once again failing and requiring another battery reset. I figured it was a motherboard problem so I got a new one.

New one is a Gigabyte P43-ES3G. Everything worked fine for about a month. But now, sporadically the OTHER hard disk (WD50000AAKS) disappears. Everything will be fine when the system is first booted up, but then after a variable length of time (5-30 minutes) nothing on the drive is accessible. This can cause a system freeze if an app is running that attempts to access the drive, or it may simply be noticable by opening Windows Explorer and noticing that the D: drive is missing. Neither a soft reboot or a hard (case button) reboot solves the problem. Problem only goes away when the entire system is powered down and a cold reboot is done. Problem then reemerges shortly after. I have set the energy saving options to “Never” power down in Win7 (it’s set to power down the hard drives after 400 mintues of no activity). I noticed in the WD Knowledge Base that this drive won’t be recognized by certain VIA and SIS chipsets, but this is an Intel chipset motherboard (P43), plus the drive is recognized initially at bootup, so I don’t think that’s the issue. I’ve reformatted both drives and reinstalled Win7 and still the problem has reemerged within 30 minutes of the reinstall. The only thing done in the interim was to download Windows Updates - so I doubt it’s a virus.

Are my HD’s just old and wearing down? I’d hate to buy a new data HD and then have the exact same symptom occur.


#2

Download and run the western digital diagnostic utility and see if it gives you any warnings and post the info here. If you’ve got Linux experience and can boot to a system rescue CD or similar post hdparm -i /dev/sda

hdparm -I /dev/sda

hdparm -i /dev/sdb

hdparm -I /dev/sdb

Each is a separate command and the I is a big i. Thats provided you’re still using the raptor as drive 1 and the 500G as drive 2. One thing to note, you said new board and install and the drives that exhibit this behavior seemed to switch. Did you swap the cables on them by any chance? Or have you tried replacing one or both cables?