Have to 'find' network settings every time it's powered up

Hi all,

I’ve replaced a WD TV with the WD TV Live, and have it connected via WUSB600N v2 wireless USB adapter to a Netgear WNR2000v2 router.

Every time I power the WD TV Live up (using the remote - it’s always connected to, and ‘on’, from the mains) the wireless network settings show correctly in Network Setup. I navigate to Network Shares (Synology DS201J in case it matters), pick a video and start watching. Within two minutes the video will freeze, and I have to go into Network Setup and ‘auto-detect’ my wireless settings to start it working again. The ‘auto-detected’ settings are exactly the same as those that are already set (192.168.1.14 IP, 255.255.255.0 sub-net , 192.168.1.1 gateway and DNS - pretty typical).

I’m on the latest firmware, my wireless network is protected (WEP) and I auto-login on WD TV Live (using the menu option in Network Setup).

If I ‘auto-detect’ my wireless network when I power on, the video freeze doesn’t happen.

What I can’t understand is that I can browse the Network Share and start the video - so the wireless is working. Why does it have to be re-detected? All devices have static IP and the DNS is working fine via my router (I’ve tried OpenDNS servers just in case, but it made no difference).

Any help or advice would be very much appreciated!

Touchstone:   Let me make sure I understand.

If you set your wireless IP configuration MANUALLY, you have problems.

If you set your wireless IP configuration AUTOMATICALLY, you DON’T have problems.

Further, if you set it AUTO, it assigns the same info that you were using MANUALLY?

If that’s correct, then I see a few issues.

You should NEVER, EVER assign a STATIC address that’s within the range of the DHCP server’s “Scope.”   It should be in a range of addresses that the server will never assign.

Can you confirm?

Sorry, it sounds like I didn’t explain the problem clearly.

I never set the configuration manually - I go to set up the Wireless connection (Network Settings etc.), choose Preferences (to pick up the SSID that’s already configured) and the WD TV Live checks the connection (IP, DNS etc. - three tests, all pass) and the unit says it’s all OK. The settings displayed after the network check are the same as those that were displayed before the network check.

The IP address assigned to the WD TV Live is fixed in the router (I’m using DHCP but have the WD TV Live’s IP address reserved using it’s MAC address). The IP address never changes - which, thinking about it, isn’t strictly a ‘static’ IP address. (Sorry - that could have been misleading in my original post.)

I have to repeat this sequence every time I power on the WD TV Live, or any video I chose to play will freeze after a couple of minutes.

Hmmm.   Ok, I follow you now.

So, try this.

Reboot, but do NOT do the connection test.

Try OTHER sources of video (You Tube, Media Fly, etc.) 

Does the problem occur there, as well?  Or just on Network Shares?

Your problem sounds familiar.   There was an issue reported a while back.   Is there more than one WORKGROUP defined on your network?

OK, I’ll give YouTube a go when I get home (tonight).

There’s only one WORKGROUP on my network, but the only active connections are the WD TV Live and Synology NAS. There are PCs, but they’re very rarely powered up and I don’t need to access them from the WD TV Live. (My Windows PCs have been superceded by an iMac.)

Can the WD TV Live survive without a workgroup configured? Should I clear all workgroup values (Synology and WD TV Live)? I don’t want to muddy the waters here but I wonder if this is contributing to the problem.

Of course I may want to share media off a Windows device in the long term… (sorry to be awkward).

Thanks for your help!

No, a configured WORKGROUP is necessary for the WDTV to “discover” the PCs that are sharing media.

Now, that does NOT apply if you’re using “Media Servers” as opposed to “Network Shares.”   DLNA (Media Server) has no dependency on Workgroup configuration.   That’s one reason some people prefer them.

What will monkey with the stability of a Network Share is if something happens in your network while watching a move, that forces a “Re-election” of a master browser.

In other words, if you’re watching a movie, and some other device in the WORKGROUP comes up (or goes down) and forces a Windows Networking recalculation, it’s possible the WDTV will get hosed.

Check in your Synology to see if there’s a setting called “Master Browser.”

There is on my Q-NAP, and I have it enabled.   What that does is force that device to win the election every time.    And since my NAS is powered on 24x7, it never has these issues. :slight_smile:

If you really want to dig into the nuts and bolts, you can run the test I highlight below (from a script.)

Run it BEFORE you start a movie, then run it IMMEDIATELY after it “Breaks,” and see if anything changes.

In other words, if your Master Browser is “X” before, and becomes “Y” when it breaks, then that could very well be the issue.

This is how to find possible problems with the Master Browser on your network, which will affect when and what servers appear on your WDTV Network Shares.

On one of your PCs, open up a “Command” window.

(In Win Vista and Win7, click the Orb, and in the search box, type CMD. An icon will appear above the box that says cmd.exe. Click it, and a Command window will open.)

(In WinXP, Click START, then RUN…, and in the box, type CMD. A Command Window will open.)

In the command window, enter the command “net view,” like this:


C:\Users\Tony>net view
Server Name Remark


\BIGNAS1 Big Freakin’ NAS Server 1
\MARS
\NEPTUNE
\WDTVLIVE WDTV LIVE
The command completed successfully.

In my example, there are four active devices that Windows has discovered.

Now, for EACH of those, issue the command “nbtstat -a (name)” for example:

C:\Users\Tony>nbtstat -a bignas1

Local Area Connection:
Node IpAddress: [10.0.0.157] Scope Id: []

NetBIOS Remote Machine Name Table

Name Type Status

BIGNAS1 <00> UNIQUE Registered
BIGNAS1 <03> UNIQUE Registered
BIGNAS1 <20> UNIQUE Registered
…__MSBROWSE__.<01> GROUP Registered
WORKGROUP <1D> UNIQUE Registered
WORKGROUP <1E> GROUP Registered
WORKGROUP <00> GROUP Registered

So, we got lucky here, the FIRST system, BIGNAS1, indicates that it is the master browser, since it lists the name …__MSBROWSE__.

You need to find out WHICH system is your master browser. If none of these steps work as described, then the issue is likely on your PC itself, and that will require substantial additional troubleshooting.

1 Like

Thanks again Tony … I’ll investigate tonight.

Typical scenario, though - the LAN will have the router, iMac and Synology connected. Wireless connections will include the WD TV Live, iPad and iPhone. The PCs haven’t been switched on in weeks, so I’m hoping it’s not an MS-Net problem.

I might power up one of the XP boxes tonight and have a look, although I’m wary of changing the environment - if I can find the same info using the iMac I’ll do that.

If Mac OS is indeed Unix/Linux-like, the command “smbtree” will get you the equivalent of the “NET VIEW” command, and more.

1 Like

Yep, so far I’ve found smbtree and a Perl version of nbtstat :slight_smile: Cooking dinner now; will reply back later.

Right - sounds like you’re on the button with the master browser suggestion. I’ve used the iMac to determine NBT status, and: With the NAS and an XP PC on the LAN, the PC is the master browser. Shut down the PC, and the NAS doesn’t take master browser status. (This test was just to see what the NAS does when there’s no master browser on the LAN. It’s the first time I’ve powered up a PC since I got the WD TV Live.) Power up the WD TV Live and, after a few minutes, it becomes master browser. I figure this is happening while I’m watching a video, and causing the problem described in my original post… The Synology does have a ‘local master browser’ setting, so I’ll enable that and carry out some more tests tomorrow. A big ‘thank you’ for pointing me in the right direction and opening my eyes to the tools I needed to investigate :slight_smile:

OK, some progress … booted up tonight and found new firmware; declined it to keep the test environment clean. With master browser enabled on the Synology, loaded up a movie and the Synology stayed the master browser, and the movie didn’t freeze. At this point I was feeling quite positive :slight_smile: So, I checked out the new firmware release notes, decided it was worth getting and went for the download via WD TV. The download got about 20% through and then the WD reported an ‘incomplete download’. Checked the WD TV - no network connection to anything. Ran Check Connection and everything was fine again. I’ve now downloaded the firmware and upgraded. After the upgrade nothing worked network-share-wise, so I’ve gone back to factory defaults and am now setting the unit up again. Fingers crossed!

You’ve got more problems than that.

Firmware downloads don’t use Samba; they use HTTP / FTP, which are “Reliable” protocols.

If that failed, your network is pretty bad shape to fail an HTTP or FTP transfer

You need to get back to the basics and see what’s going on with your Router / Cables / Switches / etc.

Indeed; I get your point. Perhaps I had two problems at the same time… Thinking about it, the only ‘unknown’ in the infrastructure is the wireless USB adapter I bought at the same time as the WD TV Live. It’s listed as compatible, but I’m wondering if it has issues. I’ll see if I can get my hands on an alternative and give that a whirl.