Have 2 x My World Books WD20000. Unable to access

Bought both drives in 2010 one for RAID backup of other. Used them on WinXP until 18months ago then Win8.1 and finally Win10. Until last week all was well and then my Win10 updated overnight and AVG Internet security updated to 2017 version. Now I can see both drives in Device Manager as hidden drives and in my Network as media drives but am unable to access them.
Obviously this is a total disaster.
Apart from going to very expensive data recovery has anyone succeeded in getting back into their drives?
I still have the old WinXP machine in the loft. Should I try to reconnect to that and then network the XP and Win10 computers and transfer. Any advice VERY appreciated.
I am very disappointed with WD at this point.


As a troubleshooting step, yes. Also, have you tried resetting the units?

Please check the AVG internet security options to see if that is blocking the connection with the drives.

Hello ERMorel

Thanks for advice. Been on holiday. I reset the WD My World Book units 4
times with increasing time periods. They worked after resetting for 30
seconds in the end. WD Discovery does not see them however.

Also had to Open AVG Internet Security 2017 :

  1. Double Click Internet Security

  2. Click Menu + Settings

  3. Click Components

  4. Select Firewall Customize

  5. Scroll down and select System Rules…

  6. Enable Windows File and Printer sharing (not sure why this is
    necessary but allowed both WD drives and the printer to reappear on my

  7. Click OK

Both operations were necessary to get my files back. Interestingly file
access to the WD drives has speeded up considerably.

The next worry is that I have been notified that I will shortly receive
Win10 Creator’s upgrade…