Has anyone tried to overwrite MyCloud NAS with Ubuntu Server?


#1

Has anyone tried to overwrite MyCloud NAS with Ubuntu Server?
And if so, is there anything important that I should be aware of before trying?
Or if it’s a bad idea, why? (I’m aware it would void the warranty, though.)


#2

Curious, why would you do that. Is there a remote access component in Ubuntu server that’s better than the internal image?

FYI, It’s well know that the software isn’t perfect, but if you are going to do that in the first place a raspberry PI2 with hard desk would have been a much cheaper alternative.


#3

Why? – Because I’d like to have a few things on it, and available, which MyCloud doesn’t support. ownCloud and Folding@Home (to run slowly in the background), for example. Also, it would be more reassuring to do updates on programs and packages, knowing that it wouldn’t break.

Another alternative I’m looking in to is FreeNAS with Webmin. But of course, it would be better if someone else - who has done this already - can provide any information.

Raspberry Pi – I’ve seen those configs before, and I really wouldn’t have a clue where to begin. Besides, I’ve already got the MyCloud, so that Pi thing would just be extra money.


#4

ownCloud seems interesting. To be honest I’ve been tempted to do the same thing for a while because of how slow and dysfunctional my drive became, but after spending hours with support we discovered that my MyCloud had a hardware issue. After It was replaced it wasn’t as bad but still slower than I’d like it to be because of the indexing processes.

Did you get around to installing Ubuntu? If so it would be great if you can share any instructions


#5

It should be worth noting that the processor (apparently a Mindspeed Comcerto 2000 (M86261G-12) dual-core ARM Cortex-A9 Communication Processor running at 650 MHz) used on the My Cloud isn’t that powerful, nor is there a large amount of RAM or flash memory on the My Cloud (supposedly 256 MB of Samsung K4B2G1646E DDR3 RAM and 512 MB of Winbound 25X40CL flash).

There is a repository of programs can be added (more or less) to the current V4 firmware: Repository with software worked on v4 firmware

For OwnCloud on the My Cloud, see the following two links…

https://community.wd.com/t/owncloud/91818

https://community.wd.com/t/guide-owncloud/92080

See this link for Clean Debain and OpemMedia:

https://community.wd.com/t/clean-debian-and-openmediavault-on-wdmycloud/93714

Or do a search (magnifying glass icon upper right) of this subforum for the word “[Guide]” for several other discussions on programs added to the existing My Cloud firmware (or replacing the My Cloud OS).


#6

If you are still quite new to all these, I don’t suggest you try transforming MyCloud into something else that’s not supported risking having a paper weight in place to unbrick.

If you want to try OwnCloud, look for my webhosting installer thread. I have OwnCloud v8 running on the v4 firmware. And personally not yet released to this forum due to various testings, I’m using PHP7 which has almost twice the speed of PHP5 very noticeable even on the MyCloud Dashboard and Wordpress I have running on it.


#7

I haven’t yet. I’ve headed over to mother’s house for a late New Year celebration, and been setting up four of her old computers to do the same thing, when I could pull away from the family for a little bit.

It sounds like other people have already created guides; however, if there’s anything I feel obliged to note, I will do so and let you know.


#8

Very well; bookmarked. Thank you.


#9

The forum links provided by @Bennor above, and the tips provided by @Nazar78, as well as a few other resources, have proven to be helpful.

While that third link by Bennor provides images, some of them are previous versions; updated OpenMediaVault OS is tracked by their website, which links to their SourceForge host. Their website is here: http://www.openmediavault.org/?page_id=77 (Choose ISOs, and write the ISO to a flash drive).

What benefited me was plugging the WD drive into a desktop PC, and booting from the USB that way. I was able to get past some annoyances. (My own hard drive to USB cable wasn’t working properly with my laptop.) Since I’m at my mother’s house - who happens to have a PC tower - I just plugged the WD drive into her tower, and ran an ethernet cable from the tower to the router, to ensure all packages would update properly (in case her tower’s wi-fi chose to act up).

Also, found this thorough YouTube walkthrough. https://www.youtube.com/watch?v=3NiZ5_l_jgk It’s a year old, but it still applies, and is very similar to the updated OS. I followed it step-by-step to prevent missing anything.


#10

For the sake of clarity, and for those who come later seeking answers to the same question, according to the FreeNAS.org site, FreeNAS does not support ARM processors, but OpenMediaMediaVault supports the ARM architecture. So, FreeNAS doesn’t seem to fit the bill for my purposes as I have an EX2 which has a Marvell ARMADA 370 (MV6710) (Single Core ARMv7 @ 1.2 GHz) CPU.


#11

Debian available for both “MyCloud” devices (Gen1/Gen2).
Debian and Ubuntu available for Mirror’s (Gen1/Gen2).
Possible to port almost all arm-based OS to our devices (Most of them have Armada CPU, that have support in latest Linux kernel). Few devices have Celeron or Atom processors, so possible to install anything, include Windows server or XPEnology!

All, what i have / what i done is here: My file archive (Mirror)


#12

Looks like you have been busy, but I see there’s a pay-wall in effect, so that means we can have the software, but no information on how to use it, until we contribute.

Is that correct or did I miss something?

Terence.


#13

I upload to my website only critical materials and how-to’s. If someone not understand what he want/what its works - don’t try.
Everything needs a basic linux knowledge.

  • Donations on my website - only for “Say thanx for work”, not “Pay for work”.
    But i have no desire to rummage in this garbage any more.
    Maybe sometime i make better firmware (Based on OpenMediaVault), but for now - i done.