Has anyone successfully recovered data from a WD 750gb Passport Drive with a failed micro usb pcb?

Hi,

I have a WD 750gb Passport SE that has failed with what looks to be the common micro usb problem. The drive cannot be recognized at all when plugged in. I can hear the drive spin up, activity light work etc etc. I have tried all other means to connect it to multiple PC’s and OS’s, rescans, new cables, computer management, diskpart and some low level usb analysis tools but to no avail. Nothing can see the drive. The usb seems to be cactus but the drive ok? This gives me a glimour of hope in getting something back. Rather than rant on about what standard I think the product is and how portable is actually is without failing, I would like to know what steps I can do to get my data off and move on.

Does anyone know if there is a way to by pass the micro USB on these drives OR can I replace the existing PCB with one from a new drive? Can I do it without destroying the original drive? They are cheap here at the moment so sacrificing a new one would be of no issue to me to get my data back…

Has anyone successfully recovered a drive after the usb component has failed? Has anyone heard of successful recovery on one of these drives by recovery experts (and how much did it cost in total?)

Just noting that I have the new style of WD Passport Drive.

Thanks in advance.

I don’t think the boards are that interchangable. This guy fzabkar seems to know the most in that area.

Joe

Recieved some quotes from data recovery experts with prices varying from $800 - $2000 AUD to recover the drive. Quite expesive considering the drive iss till working and only the usb connection has failed. Anyone know the pin outs on the drive or have a proven method of by passing the usb component and directly attaching to sata? Thank you.

Did you try a pm to fzabkar? He’s probably the only one here that really knows the electronic part. He helped somebody  that broke off the USB port convert it to something else to transfer data off. He’s helped a lot of people with fried drives too. You might get lucky with another drive and it’s board but they change those boards quite a bit.

Joe

Hi,

Same problem - my micro USB component also failed inn passport elite. Got replacement PCB (from my passport essential - pretty similar) - resoldered two firmware chips (two 8-legged chips) from the old drive. Now drive suprisingly shows encryption, SEs device has dissapeared and every time I try to unlock it it says - “too many attempts, please erase the drive …bla,bla bla”. Of course unplugging and plugging again, changing USB port or changing user doesn’t help - I really tried hard. Can anyone help me with this issue? I’m getting really frustrated with this issue, trying to recover my files.

Really liked WD for its quality and reliability before, but now I think that, what they’ve recently developed (rubbish micro-USB connector idea, stupid hardware encryption etc. etc.) serves only to data recovery industry, not customers. In one word, ■■■■.

1 Like

MattZet - Thanks for posting your experience about changing PCB’s… It doesn’t look too good with the encryption still being there. I wonder if it would have been the same with the exact same drive type PCB? Could you actually see the drive after replacing the PCB? Would software recovery tools be able to recover the files from it?

Anyone else had any other experiences? Successful or not in getting any of their data back off these drives?

Just a thought…

You may need to move this chip from old to new PCB. And you’ll need special tools and skills for this. Besides, this chip should in proper working order.

Good Luck… you need that!

Mabikay - SLK

PCB.jpg

1 Like

Hi,

I think the problem lies in two encryption chips. The small one - near USB connector is responsible for decrypting data to USB connector, which is previously encrypted with the bigger chip (that one marked on the right side) - it’s the one, which is responsible for decrypting data from the SATA drive. Well, I removed those two 8-legged chips from the old PCB and put into the new one. Didn’t help

I gave my PCB to the repair shop to try to resolder those two encryption chips to my new PCB> See if it’ll help. Will keep you updated original.jpg.

check to see if Disk Management can see the drive – if it can at least see the drive, then chances are it is not a damaged drive and/or cable or a power issue –

the probable cause is that the partition table somehow got screwed up – use some sort of partition recovery program and that should get your data back

Have a similar problem with a 500GB drive. Day before yesterday the drive was fine, it stayed connected over night, and in the morning I couldn’t access it anymore. Any application that tries to access it freezes for several minutes to then spit out a message “Cannot connetct to drive E:. Wrong parameter.”

This is usually a sighn that the disk is dying, right? So I started out to try a data recovery. For a two month old disk that was NOT carried around a lot not much of a lifetime, BTW.

I opened the housing to see if I can connect the drive via SATA instaed of USB. I haven’t sen anything like this before: the USB3 port is soldered onto the controller platine, and there is no SATA connector- not what I expected…

I triedg to recover the partition using TestDisk. After ruuning for 5 hours it had scanned about 1% of the disk, and it reported a read error “Read after end of file” for every single sector. Yesterday evening PhotoRec found the drive, and I let a recovery run over night, but it didn’t locate a single file!

Any other tool I used didn’t even show the drive, and it is mfound onlky sporadically by those two, either.

I am sure the data has to be still on the disk, and that either the USB port has a problem or the partition or index is shot.

But it seems that not only the physical HDD design is propratory, but somehow normal deep inspection and data recovery techniques that used to work on other disks just fine seem to fail on this one for whatever reason :frowning:

Does anyone have an idea how to go about a low level file recovery on those kind of disks? Am I missing something? Is there a special tool from WD to help recover data from a shot disk?