Hard drive works on blueray player but not on laptop

My 640Gb portable hard drive just stopped working during an anti-virus scan with Avast and the whole laptop freezes up so I need to force to shut down the laptop using the power button. Now eveytime I plug in the hard drive, window explorer keeps on loading and the drive letter doesn’t show up. I look in Disk Management and it keeps on loading forever as well.

Whenever I unplug the hard drive, window explorer works again and a table come up tell me to format the hard drive but now it is already disconnected.

When it is connecting to the laptop, the light on the drive is blinking and I can hear it spinning without the click noise.

This is what I have tried:

  • Change the cable, no help

  • Change usb port, no help

  • Change operating system window 7, vista, xp and ubuntu, no help

  • chkdsk and WD data lifeguard diagnostics, no help (chkdsk can’t see the drive and WD tool stays frozen)

  • Some data recovery software but all of them freeze up.

Now is the weird thing that when I plug the hard drive in to my Samsung blue-ray player, the player actually recognises the drive, I can see and access all the folders. Eveything is still there.

So I strongly believe that I can still recover my data  but now I can’t access it by using computer. I got many years of photo and work document in it so can someone please suggest a solution to this. Thanks.

My laptop is Acer Aspire 5755G i5, 8Gb of Ram and is running Window 7 Home Premium. The portable hard drive is more than 2 years old.

Search for a data recovery software online

after recovering you can try to format 

I tried many of recovery software already. All of them just freeze and taking forever to load. The drive doesn’t show on My Computer, Disk Management freezes but in the safety remove, I can see the Local disk I (but in grey in which I can’t click in). Any help?

In this situation is best to contact a data recovery company