Hard drive worked now it wont work on gen 2 but works new plus


#1

hi, i love my wd tv live but i need some help.  It worked with my samsung 2.5: hard drive, then friend used it on his mac and formatted to fat32, suddenly the gen2 player would not recognise it.  I converted it to ntfs but still nothing, it says no media found but when you eject you can see its picked it up on usb.  The strange thing is it works with my new wd tv live plus no issues.  Please help, want to give hard drive and gen 2 to parents to use but cant if it wont read the drive.

any ideas???


#2

Hello,

Do you have experience this issue with any other drive?


#3

   No , but what i eventually did was format it fat32 (not easy would not accept exfat or when I reformatted to ntfs), used a friend’s mac to format it.  Now it works.  will be a bummer when I want to copy large files but will have to just use the other hard drives.  it is a samsung hard drive.

do you have any idea why it would do this, when it reads other hard drives formatted ntfs?