Hard drive size changed


#1

I tried formatting my 1 TB portable to fat 32 to use on my ps3, and now it says the hard drive size is only 32 GB.  How do I fix this?  Did i ruin it?


#2

It sounds like you formatted the drive using an “allocation unit size” of 16KB. That would leave the drive with only 32GB usable storage when formatted.  Try changing the allocation amount when you format the drive. FAT32 will yield up to 8TB.


#3

Try using something like this to format  http://www.partition-tool.com/  maybe it will be easier.

Joe


#4

Okay, you cannot use Windows format utility to format larger drives above 32GB. For this you need third party formatting utility.

Command line version is available here. [Free] Read the info on that page. A GUI version is also available there [Free] 

http://www.ridgecrop.demon.co.uk/index.htm?fat32format.htm

Mabikay - SLK

  

Warning: Since you were not bothered to indicate your external drive model, I had to assume it could be either My Passport Essential / ES USB2 or USB3 version with 1TB.  I strongly advice against using these drives for PS3 data storage with FAT32 formatting as it is not designed to use in that way. In another words you’ll be ruining your drive within one week / month or so. And you cannot copy larger files such as movies with 4GB and above to FAT 32 partitions.

Note: Click the Kudos star to say thank you for helpful posts. And be sure to come back to click the ‘Accept as Solution’ button for the post that solved your issue.