Hard drive not detected in BIOS but when using external USB-SATA

Hey guys,

I got a little bit of a weird issue. I recently acquired a used cable receiver. Well, sadly it is busted so I took it apart in hopes of using at least the hard drive. In it is a WD10EURX drive. It is working flawlessly when it sits in my external USB casing.

However, as soon as I try to mount it in my computer it is not even recognised by BIOS. I already tried switching SATA cable, power cable and SATA slot. Nothing changed. Connecting an old dvd-drive using any of the cables or slots works flawlessly and is recognised in the BIOS. Also tried swapping the new drive for my “old” 1 GB WD Blue, not working there either. I already tried using a jumper on the drive in slots 1&2, 3&4, 5&6, 7&8 and 5&6 + 7&8. Has anyone any idea what the issue might be? Using an Asus Z-97 p motherboard.

Hi FishDa,

Maybe you should try contacting WD’s Technical Support about this.

To Contact WD for Technical Support


The link below will allow you to call support.

I was in the same boat. Moved all of the files off of the 1TB WD RE4 & used DBAN to wipe the drive.

Once that was completed, could be seen again in Disk Management on boot. Be sure if one tries this, to remove SSD (if used for boot drive), including NVMe types & any other USB drives other than the one with the bootable DBAN ISO (using Rufus).

When DBAN boots, be sure to type autonuke at the prompt, will take around 12 hours per/TB to run. Nothing will be recoverable, why it’s imperative to save any files desired. Even powerful forensic tools will not be able to get any meaningful data from the drive.

Normally, I run this on a CD, because the tool loads into RAM & can be ejected, yet I’ve not installed an optical drive in this PC & likely won’t.

Good Luck!

Cat