Hard disk slow to be recognized


#1

I’ve got a WD Passport 160GB that was working fine with my WD TV HD. I’ve upgraded to a WD TV Live now and I’m starting to run into a problem: When I turn the unit on, it sometimes takes up to 10 minutes for the hard disk to be recognized. Sometimes it tries to access it and fails (flashing USB light) but other times the USB light doesn’t even start flashing and the WD TV Live doesn’t seem to start searching for USB devices for several minutes.

Nothing changes if I unplug the drive, put it in the other USB port, remove power to the WD TV Live, etc etc.

Unlike the WD TV HD, which keeps the HDD on even when the WD TV HD itself is turned off, the WD TV Live turns off the HDD when it shuts down. But it sounds like it just cuts the power rather than spinning the drive down gently first. I’m wondering if this is damaging my HDD or causing some kind of problem that prevents it from being recognized.

I used to think that having the HDD turn off would be a good idea, but I think I’d rather have it powered up but spun down now.

Any suggestions? Should I try deleting the database on the HDD?


#2

Same error here !

I updated it to firmware 1.01.17


#3

i don’t know why but some times happen to my WDTV live.


#4

This could be due to several problems.

1. If the interface cable is intermittant (i.e., a loose one) then the drive might be disconnecting randomly.

2. If the drive has a lot of defects, then it will be retrying the defective sectors and consequently be slow.

  

I’d recommend checking your cables, and also downloading WD’s WinDLG to check the drive to make sure it’s okay.  DLG Diagnostics only works on XP and Vista right now though. 


#5

I had seen this problem and it usually happens when I was playing with my wireless setting.

To fix it, I just restore default factory setting and the HD will get recognized again.


#6

I am also having this problem. my GEN 1 WDTV did not take this long to recognize the drives. Now it takes 4-5 minutes, every time I start the WDTV Live.

I will try this “reset network” option and get back to the forum on it.

It if takes this long to recognize the drive. I might have to take it back for a refund – this amount of delay is unacceptable - especially since the WDTV Gen 1 does not perform this way.


#7

I’m having same kind of problems. One drive takes a long time (it actually connects and disconnects over and over till it finally sees it) and the other never gets discovered until I hit factory reset, then it sees it right away.


#8

I tried the “factory default settings” reset and it fixed the issue.

Any info from WD why this is happening?


#9

Are you using a wireless USB adapter?