Hanging uploading music

I am copying my music from the mac book pro to mycloud 4TB via wi-fi.
Should i copy 80-100 songs everithing goes fine.
Should I selet all my music, more than 1500 The copy starts nevertheless after some time it hangs.
I have been trying this procedure several times, always getting the same hanging but not on the same song.
After each hanging I was deleting the songs copyed on MyCloud (directory Public folder, then my folder called Music).
In order to copy my music I have had to do it by groups of about 100each copy.
Is there a reason why ?

I wish also to add some details to my previous post on a different problem I have had.
While the system was copying few songs from iTunes I was launching other few songs copies.
The system was also hanging.


Are you uploading the files on a wired connection or wireless?

What firmware are you running on the device?

Have you tried resetting the device and trying that again?

I am uploading via Wi-Fi.
Serial n. [Deleted]
Firmware update: WDMyCloud v03.04.01-230 : Core F/W
Last fw update. : tuesday 22 aprile 2014 3.45.09
No i have not tried to reset the wd my cloud but on the first days i was shutting down it every evening, from the ws console.

Thank you for your prompt support. Best regards.

Today I have a similar problem with pictures, very few pictures moving.
Files were already on mycloud. I created a folder and moved less then 10 my pictures from my folder into a subfolder.
After that I was checking with Wd My cloud (app. Ver 3.1.1) if I could acces the pictures I had just moved.
The folder was visible but the cpunter w’as 0, even if there were pictures in it and i could see these pictures.
Same problem trying to acces with WD Photos, (ver . 2.3.2).

Following your suggestion I shutted down the disk and restarted it. After the restart I can se the pictures in my folders and counters are updated (both applications).

This is a by-pass and it might be of some help nevetheless I can not imagine a cloud to be shutted down to update the index. Is there any way to force the index update or avoid shutting down? If not, could you please fix it in a next release? Thank you.