Handbrake / PGS burn in support

Hey guys,

I have been trying to follow the progress of BD/PGS support for Handbrake for a while now.  It’s something that has been request for a while on the Handbrake forum but hasn’t seen much movement. 

Before, to get subtitles burn in, it took multiple programs to demux then remux the file to get the file, which could take an hour or more, just so that you could burn in the subtitles with Handbrake.

Well I’m happy to announce that there is now a new nightly out that will not only allow you to add PGS to you videos, but also allows you to burn in the subtitles.  I haven’t been able to do a full test yet (in the process now), but I did do a partial test with MI: Ghost Protocal and it seems to work pretty good.

If your interested you can get the nightlies from HERE.

One thing to note though, with the new nightly, I did have problems getting it to transcode a preview, but the actual encode seems to work fine.

Cool, thanks for sharing.

TW:  Which platform did you use?  Mac / Wn / Linux?    I just tried the Win nightly and still couldn’t get it to burn in forced subs…

Tony, I’m using the Win-64 GUI.  The version that I’m having good luck with is svn4608, I’m not sure about the newer nightlies since I haven’t updated in a couple of days.

Here’s the development discussion before it was implemented:


 I have tested with Captain America & MI: Ghost Protocol and everything works great.  The only thing I’m having problems with is playing mkv’s (BD) on the SMP, but this doesn’t have anything to do with Handbrake or the encodes because I was haveing the same issue before now.  Some mkv’s(BD) that play perfectly on the HUB & my Gen 1 player, freeze on the SMP.

And Tony, if you want to test (and you have it), try MI: Ghost Protocol, select the 3rd subtitle track and make sure you check “forced only” and “burn in”.

Hey guys,

So I’ve been burning in subs for several BD mkvs now and I’m happy to report that I haven’t run across any that I couldn’t burn the English subs for foreign languages (I can’t speak to any other language).

However, I have found a few things that “YOU SHOULD KNOW” if you’re going to burn in subs, so I thought I’d update this thread.

  1. If a BD movie uses PGS for English subs for foreign languages it appears to always have 3 subtitle tracks (I can’t say this exclusively, but all that I have done do), and if it does then you need to always select the 3rd track in Handbrake.  If you demux the BD, it may show the track as a different track, but Handbrake seems to always make it the 3rd track no matter which track it is.

  2. You should always do several Previews of your BD mkv before encoding.  As many who have used Handbrake know, it can take 10hrs or more to encode the mkv and you should always try to make sure that the subs are going to be added correclty before you do an encode and doing Previews takes a lot less time then messing up the encode and then having to do it all over again.

  3. For the most part when you do burn in the subs, you also need to check the “Forced only” box.  However, this is not always the case.  For example, John Carter uses a PGS (3rd track in HB) for the English subs when the Martians are speaking.  But this track does not use a Forced Flag to display these subs, so if you check the “Forced only” box your subs will not display.  In this case you will only need to check the “Burn in” box since the aforementioned PGS track only contains the English subs for the Martian language.

  4. When in doubt, DEMUX.  If you don’t know which track to burn in or whether it has a forced flag for the track you need, then demux the subs out of the BD (I use Clown BD), then open the PGS tracks with BDSup2Sub .  Like I said though, if you do this, then no matter which track it says contains the PGS you need, in Handbrake it will most likely be the 3rd track.