Had to move remote backup MyCloud Mirror and now it doesn't work

#1

I had to move a remote backup device (MyCloud Mirror) from one location to another and now I can’t get it to work. I’ve read the threads and made some of the changes related to Windows 10. I’ve gone back through the settings on the device itself so that it will update the router properly and confirmed by looking at the router table that the ports are there. I have two symptoms:

  1. The backup jobs are failing
  2. Right here on the same network I cannot map a drive to it. But, when I click on Network in Windows explorer I can see it, and get the dashboard up.
  3. It does mysteriously disappear from time to time but I can live with that .
  4. I seem to have no way to actually get to the files on it even though I can see it and get the dashboard up. Nothing seems to just open the folders in Windows explorer.
    Is there any solution to this?
#2

I don’t have any in-depth knowledge of networking but a question came to mind,

Remote in what sense? Is it on a LAN other than the one to which your computer is attached and if so how do you access that LAN, is it controlled by a server, have you got all necessary rights on that network once logged in.

Or perhaps it’s simpler than that e.g. the same LAN just another part of the building.

#3

If everything is on the same local network, the most common cause of this kind of issue is your MCM being set to have a router-assigned IP address (via DHCP) and that address having changed. So when you access the dashboard (via mycloudmirror.local or suchlike) the name is resolved to the new IP address and access works, but the mapped drives etc are via the old IP address which is no longer valid and so access fails.

As a check, the first step is to find the current IP address of your MCM. You can do this either from the dashboard, or from your router’s web dashboard. Once you have that, go to file manager on your Windows PC and type \192.168.x.x, replacing the x.x with whatever the MCM IP address is.

That should open up the available shares (although you may need to enter SMB log-in credentials beforehand). If that works then you should set the IP address to a fixed static one (that’s always recommended to do with NAS boxes anyway). You can do that either in your router, or on the MCM itself (see the MCM user manual page 90 for more details). Then you can either recreate your mapped drives or edit them to point to the new IP address.

#4

It’s a MyCloud Mirror device and it is not on the same LAN. It is using the Remote Backup software from one MyCloud Mirror to another at separate locations.

#5

I set static IP address already on the MCM. I can see when I log into the router that it is what I expect, which is 192.168.1.100. I did read there are other ways to set a static address but I used the setting in the MCM itself. When I go to windows explorer and type it, it brings up the dashboard, not the shares or folders or files. I was trying to search WD downloads to see if there is an obvious download that would let me see them. Way back when I bought my first MyCloud, it wasn’t a mirror and it was through an old app that I could see the files. Now this is a different computer and a different device and I don’t know what app might do it. And, I still can’t use it as a remote backup device either because the device that tries to access it gets an RSYNC error.

#6

Just typing the IP address into Windows Explorer is interpreted as if you had typed in HTTP://192.168.1.100 and that is why you get the dashboard. You must precede the IP address with two backslashes which tells the system that you are connecting to a device on the local network \\192.168.1.100 you can go directly to a particular share by adding it in the address say the share is called photos \\192.168.1.100\photos.

p.s. you can map a drive to the share, which is what I have done devices X: Y: and Z: on my computer are mapped to different shares on my MCM. A slight downside to this is that Windows 10 doesn’t re-connect drives correctly at boot time so I have a script to do it for me in my startup folder.

p.p.s. it’s not enough to set a static IP in your MCM. You must also allocate that particular IP as static/reserved for the MCM. That prevents problems if the router reboots.