H: not accessible Access Denied


#1

Hello there,

I own a WD My Passport Essential 320gb  external Drive, it used to work fine , but now when I  plug it in it, I cannot see the properties window  unless I go to the  computer/manage/storage/disk management , there is shown OK, it shows the amount of free - used space, but if I click it and try to explore the contents it says : access denied

So I tried to set the permissions to full control under my admin-user all of them but the special permissions box…

I know my files are in there because when I apply the permission rights it shows the sub directories with my pictures and other work files which are all my life ! 

Please could any body help me retrieve my data in there, I don’t know if its the WD Smartware or what the one giving me the H: is not accessible   Access is Denied. 

Thanks for any help anyone can provide to me  


#2

same here! :cry:  would be nice if someone could reply to this thread.


#3

Your drive may have a corrupt partition.  Can you error check or defragment it through Windows?  Also, can the drive pass an Extended Test using the WD’s Windows-based diagnostics (WinDLG).  You can get the diagnostics off the “Downloads” section of WD’s website.


#4

I have no solutuion to offer. This happens on an ATA HDD of mine running under the Vista OS. I can read, but I can’t write to the HDD. However running under Win 7 I have no problems writing to that HDD…strange!


#5

I found a solution!!

It kind of happened on accident when i explored another storage device but here it is.

In my computer window where the drive should be showing click on the folders tab. (the icon above)

This will open a side box of all the files in that window. From there you can explore the WD just like you were able to access it in its own window. I hope this helps. [edited for privacy]  if you have any other questions PM me.


#6

Try changing the drive letter in disk management, worked for all three of my Passports.