[GUIDE] TRANSMISSION 2.84 on mybooklive (02.43.10-048)


#44

hi dears
i do all terms step by step but when enter: ./setup.sh i see this error!!! i try with all old & new code.
anyone know any fix about this happen???
.
.
.
& ihave a big problem when reset or power down on my hard when come back i lost my torrents file in download!!!
thank you so much


#45

Hello everyone, does this script / method works with My book live DUO?


#46

For sure it works this https://community.wd.com/t/guide-install-transmission-2-77/58355. I have it on my DUO for years. For the transmission-daemon you must paste the info tha I give here: Can someone paste his /etc/init.d/transmission-daemon


#47

Thanks for the asnwer, how about FeaturesPackManager from highlevelbits.fr? do you know if it works? I’m seeing is easier to install that way.


#48

Yes, it will work for sure.


#49

Hi,

I’ve WD My Cloud 4 TB single bay storage. It’s version is 2.30.165
Is it possible to install feture pack on it?

Thanks.


#50

Updated the first post with correct forum format.
Updated the second post with suggestions from @HTaborda and @olimatis

I do not have the MyBookLive since 2016 so I can’t test the entire script anymore. Using community feedback I can adjust it.

Have fun!


#51

Transmission 2.92 is the latest. How can we get it installed on MyBookLive (MBL)?


#52

You can’t. Version 2.92 requires a more recent version of the Linux inside mbl. This can happen if WD update the mbl firmware


#53

Hi there, everyone.

This is in continuation to the post I posted a year ago.

Is anyone else facing this issue, cause I am.
If I need to access the MBL via the WD My Cloud app, I will have to execute this /usr/local/sbin/factoryRestore.sh noreformat and then add start accessing the drive on the mobile.

Every time I do this, I loose all my users and shares.

I tried downgrading the firmware, it would not allow me to do so.

Could someone help me out.

Thanks in advance.


#54

Thanks!!!


#55

Hi Proglin,

I have try this structure and stuck with error since step one of
"1/22 … (part 1/3) "

Please help review.

My MBL is model 1 Tb.

thanks.


#56

This is screen of error.

image


#57

Now I fixed it. Just my MBL not connect to internet. (>_<’)


#58

Hallo,
Seems the script got outdated. @Proglin any chance for links update?

1/22 Configuring repositories… (part 1/3) OK!

2/22 Installing packages… (part 1/7) OK!

3/22 Installing packages… (part 2/7) OK!

4/22 Installing packages… (part 3/7) OK!

5/22 Installing packages… (part 4/7) OK!

6/22 Installing packages… (part 5/7) OK!

7/22 Configuring repositories… (part 2/3) OK!

8/22 Installing packages… (part 6/7) OK!

9/22 Configuring repositories… (part 3/3) OK!

10/22 Installing packages… (part 7/7) OK!

11/22 Downloading sources of LIBEVENT…The command failed, exiting.

MyBookLive:~#


#59

Hi @seeker_pl
Try to change line 33 from:

LIBEVENTSOURCE='https://github.com/libevent/libevent/archive/release-2.0.18-stable.tar.gz'

to

LIBEVENTSOURCE='https://github.com/downloads/libevent/libevent/libevent-2.0.18-stable.tar.gz'

#60

Hey @Proglin,

I have the same issue as @seeker_pl, even if i try to paste the new line you linked.

it occured at the 11/22 step, with the same error message.

Any other solution?

Thank you for keeping this post update!!!:heart_eyes:


#61

You need to download latest MyBook live firmware and install it again. Restoring to default settings will not do a trick.
Set up a Remote and Mobile access.

Reboot, verify if it works.

Install transmission. You are again no longer able to add new remote or mobile access, but previously set should work.


#62

Lets see the error message from this line.

Follow this steps:

  1. You need to connect as root on your mybooklive
  2. Type and press enter:
    mkdir /shares/Public/tmpCompile
  3. Type and press enter:
    cd /shares/Public/tmpCompile
  4. Type and press enter:
    wget https://github.com/downloads/libevent/libevent/libevent-2.0.18-stable.tar.gz

This should show the error about step 11/22. Post it here


#63

Hi proglin,
Thank you for your answer, this is the error message i have :

MyBookLive:~# mkdir /shares/Public/tmpCompile
mkdir: cannot create directory `/shares/Public/tmpCompile’: File exists
MyBookLive:~# cd /shares/Public/tmpCompile
MyBookLive:/shares/Public/tmpCompile# wget https://github.com/downloads/libev ent/libevent/libevent-2.0.18-stable.tar.gz
–2019-01-14 10:03:29-- https://github.com/downloads/libevent/libevent/libev ent-2.0.18-stable.tar.gz
Resolving github.com… 140.82.118.4, 140.82.118.3
Connecting to github.com|140.82.118.4|:443… connected.
OpenSSL: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert proto col version
Unable to establish SSL connection.

I hope to get this problem solved! :tired_face: