[GUIDE] TRANSMISSION 2.84 on mybooklive (02.43.10-048)

Hi Proglin

After installing as per the your instructions in Post #1, and after a reboot, I’m unable to add new mobile access (Settings --> Remote Access --> Mobile Access --> Add Access).

Have you/anyone faced this issue? I get the following error.

31652 - Failed to generate code for your mobile device. Please make sure you do not have any network connectivity issues and try again.

If I update the same firmware from the file, I’m able to grant mobile access again.

1 Like

Line 27 needs to be changed.
TRANSMISSIONSOURCE='https://github.com/transmission/transmission-releases/raw/master/transmission-2.84.tar.xz'

Line 202 needs to be updated: (add --no-check-certificate option)
wget -q --no-check-certificate $TRANSMISSIONSOURCE -O $TMPFOLDER/${TRANSMISSIONSOURCE##*/} >/dev/null 2>&1

Updated version of the script can be download at http://pastebin.com/c85PwXcu

BTW do not try to install a more recent version (like 2.9x). It does not compile due to missing ssl lib. I couldn’t sort this out so far.

Everything else worked on my side :slight_smile: Thanks!

Hello! i tried this guide but i get this error message

in step 12/22 downloading sources of transmission the command failed, exiting.

The basic reason i tried to install again transmission was because for unknown reason the trasmission in my mybooklive duo start having issues with with connection port 51413. i tried to change that port to open it port forwarding but nothing work!

Any help please

Thanks

ok I found the solution for both after i read the last post!

hi dears
i do all terms step by step but when enter: ./setup.sh i see this error!!! i try with all old & new code.
anyone know any fix about this happen???
.
.
.
& ihave a big problem when reset or power down on my hard when come back i lost my torrents file in download!!!
thank you so much

Hello everyone, does this script / method works with My book live DUO?

For sure it works this https://community.wd.com/t/guide-install-transmission-2-77/58355. I have it on my DUO for years. For the transmission-daemon you must paste the info tha I give here: Can someone paste his /etc/init.d/transmission-daemon

1 Like

Thanks for the asnwer, how about FeaturesPackManager from highlevelbits.fr? do you know if it works? I’m seeing is easier to install that way.

Yes, it will work for sure.

1 Like

Hi,

I’ve WD My Cloud 4 TB single bay storage. It’s version is 2.30.165
Is it possible to install feture pack on it?

Thanks.

Updated the first post with correct forum format.
Updated the second post with suggestions from @HTaborda and @olimatis

I do not have the MyBookLive since 2016 so I can’t test the entire script anymore. Using community feedback I can adjust it.

Have fun!

Transmission 2.92 is the latest. How can we get it installed on MyBookLive (MBL)?

You can’t. Version 2.92 requires a more recent version of the Linux inside mbl. This can happen if WD update the mbl firmware

Hi there, everyone.

This is in continuation to the post I posted a year ago.

Is anyone else facing this issue, cause I am.
If I need to access the MBL via the WD My Cloud app, I will have to execute this /usr/local/sbin/factoryRestore.sh noreformat and then add start accessing the drive on the mobile.

Every time I do this, I loose all my users and shares.

I tried downgrading the firmware, it would not allow me to do so.

Could someone help me out.

Thanks in advance.

1 Like

Thanks!!!

Hi Proglin,

I have try this structure and stuck with error since step one of
"1/22 … (part 1/3) "

Please help review.

My MBL is model 1 Tb.

thanks.

This is screen of error.

image

Now I fixed it. Just my MBL not connect to internet. (>_<’)

1 Like

Hallo,
Seems the script got outdated. @Proglin any chance for links update?

1/22 Configuring repositories… (part 1/3) OK!

2/22 Installing packages… (part 1/7) OK!

3/22 Installing packages… (part 2/7) OK!

4/22 Installing packages… (part 3/7) OK!

5/22 Installing packages… (part 4/7) OK!

6/22 Installing packages… (part 5/7) OK!

7/22 Configuring repositories… (part 2/3) OK!

8/22 Installing packages… (part 6/7) OK!

9/22 Configuring repositories… (part 3/3) OK!

10/22 Installing packages… (part 7/7) OK!

11/22 Downloading sources of LIBEVENT…The command failed, exiting.

MyBookLive:~#

Hi @seeker_pl
Try to change line 33 from:

LIBEVENTSOURCE='https://github.com/libevent/libevent/archive/release-2.0.18-stable.tar.gz'

to

LIBEVENTSOURCE='https://github.com/downloads/libevent/libevent/libevent-2.0.18-stable.tar.gz'

Hey @Proglin,

I have the same issue as @seeker_pl, even if i try to paste the new line you linked.

it occured at the 11/22 step, with the same error message.

Any other solution?

Thank you for keeping this post update!!!:heart_eyes: