Guide to direct backup, unbrick , disassemble process (video) like MBL ones?


I’m about to open my bricked My Cloud as soon i receive an HDD to backup my data from it through a sata cable.

When i  search the net for info on disassembly of My Cloud to avoid damage to the cover and it seems to be a too new device cause the info i found are about other older WD devices.

I found two excellent threads of unbrick (with script), disassemble and data recover of MBL in WD Community forums:

[GUIDE] How to unbrick a totally dead MBL

[GUIDE] Debrick MyBookLive v2.0

I only found a picture of  My Cloud opened:

It’s from the second page of smallnetbuilder,com review of My Cloud.

From this image i guess the cover must slip to the right once i push on the latch on the left side after lifting the cover with a credit card o similar object but i have no idea where (if) are situated the latches on the other side.

Could someone post more info about the disassemble with photos or even a video?

I have been investigating this and playing a little…

The downloadable “firmware” for the WD My Cloud is just the raw boot image.

During an “upgrade” operation it splits the md based mirror and just does a dd of the raw image to lay it down.

It then copies all the customized configuration files over to the newly built image and boots from it.

I have already used this to “de-soft-brick” after I upgraded PHP to load OwnCloud… that broke the UI… doh.

I was able to run the script “” in /usr/local/sbin to perform the de-brick.

I downloaded the firmware zip and extracted the .deb file and planted it on the MyCloud in /CacheVolume

Then did… /usr/local/sbin/ /CacheVolume/sq-030104-139-20131028.deb

Worked like a charm to undo my “soft brick”.  I say soft brick since the UI was non-functional but ssh was fine.

The “” script in /usr/local/sbin looks quite interesting also, I have not finished reading that over yet.

It appears to format the drive and start from scratch…  Anyone else reverse engineer this script yet?

All these scripts are part of the wd-nas pkg:

WDMyCloud:/usr/local/sbin# dpkg -L wd-nas | grep -i install

Some snippets from the update.log:

Preparing to replace sq 03.01.04-139 (using …/sq-030104-139-20131028.deb) …
Master package name: sq
sq-preinst: action=upgrade
disable lazy init
stopping duplicate md device /dev/md0
Restore raid device: /dev/sda1
Restore raid device: /dev/sda2
Prepare for upgrade pkg install…
mdadm: set /dev/sda1 faulty in /dev/md1
mdadm: hot removed /dev/sda1 from /dev/md1
Preparing FW upgrade image on: “/dev/md0”
preinst: currentRootDevice=/dev/md1
preinst: upgradePath=/mnt/rootfs
preinst: upgradePart=/dev/sda1
preinst: upgradeDevice=/dev/md0
Unpacking replacement sq …
Setting up sq (03.01.04-139) …
root: ## postinst ##
/var/lib/dpkg/info/sq.postinst: line 6: /CacheVolume/upgrade/disk-param.conf: No such file or directory
root: ## postinst_body ##
root: ## postinst_header ##
postinst: isImage=true
postinst: Master package name: sq
postinst: sq-postinst: action=configure
postinst: currentRootDevice=/dev/md1
postinst: upgradeDevice=/dev/md0
postinst: upgradePart=/dev/sda1
postinst: upgradePath=/mnt/rootfs
root: ## postinst_image ##
Copy image to upgrade device /dev/md0:
blockSize=64k blockCount=31247
Compare checksum
-: OK
ok 0
mounting new root file system
root: sourcing new config files


JRman wrote:

Worked like a charm to undo my “soft brick”.  I say soft brick since the UI was non-functional but ssh was fine.


No ssh access here only the infamous yellow blink.

The only option i imagine  is to format partitions and copy over a fresh install of factory state My Cloud and crossfinger the problem is only related to data corruption in OS.

Meantime i will try to open it without damaging the cover and recover my data from his disk.

There is somebody around who can upload a fresh disk image (from factory i mean) of MY Cloud 3 TB?

1 Like

Do you know linux at all?  The zip of the firmware image contains the raw boot image.  You can dd this onto the boot partition of the drive. Filename: rootfs.img 

If you can attach the raw drive to a system booted with linux you should be able to recover.

The partitions will be key also. You may have to re-partition.

parted output:

WDMyCloud:/# parted
GNU Parted 2.3
Using /dev/sda
Welcome to GNU Parted! Type ‘help’ to view a list of commands.
(parted) p
Model: ATA WDC WD20EFRX-68A (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number Start End Size File system Name Flags
3 15.7MB 528MB 513MB linux-swap(v1) primary
1 528MB 2576MB 2048MB ext3 primary raid
2 2576MB 4624MB 2048MB ext3 primary raid
5 4624MB 4724MB 99.6MB primary
6 4724MB 4824MB 101MB primary
7 4824MB 4826MB 1049kB primary
8 4826MB 4828MB 2097kB primary
4 4828MB 2000GB 1996GB ext4 primary


WDMyCloud:/CacheVolume/extract/CacheVolume/upgrade# ls -al
total 1999848
drwxr-xr-x 2 root root 4096 Oct 28 17:26 .
drwxr-xr-x 3 root root 4096 Oct 28 17:21 …
-rwxr-xr-x 1 root root 2207 Oct 28 17:21 postinst_all
-rwxr-xr-x 1 root root 953 Oct 28 17:21 postinst_body
-rwxr-xr-x 1 root root 313 Oct 28 17:21 postinst_container
-rwxr-xr-x 1 root root 515 Oct 28 17:21 postinst_footer
-rwxr-xr-x 1 root root 1862 Oct 28 17:21 postinst_header
-rwxr-xr-x 1 root root 2076 Oct 28 17:21 postinst_image
-rw-r–r-- 1 root root 2047803392 Oct 28 17:26 rootfs.img
-rw-r–r-- 1 root root 36 Oct 28 17:27 rootfs.md5

Jrman thank you very much to to take your time to reply and excuse me if my questions seems stupid but my Linux knowledge is pretty basic, i use it mainly to repair windows boot problems and data recover.

Linus Torvald has nothing to worry about my Linux skills! :smiley:

I knew that boot image was in the firm and how to use (g)parted.

I understand that partition sizes for a 3 TB disk are the same as you write for a 2 TB disk in but the ext4 being larger.

  • How can i use the scripts you said without SSH? :confounded:

    I was able to run the script “” in /usr/local/sbin to perform the de-brick.

    I downloaded the firmware zip and extracted the .deb file and planted it on the MyCloud in /CacheVolume

    Then did… /usr/local/sbin/ /CacheVolume/sq-030104-139-20131028.deb

    Worked like a charm to undo my “soft brick”. I say soft brick since the UI was non-functional but ssh was fine.

  • I don’t understand the presence of 8(?) partitions in your partition layout of My Cloud 2TB.

  What’s the purpose of partitions 5,6,7 and 8?.

  • Must i simply dd the 2 GB rootfs.img to both raid partition, repartition the other partition and reconnect the disk to My Cloud booting it in a normal way?

What make me though about OS partition image is that  the guide to recover bricked MBL 3 TB when there is no dashboard or SSH access use it  instead of the raw boot image from his firmware.

The unzipped 203 mb file is a 4,31 GB disk image of 4 partition s:

  • 2 ext3 raid 1,9 GB each

  • 1 swap of 489 mb

  • 1 ext4 for data completing the remaining  2.7 TB at the end of disk.

[GUIDE] Debrick MyBookLive v2.0

Guide 2 (3TB MBL)


1) Download the virgin disk image (02.41.05-034) (203MB) from!FZkASQ6T!P3DMWzaOn62jSrG4SECtIDeJeLYEdmz6w6kR9it8U68
2) Extract with 7-zip and you should have a file called mybook3tb.img

3) Format an 8GB+ thumbdrive or external usb hard drive to NTFS and copy mybook3tb.img to it 
4) Download SystemRescueCd and burn it to a CD


5) Shut down your computer and remove the cable from your computers hard drive so we don't erase it by mistake


6) Hook up your MyBookLive to a SATA port on your motherboard or buy an eSATA to SATA cable or dock and hook up the drive that way. You can try a USB to SATA cable but success rates vary


7) Turn on your computer and tell it to boot from the CD drive


8) When the system rescue cd menu comes up, select to "directly start the graphical environment"


9) Open gparted and check to see where your MyBookLive shows under. In my case it shows up under /dev/sda
The drive should contain several EXT3 partitions and a rather large EXT4 partition

If your drive shows up under sdb, sdc, sdd etc. just substitute the proper name for the drive when getting to
dd if=/mnt/usb/mybook3tb.img of=/dev/sda bs=1M (DON'T ENTER THIS COMMAND YET)


Now in gparted check to see where your thumbdrive shows up. In my case it shows up under /dev/sdb1
If it shows up under sdc1, sdd1, sde1, etc. just substitute the proper name for the drive when getting to
mount -t ntfs /dev/sdb1 /mnt/usb (DONT ENTER THIS COMMAND YET)

10) In terminal type the commands below (Make sure you change sdb1 (For the thumbdrive or usb hard drive) and sda (for the MBL hard drive) to whatever they show up as in GPARTED)

mkdir /mnt/usb
mount -t ntfs /dev/sdb1 /mnt/usb
dd if=/mnt/usb/mybook3tb.img of=/dev/sda bs=1M

11) Look for any errors in the terminal window (output should look similar to below)
4420+0 records in
4420+0 records out

12) Logout of the SystemRescue CD and shut down the computer


13) Hook up the pcb to the MyBookLive hard drive and screw it down with 2 screws for now and then hook up the ethernet and power cord and try booting the drive again without putting it back in the case


14) Now from the dashboard do a Quick Factory restore to format the data partition


15) When the quick factory restore is complete power down the MyBookLive


16) Put the drive back together as you are done!

 I disassembled it today and received a 3 TB drive to try to backup my data.

Tomorrow i will have time to attach the drive to sata and look what the drive has inside. 

Any news?

I have totally dead My Cloud 3TB and I have tryid to wake it up with modified MBL instructions, but no success.

Does anybody have any ideas? Image?

I solved it:

I have done almost same way but it’s not working…I have created similar disk partitions (8 partitions) with modified debrick script from this instruction: and using rootfs.img from latest firmware but no success.

Only difference I just noted is that I’m connecting via USB-SATA. Maybe that is causing problems?

I didn’t  use any script i simply write partition image over each raid partition. 

I didn’t touch partition layout cause it was right. 

Usb sata or sata doesn’t make difference if you use usb 3.0,  if you use usb 2.0 it will be slower but the image to write is only 2 gb so it wil not take much longer than 3.0 to write over each raid  partitions. 

Hi! How did you manage to write the image into the partition?

I can find all partitions on r-linux, but they are not being displayed on gparted or disk.


r-linux? You will see the partitions of MyCloud Hdd on gparted or disks when the hard drive is connected to your system via sata, esata or sata via usb adapter.

the partitions weren’t being listed on gparted so I’d to recreate them… I’m now in the same situation as cnlynia (from the other post) so still trying to figure out next steps… thanks anyway :slight_smile:

Photos of a teardown here:

dggomes… any luck? i’m in the same boat. have a completely borked installation.

Yes, bogdi1988. I’ve fixed mine following the steps on this post (cnlynia post on page 6 or mine on page 5). Just bear in mind that you will lose all data on your hard-disk.

I finally got mine fixed with virgin disk image. I tested all other ways without any luck, but that virgin disk image finally solved my problem. Thanks!

Help !! Not able to access -

chetan_shah wrote:

Help !! Not able to access -

“You do not have sufficient privileges for this resource or its parent to perform this action.”

is shown because WD prefered to delete all my previous postings.

However, they have been too lazy to delete all links to these pages and thats why you get this message.


Anyhow, these images on the net are not reliable and I suggest you to send back MyCloud for a full refund.

1 Like

Well i managed to get an MYbook cloud - PCB only - and had and WD 3TB red drive lying around. I thought i could build a NAS like i did with my 3TB my book live.