[Guide] Modify Transmission settings permanently


#1

Disclaimer : When performing this procedure, you are doing it at your own risk and potentially voiding your warranty.

I have been toying around with Transmission settings on my MycloudDL4100 and found an issue where the system does not seem to take any of the settings I apply. I have transmission installed directly in the Apps folder within the myCloud UI. I am accessing Transmission via the transmission-qt in windows.

The solution at a high level is to log into the device using WinSCP and modify the settings.json file manually.

Here’s a step by step of the solution that worked for me:

  1. Install WinSCP
  2. Log into server at 192.168.1.6 as root with the administrator password (I have this as the local static IP) and the SCP protocol.
  3. Locate the transmission configuration folder.
  4. Right click and duplicate the settings.json file for back
    up purposes.
  5. Right click and edit the settings.json file.
    (I used the WinSCP built in editor)
  6. Change desired settings for example my login and password are the goal for this procedure. You should be able to google the transmission settings you desire to have permanent changes made to, or just experiment since you have a backup :wink:
    “rpc-username”: “admin”,
    “rpc-password”: “supersecurepassword”,
    *DONT SAVE YET
    Note that when you save the file your password will be hashed and will appear to be nonsense the next time you open the file.
  7. Turn off the Transmission application via the WebUI
  8. Save your changes to the .json file .
  9. Turn the Transmission application back on via the WebUI
  10. Connect via transmission-qt windows application.

#2

Hi,

Thanks for sharing this with the Community.

As a recommendation, add a disclaimer for the other users to let them know that they will be doing this at their own risk.


#3

Don’t forget to add to json file:
“rpc-authentication-required”: true,
if you actually want to be prompted for credentials.

Otherwise, great write-up!