[GUIDE] Install MiniDLNA on WD My Cloud (firmware series 3)


#6

From WD-README.txt within available source file:

"Instructions to rebuild a Debian package

The WD My Cloud device firmware versions 04.00.00 and later use a modified version of Debian Linux which uses 64K sized memory pages.

In order to build Debian packages for use on a 64K page-size device, an “qemu-emulated native” build system is used, which contains the binutils package modified for 64K page-size alignment.

Prerequisites:

  • x86 PC with 64-bit Ubuntu or Debian installed
  • packages qemu-user-static and binfmt-support installed on host build system
  • Modified binutils package with 64K page size support. A pre-built version is included in binutils directory. There is no need to re-build binutils, however, instructions are provided in the source package (see binutils/README-binutils-64K-pagesize.txt).

Run the script:

./build-armhf64k-package.sh <package_name>

Where:

<package_name> is the name of the package you would like to build.
is the Debian suite version. E.g., “wheezy” (i.e. stable) or “jessie” (i.e. testing).

After a successful build, the Debian build artifacts (.deb files) for the package will appear in the directory “build/root”. The artifacts may then be copied to a WD My Cloud device, and installed through the standard Debian install mechanism (dpkg -i)."

I guess this can improve performance but may as well prove to be a big hassle considering the handling of the dependencies…


#7

Thank you very much for your reply.

Mhmmm… I think I’ll stick to Transmission for now. Indeed, I’ve seen that you can’t push it. But it usually works just fine dealing with a small amount of connections.

That explains a lot. Seems I won’t be upgrading to 4.0. I don’t have a Linux box and I’m too lazy to install a virtual. Plus, I’m not so good with Linux. Also, 4.0 caused issues out of the box anyway. So… Maybe, someone will upload some already compiled file somewhere.  :stuck_out_tongue:

Cheers.


#8

hvalentim,

Just wanted to thank you for adding in our disclaimers.  We really appreciate that our users show this kind of responsibility. 

Bill_S


#9

Hello,

after reading the whole thread I still don’t understand if it’s possible to stream subtitles over the DLNA server. So, I have Sony KDL-40W605B TV & Western Digital My Cloud 3 TB (firmware v04.00.00-607 & Twonky DLNA media streaming server 7.2.8_7.5.0-20140510.024914).

As such, external subtitles don’t work and muxing subtitles in video files isn’t an option.

Is it possible to install MiniDLNA on this WD firmware without losing my data on WD drive?

Regards,


#10

I have an LG TV myself and never used the Twonky version shipped with v.4 firmware so I am afraid I can not help you with that.

Concerning the installation of MiniDLNA with firmware v.4, I am unaware of the existence of a custom compiled version. So the short answer is no. It is thus far not possible.


#11

@mladimatija,

please check the specs of your TV.   No matter what you do, unless you get an actual client (i.e. computer, media player, etc) to play your movies, your TV will not display subtitles over network, only USB.

http://pdf.crse.com/manuals/14HM094111/EN/codeclist.html#10 


#12

Thank you for your answers. So, my next question is: Is it then possible to stream movies with subtitles from Android Media Player > WD My Cloud (LAN) > TV? Also, which price range do you recommend for such media players?


#13

It should be WD My Cloud > Android media player > TV.  If you’re android media player supports subtitles (most likely would) then it should work.  Otherwise most media players will support subtitles.  You can use a cheap laptop, pc, roku, wd tv, etc…


#14

I’m streaming movies from WD MyCloud to EZCast dongle in TV (by default DLNA client from WD) controlling by android phone. You can use for this Media House or Bubble UPNP apps from market.

BTW, Android is involved just as control device. I can even switch the phone off and this will not stop the show, I’ll just loose the control of playback.


#15

Hi everyone, and sorry for the long absence. 

About the subtitles - I didn’t read the entire discussion cause i’m in kind of a hurry here but on short - minidlna streams .str subtitles just fine as long as both movie and subtitle file have the same name - e.g. movie.avi / movie.str

neither WD Dlna server nor Twonky (before v.7) does not support subtitles. 

I don’t know anything about this new firmware since right now I use fully working debian wheezy distro with my MyBookLive and the new Twonky 7.2.8 as media server and everything works like a charm. I found this firmware on a russian forum and I can say it is awesome.

If the moderators are ok with this, i’ll post here everything about it, if not you can ask me about the details via PM.

Cheers!

Sorry for the missunderstanding, i was sure that i’m replying to my topic… the wheezy firmware is for MyBookLive… sorry again… i gotta catch some sleep hours… :frowning:


#16

Hello everyone,

I was wondering if it was possible to safely downgrade the firmware like it’s described here http://community.wd.com/t5/WD-My-Cloud/Firmware-downgrade/m-p/693892/ and then install MiniDLNA?

Or any custom firmware for that matter. Has anyone tried it yet?

Regards,


#17

Hey

Has anyone taken the plunge and recompiled Minidlna for firmware version 4 as per the full guide here:

http://community.wd.com/wstd/board/message?board.id=mycloud&message.id=18650#M18650

(there is a link at the top of this thread which has information about compiling packages for the new firmware but the guide above seems more useful).

I am tempted to have a go but i’d have to install linux somewhere and id really rather not. Im also not sure about what would happen with dependencies and such as im really no linux afficionado.

I would be surprised if no-one on the formus had already done this as there seems to be an interest in those of a technical bent to have minidlna on their my cloud. But so far anyone who has done this is not sharing their results or at least not that i can find for all the googling I have done.

I have seen instructions on how to install clean debian with openmediavault (which also seem to include downgrading the firmware which I dont really want to do as heartbleed and or shellshock probably arent patched under the older versions and I cant confirm from reading and rereading the thread what the results will be vis a vis the original web ui and software on the my cloud and my data already on the device).

http://community.wd.com/t5/WD-My-Cloud/Clean-debian-and-OpenMediaVault-on-WDMyCloud/td-p/785505

Anyway i was hoping someone who had been reading this thread might have some info. It has been several months since the new firmware came out.


#18

I can tell you that it can be done in V4.

I built amule and minidlna for V4 before and they worked fine.

However, my WD my cloud was crashed and I lost all the deb files.

Jsut follow the guide you post, you can build all the packages (to me I built them in ubuntu under a VM).

It is a very time consuming process as you have to build many deb files.

I hope you good luck to build all of them!


#19

When you build it does it automatically build all the dependencies which are needed or do you need to do that all manually?

And if you have to do them all manually do you have any pointers on how to determine what packages need built?

I have no problem if it takes a long time id just rather know that when I have built something im not going to have to stop and figure out what dependencies I forgot or didnt know to include.

Its a pity all those people who have rebuilt packages for the new firmware didnt feel the need to share with the rest of the community.


#20

@henryjfry,

_ Its a pity all those people who have rebuilt packages for the new firmware didnt feel the need to share with the rest of the community. _

Apart from security concern installing personally built packages, rebuilding the packages is no easy task. Run below in shell (you need to 1st add the source list then “apt-get update”): 

nazar@TeaNazaR4TB:~$ apt-cache depends minidlna
minidlna
Depends: adduser
Depends: lsb-base
|Depends: libavformat53
Depends: libavformat-extra-53
|Depends: libavutil51
Depends: libavutil-extra-51
Depends: libc6
Depends: libexif12
Depends: libflac8
Depends: libgcc1
Depends: libid3tag0
Depends: libjpeg8
Depends: libogg0
Depends: libsqlite3-0
Depends: libvorbis0a

OR show all:

nazar@TeaNazaR4TB:~$ apt-cache showpkg minidlna
Package: minidlna
Versions:
1.0.24+dfsg-1 (/var/lib/apt/lists/ftp.us.debian.org_debian_dists_wheezy_main_binary-armhf_Packages)
Description Language:
File: /var/lib/apt/lists/ftp.us.debian.org_debian_dists_wheezy_main_binary-armhf_Packages
MD5: 5b2d396f86d25a79b5ab8a1c34181623
Description Language: en
File: /var/lib/apt/lists/ftp.us.debian.org_debian_dists_wheezy_main_i18n_Translation-en
MD5: 5b2d396f86d25a79b5ab8a1c34181623

1.0.24+dfsg-1 (/var/lib/dpkg/status)
Description Language:
File: /var/lib/apt/lists/ftp.us.debian.org_debian_dists_wheezy_main_binary-armhf_Packages
MD5: 5b2d396f86d25a79b5ab8a1c34181623
Description Language: en
File: /var/lib/apt/lists/ftp.us.debian.org_debian_dists_wheezy_main_i18n_Translation-en
MD5: 5b2d396f86d25a79b5ab8a1c34181623

Reverse Depends:
Dependencies:
1.0.24+dfsg-1 - adduser (0 (null)) lsb-base (0 (null)) libavformat53 (18 4:0.8-1~) libavformat-extra-53 (2 4:0.8-1~) libavutil51 (18 4:0.8-1~) libavutil-extra-51 (2 4:0.8-1~) libc6 (2 2.4) libexif12 (0 (null)) libflac8 (2 1.2.1) libgcc1 (2 1:4.4.0) libid3tag0 (2 0.15.1b) libjpeg8 (2 8c) libogg0 (2 1.0rc3) libsqlite3-0 (2 3.5.9) libvorbis0a (2 1.1.2)
1.0.24+dfsg-1 - adduser (0 (null)) lsb-base (0 (null)) libavformat53 (2 6:0.8.3-1~) libavutil51 (2 6:0.8.3-1~) libc6 (2 2.13-28) libexif12 (0 (null)) libflac8 (2 1.2.1) libgcc1 (2 1:4.4.0) libid3tag0 (2 0.15.1b) libjpeg8 (2 8c) libogg0 (2 1.0rc3) libsqlite3-0 (2 3.5.9) libvorbis0a (2 1.1.2)
Provides:
1.0.24+dfsg-1 -
1.0.24+dfsg-1 -
Reverse Provides:

OR via web: 

Just look here https://packages.debian.org/search?searchon=sourcenames&keywords=minidlna

Choose your suite, then look at the “adep:”. Each of those are required to be rebuilt manually if its not already in your system (check: “dpkg -l|grep package_name”). If that doesn’t look bad, each of those has its own sub-dependencies to go crazy with. And no it won’t automatically build for you but you can do sort of scripts to help out a bit.

The problem here is not figuring out dependencies, but if they can be compiled successfully or not. I recently tried gcc-4.9. It took almost the whole night despite me running the entire build process on ramdisk. But ends up with segment fault. Also when installing those debs, one needs to be careful as not to break the mycloud. I have rebuilt several packages but only those few I could share here because it needs more than just installing i.e. modifying configs, linking libraries manually.


#21

I have v03.04.01-230 installed and attempts to install minidlna have broken my install.  I followed the instructions, but the apt-get fails, and then I have dependency issues that I cannot clear up.

I experience the exact same issue that someone else outlined here:   http://community.wd.com/t5/WD-My-Cloud/Possibly-played-too-much/td-p/785287

I had to remove the drive, and rewrite rootfs.img in order to get it running again.  I tried again, and came up with the same result.


#22

I took the plunge building MiniDLNA for firmware V4. For those who’s interested, basically below are the needed 64K page size memory packages to build. I’ll write a guide soon on how to install this when time permits:

nazar@TeaNazaR4TB:~$ find "../Public/Shared Downloads/WD My Cloud/Deb64K/minidlna_1.0.24/" -type f ! -path "*excluded*" -exec basename {} \;|sort
libavcodec53_0.8.16-1_armhf.deb
libavformat53_0.8.16-1_armhf.deb
libavutil51_0.8.16-1_armhf.deb
libdirac-encoder0_1.0.2-6_armhf.deb
libgsm1_1.0.13-4_armhf.deb
libid3tag0_0.15.1b-10_armhf.deb
libmp3lame0_3.99.5+repack1-3_armhf.deb
libopenjpeg2_1.3+dfsg-4.8_armhf.deb
liborc-0.4-0_0.4.16-2_armhf.deb
libschroedinger-1.0-0_1.0.11-2_armhf.deb
libspeex1_1.2~rc1-7_armhf.deb
libtheora0_1.1.1+dfsg.1-3.1_armhf.deb
libva1_1.0.15-4_armhf.deb
libvorbis0a_1.3.2-1.3_armhf.deb
libvorbisenc2_1.3.2-1.3_armhf.deb
libx264-123_0.123.2189+git35cf912-1_armhf.deb
libxvidcore-dev_1.3.2-9_armhf.deb
libxvidcore4_1.3.2-9_armhf.deb
minidlna_1.0.24+dfsg-1_armhf.deb
nazar@TeaNazaR4TB:~$ minidlna -h
[2014/10/30 00:44:21] minidlna.c:786: error: Usage:
        minidlna [-d] [-v] [-f config_file]
                [-a listening_ip] [-p port]
                [-s serial] [-m model_number]
                [-t notify_interval] [-P pid_filename]
                [-w url] [-R] [-V] [-h]

Notes:
        Notify interval is in seconds. Default is 895 seconds.
        Default pid file is /run/minidlna.pid.
        With -d minidlna will run in debug mode (not daemonize).
        -w sets the presentation url. Default is http address on port 80
        -h displays this text
        -R forces a full rescan
        -L do note create playlists
        -V print the version number
nazar@TeaNazaR4TB:~$

#23

Hello all,

Lot of failed while installing miniDLNA, and lot of brick my WD 2To, cause i’m a noob in linux and I don’t understand what I do…

Does anyone have an image disk of WDMYCLOUD with miniDLNA installed ? It will be more easy for me.

thx all


#24

I followed thses instrructions and it did not appear to work. It gave error message 1. My version of firmware is v03.04.01-230. I downgraded to this to allow another application be installed. Unfortunately I cannot show the screengrab of the messages as this forum does not appear to allow it.  Could you maybe point me in the way of a solution?

Tom


#25

does this command line need to be run in a certain /DIR?

echo deb http://ftp.us.debian.org/debian/ sid main >> /etc/apt/sources.list
STEP 4 - Update the sid packages list (be patient as it may take a while

im in the /ect/apt directory when I run the command in putty/WinSCP

the directory does not seem to be at http://ftp.us.debian.org/debian/ anymore.

edit: I found some files here http://sourceforge.net/projects/minidlna/files/minidlna/ but I dont know what version works with the older firmware 3