[GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud

#164

:grinning:strong textI was poking fun, the default admin password for the backdoor on the my cloud devices came from a dlink product

#165

Hello and thanks for your guide. Since I have a WDMyCloud-Board left without harddisk and I would like to have a small music server in my caravan: Do you think it is possible to plug a 512gb ssd into the MyCloud? Is there a way, because the smallest wdmycloud is 2tb.

Thanks and regards

#166

yes, if it is sata it work!

#167

Nice, thanks for the fast response. I have an old Sata hdd with 512gb, I will make a test setup with that before purchasing the SSD. Will hopefully report when I succeeded.

#168

Hi,

since the the link in #1 didnt work, I downloaded an image from a youtube video and followed you instructions.

With 512gb HDD: It works up to 14, in my case it says: Invalid argument during seek for read on /dev/sda Retry/Ignore/Cancel. I entered “ignore”
After this step/message14 happens, I can enter “OK”, but after that, I dont see the “15 message” I cant list any partitions or anything. Windows does see the partitions, the last one is bigger than the whole disk…
The wdmycloud doesnt make ANYTHING with this harddisk

With 2tb HDD:I do 1-10, then continue with 18. The wdmycloud does have white light, then a red one, nothing happens more.

My Board Part Nummber is 4061-705144-001 rev.02p
It should be a Rev1 WDMycloud. Do you have another image or perhaps any hints?!

Thanks and regards,

#169

red means image isnt mounted , try this. http://anionix.ddns.net/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD%20-%20English.txt . Download Ubunto on a usb stick, boot from it, then perform the above

1 Like
#170

Thank you very much. Made it. made a factory reset after booting, after that, HDD size got recognized. So I think with a ssd, I will have a shake-resistant NAS inside my caravan, I am happy, thank you!
I installed 4.01… Now I am testing the update

#171

congrats! glad to see you worked everything out!!!

#172

Sry, for asking here:
Since I was curious I installed clean debian with autoinstaller. After that I made “* Optional: Run “/run_me_after_reboot.sh” for few tweaks and cleanup.”
After that I followed the instructions for omv3, but then I get to following error:

root@MyCloud:~# apt-get install openmediavault
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
openmediavault : Depends: php5-fpm but it is not installable
Depends: php5-cgi but it is not installable
Depends: php5-cli (>= 5.6) but it is not installable
Depends: php5-pam but it is not going to be installed
Depends: openssh-blacklist-extra but it is not installable
E: Unable to correct problems, you have held broken packages.

How can I solve this?

Thanks and regards

edit: removed the old omv version from the sources list and started installing it with:

apt-get update
apt-get upgrade
apt-get dist-upgrade
echo “deb http://packages.openmediavault.org/public arrakis main” > /etc/apt/sources.list.d/openmediavault.list
apt-get update
apt-get install openmediavault-keyring postfix
apt-get update
apt-get install openmediavault
omv-initsystem
reboot

But it stops with

0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d…

done.
done.
Errors were encountered while processing:
collectd
openmediavault
E: Sub-process /usr/bin/dpkg returned an error code (1)

testing from the beginning now with ssd and firmware 0.3…
btw: with the ssd the wdmycloud runs like hell :slight_smile: response to inputs on the menus is instant.
Copy speed with Original Firmware is around 80mb/sec. OMV 2.x ist even slower, just around 20mb/sec. At least without any kernel updates or whatever might by possible here.

Clean OS (Debian), OpenMediaVault and other "firmwares"
#173

apt-get -f install

http://www.openmediavault.org/?page_id=1271

#174

sorry for question, you mean I do

apt-get -f install openmediavault

?

#175

apt-get -f install

this will force the broken dependencies, maybe fix your build.

#176

continued this problem here:
https://forum.openmediavault.org/index.php/Thread/26303-Install-omv4-on-clean-debian-WDMyCloud-Rev-1-error/?postID=197447#post197447
since it is not a unbricking topic any more. Nothing worked out so far :-(. Thanks anyways!

Further Problem: I wanted to shutdown the board with “shutdown -h now​”. Since it didnt turn off, I unplugged it. Now, after rebooting, I cant ping it, I cant connect. LED is green. Is there any chance to connect to it without complete new installation process?!

At least to started to work with clonezilla to reset the hdd to a clean wdmycloud status without many efforts

#177

Hi, thank you very much for this forum, it helps me put my MyCloud 3TB back from the dead. I use the 2TB image and do exactly as the instructions says and everything is setup perfectly with 3TB capacity.

I have questions though…

a. can I upgrade the firmware to the latest by manually providing the latest firmware (4.05xxx) from WD?

b. how come I cant “see” any shared folder from a Win7 using the explorer. I manually open \192.168.1.10 and it just gave me “windows cannot access \192.168.1.10” error. But I can do webui, and can also connect via FTP. However, using the same Win7 PC, I can see the other MyCloud in my network which is in \192.168.1.20. And from our other Win7 PC can see the shared folder WITHOUT even providing the username/password, it didnt ask until i want to open a non-public folder.

c. Using my laptop Win10, I can see the shared folder, but ONLY after I input a username/password. Is there a way I can see the shared folder, even just the PUBLIC folder, without providing my username/password just like the 2nd Win7 PC mentioned above?

thanks

#178

hi,

after the procedures, the firmware version is 3.x.x, your screenshot says 4.05.x… did you manually upgrade the firmware AFTER you do the quick restore?

#179

Hi jwan. No, I had done the firmware update back in July of 2018. My unit had been having problems for several months before that. It was booting OK and worked somewhat, but I would get errors trying to access a lot of the files and it kept failing the Full Test. WD support was not helpful in helping me determine what the actual system test failure was, even after I sent them logs from two different tests. So I had updated the firmware while trying to figure out what was wrong. Concluded it was a problem with the drive and so then I found this procedure to replace it.

#180

thanks for the reply. Browsing through the forum, there are quite a number of indication that seems to suggest upgrading the firmware is ok. Unfortunately, I did both auto and manual file upload of newer firmware via the WebUI and both doesnt work.

I would like to share this link: WD My Cloud v3.x, v4.x and v2.x Firmware Versions Download Links as it discuss how to do the update via ssh. Since I can not access MyCloud using regular file explorer to copy the deb file, i use the FTP instead. And from there, everything working fine. I am now on the lastest WDMyCloud v04.05.00-334 : Core F/W and is happy now.

I have to add that with this latest version, I am now able to network connect via my Win7 using Explorer (which is my problem above under letter b)

Thanks for the great people out here!

#181

Hello,
I have a 4TB mycloud without a disk and I wanted to put on a 2TB drive, I followed the instructions and it did not work (after 30 minutes still blinking red), the disk image was done correctly, because on the 2TB mycloud this disk works correctly, how can I fix it. Is it necessary to use 4TB for the 4TB version and the smaller one will not work?
Mycloud 4TB model is WDBCTL0040HWT - EESN
Please help.

#182

I suggest seeing this thread.

Many of the steps using virtualbox can be skipped if you use the bootable USB stick method used by fox_exe. (You telnet into the box to create the partitions directly on the mycloud)

The secret sauce is getting the darn thing to set up the JBOD configuration. This is managed with a byzantine web of XML config files that identify the drive by its serial number. A direct image from a different drive will have a different serial number, and so the volume mounter wont mount, and you will have the 0mb free issue.

This is why I suggest doing the “boot recovery media, and then flash firmware” method. This prompts the unit to present the RAID manager, where you can then set up the JBOD config, and all will be peachy keen.

#183

i am having a problem after step 8 here are some pictures and some errors i am getting i have a 4tb hard drive. can anyone please help me!!!?![IMG_0325|666x500]