[GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud

Note that user Ouglee last post was Feb 16, 2017.

Are you trying to unbrick a first gen v4.x firmware single bay My Cloud model (P/N # ends with “-00”) or a second gen v2.x firmware single bay My Cloud model (P/N # ends with “-10”)? The directions for the second gen model are not the same as the directions for a first gen model.

If the directions above do not work, one can try using the unbrick directions from user Fox_Exe that some have used with success.

User Fox_exe repositories:
Main Repository: https://fox-exe.ru/WDMyCloud/
First Gen: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/
Second Gen: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/

First gen directions:
English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD%20-%20English.txt
Russian: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD.txt
File(s) used in first gen:
original_v03.04.01-230.tar.gz: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Backups/original_v03.04.01-230.tar.gz
original_v04.01.02-417.tar.gz: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Backups/original_v04.01.02-417.tar.gz
Latest first gen firmware: http://support.wdc.com/downloads.aspx?g=904

Second gen directions:
English: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt
Russian: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_ru.txt
usbrecovery.tar.gz: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/usbrecovery.tar.gz
Alternate method files:
uImage-wdrecovery: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Developing/uImage-wdrecovery
uRamdisk-wdrecovery: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Developing/uRamdisk-wdrecovery
Latest second gen firmware: http://support.wdc.com/downloads.aspx?g=904

Notes on running unbrick directions on a first gen single bay My Cloud: After successful unbrick one can update the My Cloud to the latest v4.x firmware. When running the first gen unbrick directions from User Fox_exe one may get one or two errors, which one can try bypassing on a first gen. The unbrick process typically completes despite these errors. Places where one may get errors or warning when unbricking a first gen:

  • Step 8. The command ‘mdadm -A /dev/md0 /dev/sdb1 /dev/sdb2’ sometimes throws an error. One can typically just ignore the error and continue to the next entry command in step 8.
  • Step 12. When using the original_v04.01.02-417.tar.gz file, one may get a out of space error when running the command ‘dd if=kernel.img of=/dev/sdb5’. One can try ignoring this error and proceed to the next entry command in step 12. When using the original_v03.04.01-230.tar.gz extracted files one typically won’t get the out of space error message on sdb5.
  • When booting the My Cloud for the first time after unbricking the hard drive one may eventually get a red front LED after the bootup completes. One should attempt to access the My Cloud Dashboard. If one can access the Dashboard, go to Settings > Utilities > System Factory Restore > System Only restore and run the system only restore. This typically fixes the 0K capacity and the failed mount issue that typically happens with this unbrick procedure.

wow this is an old post with a lot of replays .

any idea what are the numbers for 8TB ?
and there is new way to do that ?

Generally one doesn’t change the partition size values if using the Fox_exe directions. One would enter the values in exactly. I’ve used the Fox_exe directions to unbrick a 12TB drive as a test in a first gen single bay My Cloud. After doing a system factory restore after first boot the My Cloud worked fine and utilized the full space of the hard drive.

The bigger factor is ensuring you use the correct directions for the version (first or second gen) of the single bay My Cloud (not My Cloud Home that is a different device).

i having a problem with this thing :

  1. Install original WD recovery and reboot:
    mkdir -p /mnt/usb /mnt/root
    mount /dev/sda3 /mnt/root
    mount /dev/sdb1 /mnt/usb
    cp -r /mnt/usb/boot /mnt/root/
    cd /mnt/root/boot
    rm uImage uRamdisk
    mv uImage-wdrecovery uImage
    mv uRamdisk-wdrecovery uRamdisk
    cd /
    umount /mnt/root /mnt/usb
    sync
    reboot -f

Blockquote

somehow it not working for me .



Look at the terminal screen capture you posted. Look at the name of the files. They are case sensitive in Linux. You are missing the upper cased letter in each of the files when you issued the dd command:
uImage-wdrecovery
uRamdisk-wdrecovery

It should look something like this:
dd if=/mnt/usb/boot/uImage-wdrecovery of=/dev/sdc3

oh didnt know its that critical …
i did everything from the beginning with (Fox_exe file archive) direction,
all command work fine on terminal (i hope so)
what do i need to do in 7. ?
take out the USB and HD and connect them to the Mycloud board trying to login for firmware install ?

edit :

all work GOOD ! thx

I have a gen 2 my cloud the hard drive died on. I bought a new hard drive and had been attempting to fix by using the gen 1 instructions which hasn’t worked. I downloaded the firmware of version 4 on a usb this morning I’m wondering if I still need to do the other recovery image and if so could someone send a valid link as the link above took me to a not secure message

Why are you trying to “unbrick” a gen 2 single bay My Cloud hard drive with gen 1 directions? The gen 2 My Cloud uses different hardware and different firmware than the gen 1 unit. The v4.x firmware is not for the gen 2 units, it is for gen 1 only. See my post above for user Fox_exe’s directions for the gen 2 units that some have used to install a new hard drive into a gen 2 single bay My Cloud.

WD for what ever reason decided to confuse people with the firmware version numbering scheme with the single bay My Cloud. V4.x firmware is not “newer” than v2.x firmware. It is just intended for a different device, the first gen single bay My Cloud. Likewise the v2.x firmware cannot be run on a first gen single bay My Cloud.

I had failed to scroll all through the comments to see that there were other instructions. I checked yesterday and saw I have the 2nd gen one.

So today I made the usb with the boot folder and followed the instructions by putting the usb in the my cloud and plugging it in. It constantly flashes red and when I plugged it into my network there is no IP showing as it doesn’t appear to actually boot. The cat 5 shows green flashing light as if data is transferring but my device list of my router shows no IP address sunder that Ethernet port.

So I then tried the second way and used my virtual machine and launched Ubuntu and plugged the hard drive in via a usb mount but none of the usb drives show up in Ubuntu.

Can I do this on my Mac? Does anyone have instructions to do for gen 2 on a Mac using terminal?

Also can someone tell me the proper firmware version I need to download? They have 2,4 or 5 as an option.

As previously explained, the v4.x firmware is for the FIRST gen single bay My Cloud (P/N number ends with “-00”) NOT the second gen single bay My Cloud (P/N number ends with “-10”). The second gen single bay My Cloud supports v2.x firmware. Once one has the latest v2.x firmware installed on their second gen single bay My Cloud one can update that firmware to OS5’s v5.x firmware.

If you cannot use Linux commands with Mac Terminal (not a Mac guy, no idea if it can run Linux commands), one can create a Linux boot disk or boot USB flash drive and boot their computer with it. For example Ubuntu has directions for creating a Ubuntu boot disk/flash drive on a Mac.

Thanks I booted to Linux and was able to partition the new drive without any issues and have downloaded the needed files onto a usb that is plugged in but I can’t seem to find instructions on how to copy the files from the usb to the drive in Linux? I did the cp uImage-Ed recovery /mnt/boot/boot/uImage and get the error cannot stat ‘uImage-wdrecovery’ no such file or directory

How do I write the files from the usb drive to the disk in Linux?

Edit nvm you are using the second method.

Download and unpack files from WDMyCloud/WDMyCloud-Gen2/Developing: uImage-wdrecovery and uRamdisk-wdrecovery
Write it disk:

mkdir /mnt/boot
mount /dev/sda3 /mnt/boot
mkdir /mnt/boot/boot
cp uImage-wdrecovery /mnt/boot/boot/uImage
cp uRamdisk-wdrecovery /mnt/boot/boot/uRamdisk

Done. Connect disk back to WDMC and turn on.
After few minutes WDMC boots to "WD Recovery". Go to webgui and upload official firmware.

You download the two files and while in the same directory as those two downloaded files you issue the commands to copy the files to the previously created directory locations:

cp uImage-wdrecovery /mnt/boot/boot/uImage
cp uRamdisk-wdrecovery /mnt/boot/boot/uRamdisk

File names/directory names are case sensitive.
The two files to download for the alternate method:
https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Developing/uImage-wdrecovery
https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen2/Developing/uRamdisk-wdrecovery

I’m still not sure what command to use by that reply.

Again I have already downloaded the necessary files they are on a usb that usb drive is titled dev/sda

The hard drive I am making the My cloud does not have the downloaded files yet and is titled dev/sdb

Both devices are plugged in. What script do I need to run to move the sda files to the sdb drive to finish executing the last few commands?

Perhaps this screenshot would help?

Generally it is assumed one has some knowledge of using Linux commands when doing an unbrick or can search the internet to learn what the various terms and commands mean and what they do.

You will likely need to use the Linux terminal command: lsblk to list the attached devices (hard drive and flash drives) attached to the computer. With the path information to the USB flash drive in hand one can then mount that USB flash drive to their computer by creating the /mnt/boot folder then mounting the USB drive to that /mnt/boot folder. Then one creates another directory called boot inside that /mnt/boot/ folder. That step creates a folder called boot on the mounted USB flash drive. Then one uses the cp command to copy the two files to that boot folder on the USB flash drive. One then ejects the USB flash drive, connects it to their second gen single bay My Cloud and powers on the My Cloud. After waiting a few minutes one should be able to use a web browser to access the My Cloud (likely by either it’s name mycloud or by it’s IP address). One one accesses the “WD Recovery” page they should be able to load the latest v2.x firmware that can be downloaded from the WD Support web site.

Do not mix each set of directions (main and alternate) of Fox_Exe’s directions.

I did manage to get the files copied and plugged in the my cloud directly to my MacBook via the Ethernet cable but it still just constantly flashes red. It never loads to the wdmycloud.local page

Any idea what to do to fix?

Try to access the My Cloud by it’s IP address if the name doesn’t work.

If it still doesn’t work repeat the unbrick process again. Double checking to ensure the files have been copied to the location indicated on the hard drive.

Edit: Post corrected.

I’m confused as your reply above made it sound like the files needed to be copied to the usb drive and not the hard drive itself?

Also seeing the above post showing a dd command and I’m wondering if that’s what I need to be using to move the files instead of the cp command?

Sorry meant check the hard drive to ensure the files have been copied to the boot folder that one creates there.

Use the steps that are specific to each unbrick method. Mixing commands from different methods can have undesired effects and results. The directions and files to unbrick a first gen single bay My Cloud are not the same as those used for a second gen single bay My Cloud.

Ok I ended up manually moving the files into the boot folder on my Mac and it was much easier. I now get the yellow and red light and have an IP address being assigned to it but when trying to access it via the ip it says jt can’t reach the page since it can’t connect to the server or on my windows it says can’t reach this page the IP address refused to connect. How else can I upload the firmware or access the GUI?!

Thanks for all your help!