[GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud

As the information (parted help) in the screen capture you posted indicates you use rm to remove a partition not the word “remove”. Example: rm 1

yea i got past that the tables aren’t respoding though i will try to do some more digging

apt-get update && apt-get install mdadm parted

where can i get this file

You run those commands in a Linux terminal window. The Fox_exe directions assume one is using a Linux boot disc/USB flash drive or is running some form of Linux. There are numerious free versions/flavors of Linux. Ubuntu is one such popular version that one can download and burn to a DVD or to a USB Flash drive: https://www.ubuntu.com/download/desktop

The bottom of the Ubuntu link has directions on how to create the boot media. One would then boot their computer using that boot media. One one is at the Linux desktop one would then open a Linux terminal window and begin issuing the various commands detailed in the directions.

you have been a great help i got to step 8 but i hit a wall do you know what i am supposed to do here ?

After entering: mdadm --create /dev/md0 --level=1 --metadata=0.9 --raid-devices=2 /dev/sdb1 /dev/sdb2 one would then enter: watch cat /proc/mdstat which will show one the progress/status of the mdadm command. Once it it’s 100% one would then select the CTRL + c keys to close the status and return to the command prompt where you can continue with the remaining steps.

Couple of additional comments. You can choose to use one of the two following files to extract.
Original_v03.04.01-230.tar.gz: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Backups/original_v03.04.01-230.tar.gz
Original_v03.04.01-230.tar.gz: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Backups/original_v04.01.02-417.tar.gz

If you run into trouble with the kernel.img in original_v04.01.02-417 being too large for the sdx5 partition when you issue the dd command. Delete the files extracted from the original_v04.01.02-417 file and extract/use the files from original_v03.04.01-230.

Once you reconnect the My Cloud board to the hard drive and boot/power it on, if it doesn’t boot (after a long wait) to a blue front LED, it might boot to a red front LED. If it does boot to a red front LED try accessing the My Cloud Dashboard (http://wdmycloud or http://wdmycloud.local) and access the Settings page. Then select Quick Restore from the Utilities menu. That should fix the fail to mount content partition error that causes the red front LED.

Once you have a blue front LED one can then proceed to upgrade to the latest My Cloud firmware. If one used original_v03.04.01-230 they can upgrade to v04.01.02-417 before upgrading to the very latest My Cloud firmware. Not sure if one can go from the older v3 firmware direct to the very latest firmware, but one could always try rather than doing the interim step of going from v3.x to v04.01.02-417.

https://community.wd.com/t/wd-my-cloud-v3-x-v4-x-and-v2-x-firmware-versions-download-links/148533

04.01.02-417 (12/17/2014) Firmware: http://download.wdc.com/nas/sq-040102-417-20141211.deb.zip

Latest My Cloud v4.x firmware: http://download.wdc.com/nas/sq-040500-334-20190221.deb

Use data partition as download folder:
mount -t ext4 /dev/sdb4 /mnt
cd /mnt

do you know what is meant by this process

My WD Red 4TB Hard Disks were taken out from MyCloud Mirror and wiped in order to remove sensitive data and re-install them again into the MyCloud Mirror. The unit shows solid red led lights for both disks after then. Factory reset wasn’t help. I tried above unbrick process, still wan’t able to get the hard disk pass the WD MyCloud Mirror Disk Self Check.

I gave up and purchased Synology DS418Play and slide in the two WD 4TB hard drives - now the synology disk station is very happy about them.

Just would like to share with anyone here who has been frustrated and wasted plenty of time to battle with WD’s closed system but failed. You can consider my approach.

Go to the storage section, and then set up raid configuration.

The mycloud mirror is similar to/practically identical to to the EX2. You need to set up how you want the drives to be used.

Hi Ouglee and the community,

Thanks for your guide. I’ve tried three or four other methods but yours seems to be the best. although it doesn’t works on my 2TB.
My WDMycloud blinked blue after a power outage. A short and a long reset were useless. Searching for a solution, i arrived here and i’ve tried some guides.
I must say that i’m not a pro in Linux and my english is poor (i’m French, sorry !)
Step 1 to 6 are OK. I’ve opened the box with this guide without breaking any part.
Step 7. I must add “sudo” before the lines but it works.
Step 8. Ok with “sudo” too…
Step 9. My result is exactly the same
I skip to 18. I connect the ethernet cable then the power. The LED blinks blue during 30 sec. then blinks red. I’ve waited for about one hour without any change.
So i restarted from step 7. At the end, i started gparted to see all the partitions of the disk. Four of them were “unknown” with a danger sign in front of their name. The biggest one (1,8 To) had a danger sign too but was marked as ext4. I’ve formatted it with ext4.
The result is the same. Red Led is blinking. I will wait until tomorrow but i think it’s useless.

What did i do wrong ?

Thanks for your help.

No need for all this Linux stuff…

These images are for the 2 or 3TB Gen1 drives but you just need the right image to suit your drive.

2TB - https://drive.google.com/open?id=1fpnplxqhVh8q4nx6aoHjCBmQITkQFJUo
3TB - https://drive.google.com/open?id=1u21bKSblI486SKwwKCGu92VAg2Lx9riU

Unzip when downloaded to give you the ‘image’ file.

Download this https://www.balena.io/etcher/
Use etcher to restore the image to the new HDD using a USB caddy.
Refit the HDD to the WDCloud and boot, wait for the blue light.
You should now have access to the WDCloud, now run a ‘Quick Reset’ from the WDCloud menu to reset the available storage.

Your drive should now be fully functional.

Succesfully used to upgrade mine from the original 2TB drive to a 3TB using a Toshiba HDD.

Hello, can I use this unbrick tutorial for My Cloud Gen 1 (BCTL)?

I tried already by after performing all steps from tutorial my device not boot correctly. Solid red ligth is displayed all the time.

Where can I find logs which can help me to find the error cause?

On a first gen (P/N "-00) My Cloud if you perform all the steps correctly and get a solid red front LED after booting up the device. Try to access the My Cloud Dashboard. If you can access the Dashboard, then try performing a “System Only” restore via the Dashboard > Settings > Utilities > System Factory Restore section.

1 Like

Ok, I will try, but how can I connect to the My Cloud Dashboard? I don’t use device earlier. I bought WD My Cloud first gen without drive and separate new 2TB WD RED.

I tried using this url - http://files.mycloud.com/setup but any devices found.

This is my partitions view from My Cloud drive. Is everything ok here? In this case I use Fox_exe’s [guide], but using method from topic result was the same (only solid red light).

Model - WDBCTL0020HWT-00

The My Cloud Dashboard is how one configures the various features/options of the My Cloud. See the following WD Knowledgebase Support link for more information on how to access the Dashboard.

https://support-en.wd.com/app/answers/detail/a_id/15104

Generally you would use a web browser and either http://wdmycloud or http://wdmycloud.local or the My Cloud IP address to access the Dashboard. This assumes of course one has the My Cloud connected to their local network via Ethernet cable.

1 Like

Ok, I will try http://wdmycloud and http://wdmycloud.local

But first I must upload image once again because I remove all partitions. Which method do you recommend? Use image from this topic whether use Fox_exe’s guide (https://drive.google.com/drive/folders/0B_6OlQ_H0PxVZTBtM3EyRVhDVms)? If second, which image should I use: v03.04.01-230 / v04.01.02-417?

Use the v04.01.02-417 if you plan on updating to the very latest v4.x firmware on the first gen My Cloud.

There are certain instances where the v3.x firmware is used when running certain unofficial single bay My Cloud modifications.

I have only used Fox_Exe’s first gen unbrick directions when unbricking hard drives (I’ve done a number of them, currently using an 8TB WD Red drive) for my first gen My Cloud enclosure.

1 Like

I used v3.x firmware and Fox_Exe’s first gen tutorial because I started before your reply.

Unfortunatelly it still doesnt work for me. My partition layout is the same like on screen above. When I started device after about one minute solid red light appeared. The same for second attempt. But when I started device for the third time then all the time solid yellow was displayed. After about 25 minutes I turned off device because I thought it took too long.

Below logs from my WD Red 2TB drive (tmp, var/log):

have you tried 40 sec reset? Also try the 4xfirmware then do a quick restore

I need a little help! I have succeeded in getting a new 4TB WD Red Drive mounted in Ubuntu through my Windows 10 Hyper-V. I have it connected by a USB-Sata Connector. I am at the point I believe to set the partitions. At one point in this thread, it mentions using Foxe’s documentation.

I believe that would be this step:
parted /dev/sda
mklabel gpt
mkpart primary 1049kB 2149MB
mkpart primary 8591MB -1MB
mkpart primary 7517MB 8591MB
mkpart primary 2149MB 3222MB
mkpart primary 3222MB 4296MB
mkpart primary 4296MB 6443MB
mkpart primary 6443MB 7517MB

But when I look at another thread where they referenced this, and have a graphic of having done so in Gpart, I don’t see the numbers lining up with the partitions.

I am seeing the drive and am ready through Gpart to do what needs to be done, but not sure what I really need to do. Do these above commands really apply to my current setup and I just type the above exactly as is? My ultimate goal is to migrate to an 8tb drive I have, but figured would start with the smaller.

I have a second generation my cloud. Finally, I see a lot of references to an image, and I downloaded three, 2tb, 3tb, and 4tb. But in Foxes directions of which I paste below, I am not sure where that applies.

Thank you in advance for your help.