[GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud

apt-get -f install

this will force the broken dependencies, maybe fix your build.

continued this problem here:
https://forum.openmediavault.org/index.php/Thread/26303-Install-omv4-on-clean-debian-WDMyCloud-Rev-1-error/?postID=197447#post197447
since it is not a unbricking topic any more. Nothing worked out so far :-(. Thanks anyways!

Further Problem: I wanted to shutdown the board with “shutdown -h now​”. Since it didnt turn off, I unplugged it. Now, after rebooting, I cant ping it, I cant connect. LED is green. Is there any chance to connect to it without complete new installation process?!

At least to started to work with clonezilla to reset the hdd to a clean wdmycloud status without many efforts

Hi, thank you very much for this forum, it helps me put my MyCloud 3TB back from the dead. I use the 2TB image and do exactly as the instructions says and everything is setup perfectly with 3TB capacity.

I have questions though…

a. can I upgrade the firmware to the latest by manually providing the latest firmware (4.05xxx) from WD?

b. how come I cant “see” any shared folder from a Win7 using the explorer. I manually open \192.168.1.10 and it just gave me “windows cannot access \192.168.1.10” error. But I can do webui, and can also connect via FTP. However, using the same Win7 PC, I can see the other MyCloud in my network which is in \192.168.1.20. And from our other Win7 PC can see the shared folder WITHOUT even providing the username/password, it didnt ask until i want to open a non-public folder.

c. Using my laptop Win10, I can see the shared folder, but ONLY after I input a username/password. Is there a way I can see the shared folder, even just the PUBLIC folder, without providing my username/password just like the 2nd Win7 PC mentioned above?

thanks

hi,

after the procedures, the firmware version is 3.x.x, your screenshot says 4.05.x… did you manually upgrade the firmware AFTER you do the quick restore?

Hi jwan. No, I had done the firmware update back in July of 2018. My unit had been having problems for several months before that. It was booting OK and worked somewhat, but I would get errors trying to access a lot of the files and it kept failing the Full Test. WD support was not helpful in helping me determine what the actual system test failure was, even after I sent them logs from two different tests. So I had updated the firmware while trying to figure out what was wrong. Concluded it was a problem with the drive and so then I found this procedure to replace it.

thanks for the reply. Browsing through the forum, there are quite a number of indication that seems to suggest upgrading the firmware is ok. Unfortunately, I did both auto and manual file upload of newer firmware via the WebUI and both doesnt work.

I would like to share this link: WD My Cloud v3.x, v4.x and v2.x Firmware Versions Download Links as it discuss how to do the update via ssh. Since I can not access MyCloud using regular file explorer to copy the deb file, i use the FTP instead. And from there, everything working fine. I am now on the lastest WDMyCloud v04.05.00-334 : Core F/W and is happy now.

I have to add that with this latest version, I am now able to network connect via my Win7 using Explorer (which is my problem above under letter b)

Thanks for the great people out here!

Hello,
I have a 4TB mycloud without a disk and I wanted to put on a 2TB drive, I followed the instructions and it did not work (after 30 minutes still blinking red), the disk image was done correctly, because on the 2TB mycloud this disk works correctly, how can I fix it. Is it necessary to use 4TB for the 4TB version and the smaller one will not work?
Mycloud 4TB model is WDBCTL0040HWT - EESN
Please help.

I suggest seeing this thread.

Many of the steps using virtualbox can be skipped if you use the bootable USB stick method used by fox_exe. (You telnet into the box to create the partitions directly on the mycloud)

The secret sauce is getting the darn thing to set up the JBOD configuration. This is managed with a byzantine web of XML config files that identify the drive by its serial number. A direct image from a different drive will have a different serial number, and so the volume mounter wont mount, and you will have the 0mb free issue.

This is why I suggest doing the “boot recovery media, and then flash firmware” method. This prompts the unit to present the RAID manager, where you can then set up the JBOD config, and all will be peachy keen.

i am having a problem after step 8 here are some pictures and some errors i am getting i have a 4tb hard drive. can anyone please help me!!!?![IMG_0325|666x500]

You’re trying to run parted without specifying which device, so it is defaulting to /dev/sda.

You don’t want it to do that; that’s your computer’s OS disk…

Tell it what device to use instead:

parted /dev/sdd

i did use /dev/sdd on the first picture above this post and i still got an error

dd if=/mnt/usb/mycloud2tb.img of=/dev/sdd is what i typed for step 8

You weren’t specific for which of the ‘some errors’ you wanted help with. I commented on your use of parted, not the dd image copy.

I don’t know what’s causing the dd error, but I note that it only seems to have affected one record. Are you sure the source file is okay?

is this what you meant?

Your photo shows you tried to use /dev/sdb

I could be wrong as I’ve not used mycloud2tb.img file but normally one writes the image file direct to a specific partition. For example: dd if=kernel.img of=/dev/sdd5

On a first gen My Cloud I’ve used the following directions by user Fox_Exe several times with success: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD%20-%20English.txt

The IMG file used in those directions can be found here: https://fox-exe.ru/WDMyCloud/WDMyCloud-Gen1/Backups/

do you know if there is a video tutorial on this method?

No idea if there is a video of this method as I don’t use this method when unbricking a first gen. I use Fox_exe’s method which I linked to in my prior post. In fact just unbricked a blank 1GB drive yesterday using Fox_exe’s first gen directions.

Couple of suggestions. Try partitioning and formatting the drive then test the drive for errors before following the steps in the initial post.

One thing I am finding though is if the superblocks and or GPT information (used for Linux drives and partitions) get corrupted you can run into possible problems trying to push IMG files to the drive or it’s partition. One may need to check the Linux formatted disk for errors and try to correct them, possibly using gdisk to correct GTP or MBR errors.

i meant is there a video on fox.exe method?