[GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud

Hi folks,
I’m trying to unbrick my mycloud gen2 with this tutorial foxys_guide and everything running as expected till the very last step.
When I try to upload the firmware the upload page is hanging at 0% , the red LED stops blinking, and its permanently on. Any idea?
Many thanx!

1 Like

I got a Mycloud board off ebay. WDBCTL0020HWT.
Got a 3 TB wd drive and piut the 3TB image on it.
Magic happened and I got a Blue light.
Trouble is there is on 1.5GB of free space on it . Anyone, can you publish the partition table for yout 3TB mycloud?
min had a 1 mb partition
a 128 mb partition
and a 2.73 TB partition (unformatted)
But the mycloud ap says only 1.5gb free space.

Hello,

Do I really need a CD reader?
We are in 2018, no one has it anymore.

I would like just to see my files, copy them into my other HD and send this MyCloud to RMA.

My files which I know are here, are not shown.

Can anyone help me?

Check the Public folder. Never mind. Didn’t see that the Public folder has 0kb.

If using Windows 10 the following discussion may be helpful if one has removed the hard drive from the My Cloud enclosure and it attempting to read it’s contents.

same issue here. seem to be stuck as any ethond I try to use fail (recovery, USB or load the files to the partition of my 8TB Red directly all fail to get my cloud to stay on blue.)
I have a feeling that its because when I use parted on my linux box and force the partitions when I mkpart primary xxxxx xxxxxx , using “I” to ignore the error:
The resulting partition is not properly aligned for best performance
my partitions are not the correct size or they don’t start with the correct offset.

Try just this steps again. It should work as it worked for me well.

This link

Hi Ouglee, This worked perfect for me! I’ve tried almost all of them and this one worked best for me. I suspect it was the SystemRescue CD that was cooperative. Thanks!

Hi Ouglee and all. Just wanted to add that I had a single drive MyCloud in which the drive was failing. So I followed you’re instructions and was able to install a new 10TB (I’m a go big or go home kinda guy) drive and it’s working fine. I was able to generate an image file from my own cloud and I installed that rather than one from the link(s) posted.

I’m a complete Linux newbe, but was able to follow your instructions just fine. I did have two differences from your instructions. First I did not get the error (step 14) and it did ask for an ending block number. I entered the 3TB number 5860533134s supplied by zelig (thanks zelig) so there was a lot of unallocated space. Like some of the others, I just went into gparted and expanded EXT4 to use the remaining space. Boot up mycloud and
it was showing 0 for available space and diagnostics showed drive not mounted. So I did a quick restore and it then show 9.8TB

In this screen shot it shows 9.6TB because I had already loaded a bunch of files.

If anyone is interested, here’s what it looked like once I finished expanding the EXT4 partition (sorry for the picture quality, it’s a phone picture of my monitor):

So thanks again for making such a good guide.

Sorry, previous post dropped my partition stats screen shot.

I am glad you posted this, Recovering from a brick is rather simple so even if your a novice linux person dont frey away from a brick, You might be glad you did. I plan on writing script that will pull them with wget of and fully automate this since WD is just to busy these days to have one of there many coders (hey Craig!) to devote 1 week of copying D-Link src code and make it there own. Just saying…Also I have a mirror of Fox’s Code on my site if for whatever reason links are down. www.hackerz.me
brannon@brannon-EL1352G:~$ uname -arn
Linux brannon-EL1352G 4.18.0-13-generic #14-Ubuntu SMP Wed Dec 5 09:04:24 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

What is different about the D-Link src and the WD My Cloud src?

:grinning:strong textI was poking fun, the default admin password for the backdoor on the my cloud devices came from a dlink product

Hello and thanks for your guide. Since I have a WDMyCloud-Board left without harddisk and I would like to have a small music server in my caravan: Do you think it is possible to plug a 512gb ssd into the MyCloud? Is there a way, because the smallest wdmycloud is 2tb.

Thanks and regards

yes, if it is sata it work!

Nice, thanks for the fast response. I have an old Sata hdd with 512gb, I will make a test setup with that before purchasing the SSD. Will hopefully report when I succeeded.

Hi,

since the the link in #1 didnt work, I downloaded an image from a youtube video and followed you instructions.

With 512gb HDD: It works up to 14, in my case it says: Invalid argument during seek for read on /dev/sda Retry/Ignore/Cancel. I entered “ignore”
After this step/message14 happens, I can enter “OK”, but after that, I dont see the “15 message” I cant list any partitions or anything. Windows does see the partitions, the last one is bigger than the whole disk…
The wdmycloud doesnt make ANYTHING with this harddisk

With 2tb HDD:I do 1-10, then continue with 18. The wdmycloud does have white light, then a red one, nothing happens more.

My Board Part Nummber is 4061-705144-001 rev.02p
It should be a Rev1 WDMycloud. Do you have another image or perhaps any hints?!

Thanks and regards,

red means image isnt mounted , try this. http://anionix.ddns.net/WDMyCloud/WDMyCloud-Gen1/Replace%20HDD%20-%20English.txt . Download Ubunto on a usb stick, boot from it, then perform the above

1 Like

Thank you very much. Made it. made a factory reset after booting, after that, HDD size got recognized. So I think with a ssd, I will have a shake-resistant NAS inside my caravan, I am happy, thank you!
I installed 4.01… Now I am testing the update