GUIDE FOR PROPER NETWORK SETUP in XP that should resolve every WDTV LIVE network issue


#1

The following guide applies to WINDOWS XP, but every principle of getting the firewall/router, windows services, and User Permissions setup properly are the key stumbling blocks that applies to all versions of Windows to be successful in networking with WDTV LIVE.

  • Make sure you have Network DDE DSDM and Network DDE set to automatic and started in your SERVICES. 

  • Also very important, make sure you DISABLE your firewall SERVICE in Windows.  Not the check box in Windows that disables the firewall.  That alone won’t do it.  You have to disable the actual firewall SERVICE called “Windows Firewall/ Internet Connection Sharing (ICS)” located in your SERVICES.  Don’t worry about your security.  That windows firewall is only good for LOCAL traffic.  It provides minimal to almost no security from the internet.  Having this SERVICE on could give you a headache with your WDTV LIVE.  And with routers nowadays, rarely does the average person need ICS either.

One note I should mention which I haven’t tested yet, is that I believe the “Computer Browser” service  also needs to be put to AUTOMATIC and started.

Ok, moving on…

  • Turn Guest account or a user(s) account you created to ON

  • In your router config settings, do not use the DMZ in application support (port forwarding).  Forward ports for each application or device in application support (port forwarding) instead. If you don’t know how to do that, don’t worry.  Here is a website that will guide you for your EXACT ROUTER/ROUTER MODEM YOU OWN on what exactly to do. Pictures are included for every single step of what you will be doing inside your router or modem/router settings.  This website is at  www.portforward.com.  Scroll down, select your modem and the rest you can almost do with your eyes closed.

This next part is optional, but may be necessary if you are also rrunning media servers/plugins. So, at the same website goto “Port List” and the same tutorials w/ pictures will guide you on opening up ports in your modem/router settings for your addons like Tversity for example, and Crackle, a Playon plugin, and other things you may have connected to your network.  Ok, we are done for the router settings.

Now you need to setup your USER PERMISSIONS.  Very important you get this right.  But beforehand you need to disable “SIMPLE File Sharing” by clicking…

. Scroll down and UNCHECK the box “Use simple file sharing”.

moving on…

-  Because most wouldn’t know which user or users to select to give PERMISSIONS to, just to be sure to get the right one, do the following steps below for each USER in your shared folder, 

1 - Right click the folder  in Windows explorer you want to share on your network

2 - Then click on “sharing and security”, then click the “sharing” tab.

3 - Make sure Sharing is enabled

4 - In same window click on PERMISSIONS

(NOTE: Before adding users, write down what users are currently there now before adding more users)

5 - Then click on ADD

6 - Click ADVANCED

7 - Click FIND NOW

8 - Highlight the USER for WDTV Live

9 - Click OK

10 - Click OK again

11 - Now you are back in the PERMISSIONS window. Select the USER that was just added to the PERMISSIONS window and allow aREAD ONLY permission  by placing a checkmark in the READ box leaving the otther boxes unchecked.

Then reboot the modem/router first because of the changes made, then the PC or PCs, the WDTV LIVE in that order. After that it won’t matter which order you boot up unless you make drastic changes as indicated above.

Doing all these steps should resolve just about every network issue you may have with WDTV LIVE connected to your network.  Let me know how well you did.

UPDATE 14/02:

INSTRUCTIONS WERE EDITED SINCE FIRST POSTED…

ptricks was good enough to point out that giving ALL permissions and adding every USER is not a good idea. I agree, so I would suggest that instead of adding every USER you see, just add one USER at a time to see if your WDTV Live  works properly on the network with the shares/ media server.  Doing it this way is a longer process going through all the boot process until you find the proper USER, but it is a much better way that won’t run you into other kinds of problems down the road.

And I also agree with ptricks, give only READ permissions when you are adding a USER to your permissions for WDTV LIve.

Thanks ptricks.


#2

There is no need to add every user and especially not to give every user full permissions.

The only required for the WDTV Live to access files is for READ access to be enabled. Everything else it does not need to have permission to stream files. Enabling everything just because you don’t know what to enable will end badly.


#3

No info provided as to how to find these things to turn on or off… any help would be appreciated


#4

Click ,

Start,

Run,

Services.Msc


#5

Wow, this all seems so complicated.

I did the first part in Services regarding Network DDE DSDM and Network DDE set to automatic and started, disabled Windows firewall and made sure the Computer Browser was set  to automatic and started also.

What is the significance of the guest acccount/user account and how do I turn that on?  Do I need to?

I went to portforward.com and could not find a any help for the PlayOn plugin.  I really don’t know what other ports I would forward.  I only play a couple of online games -BF2142 and BF Heroes (which is browser based).  Any suggestions about common applications which would need port forwarding?  I am just an average Win XP user.  I use the WDTV Live to access the PlayOn server and play Windows Media Center recorded tv shows on my HD TV.

I unchecked the box for “Use simple file sharing”.

When I go to add permissions for other users I don’t see a user for the WDTV Live, just my local computer.

I would appreciate your help.

Ron


#6

Sounds like you missed Step 5.


#7

Read the special note in step 4, then do step 5 and you will see all your USERS on your system


#8

I gotta say this has made a HUGE difference for me. I thought I had it set up well but I was getting drop outs within the first few minutes and it was driving me crazy. Now its perfect…I mean perfect. I was testing it out all day and so far everything is running solid with no interuptions.

I will say it is too bad so many tweeks need to be done to have this wdtv live to work the way you want it…but now I am no longer yelling at the tv.

Thank you!


#9

On Step 8, which USER is that exactly…What USER is the WD Live user???

And this is unclear: ‘Turn Guest account or a user(s) account you created to ON’

I turned Guest Account on, but how about giving some more info…Should we create a separate user for WD LIVE???..

And I couldn’t make heads nor tails about that port forwarding…why would you need to forward ports?

And no, I don’t see any network shares either on the WD Live unit…And I’m a halfway savvy guy when it comes to networking and this stuff…but it’s a mystery to me why it doesn’t work…

I think if you’re gonna post a tutorial, you’re gonna have to go into more detail on exactly what people are supposed to do…Like I said, I’m somewhat savvy with this stuff, and this tutorial is lacking…z

PS. I’'ve got read permissions for Everybody, and STILL don’t see the shared folder…bunko…

…z