[GUIDE] Beautiful Directory Listing for Apache File Server Sharing Public Folder (h5ai)

MyBookLive:~# ln -s /shares/Public/ /var/www/public/
ln: target `/var/www/public/' is not a directory: No such file or directory

 You need to get rid of the trailing / after ln -s /shares/Public/ /var/www/public/ in your guide

ln -s /shares/Public/ /var/www/public

<MBL_IP>/public

Works like a champ! Thanks for the tut Timmy :slight_smile:

Will see about those missing options in the coming days

I edited the json file and enabled renaming as it is something I would like to do in that folder. Once I highlight a folder, where do I go to rename it?

I’m glad you confirm it working nfo! Is not a great guide as yours, but it’s just a little homage :wink:

About the renaming, I don’t know where to rename neither. If you saw, in the json documentation for renaming it says “No GUI yet.”, so maybe the developer haven’t implemented it yet? And according to  this thread on the sources forum, it seems that a GUI for renaming is not still defined.

Hopefully we can work out on those missing “unsupported” options! I’m afraid that PHP-GD might be more difficult, as I’ve read a thread in MyBookWorld.wikidot (which I can’t find now), saying that a guy installed it but needed to rebuild php himself, as gd had to be enabled in the php installation or something along those lines. 

Yes I did notice that in the json file and that was my guess as well. Excellent job on the guide :slight_smile:

After a lot of trial and error I’ve updated the guide with the Apache redirect script! :smiley: It should now redirect every request from the internet that’s happening outside the public folder, to the public folder. When you are on your own network, it’ll resolve to anything you type in.

Please try it and try to “break it”, i.e. going someplace else and not being redirected to public when you are on the internet (not on your LAN), so I can improve it.

Enjoy!

This is good! Will have to give it a try. In my case it would result in avoiding installing mobile apps such as “ES file explorer” to access network drives, it should even work for IOS.

If upload option was there would be perfect. :slight_smile:

There’s an upload option, you have to enable it in the configuration file. :wink: Although it’s still experimental, it might work

I added the loopback adapter in the guide in the redirect script because some of the UI dashboard tabs weren’t working.

There you go Timmy

1 Like

D a m n, you got the all green, nfo! :smiley:

Sooo… please correct me if I’m wrong, but you got there by doing these:

  1. You ran the brick protection script for apt-get

  2. You installed the php5, php-gd, etc; all that stuff from OwnCloud thread

  3. You installed ImageMagick

4*) Zip & Rar PHP got installed somehow (¿?)

… and that’s it?

What are the cons of installing php5… more memory consumption, disk space used, something like that? As you know, I refrained from installing it because of all the stuff it modifies, but I’d be quite happy to have my H5AI all green too :stuck_out_tongue:

BTW, did you tried it with any PDF? How does it work, as an image thumbnail, similar as any picture?

Thanks man!

Yep all the steps just like you said. I noticed in your post in the OwnCloud thread that you were installing from the wheezy repo. Mine actually installed from the squeeze repo as wheezy is commented out in my sources.list

As far as cons, more disk space for sure…

I will try a pdf now

PDF shows a thumb of the first page of the PDF and when you click it it opens right up full screen

Did a reboot just to make sure everything was still in check. All mods are working and dashboard is working.

Looks like you have a guide to edit when you get debricked :stuck_out_tongue:

top - 16:08:28 up 7 min, 1 user, load average: 1.03, 1.22, 0.68
Tasks: 86 total, 1 running, 85 sleeping, 0 stopped, 0 zombie
Cpu(s): 0.3%us, 0.7%sy, 0.0%ni, 99.0%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 253632k total, 243520k used, 10112k free, 59840k buffers
Swap: 500608k total, 19584k used, 481024k free, 50176k cached

Hello,

 I need a little help about it.

 I downloaded the WAMP server. Install, and implement H5Ai. After i made a new directory:

 “Árvíztűrő tükörfúrógép”

 And this is how its look like in browser:"%C1rv%EDzt%FBr%F5%20T%FCk%F6rf%FAr%F3g%E9p/"

 And after i click on link get Access Forbidden error.

 If delete H5Ai, than folder is ok, and i can open it.

Thank you,

Beautiful indeed!!! and good job!!!

I would have a request, well, actually two…

  1. could someone put some order in this guide? it’s a bit confusing, especially when it comes to trying to get all “green” working functionalities (as nfo did).

  2. would it be possible to use this template to access all of MBL shares from inside LAN, rather than from outside LAN? I am saying this because I usually remotely access my MBL through OpenVPN

Thank to anybody reviving this thread!

ok, I tried out this… looks gorgeous, but runs slow…

tried to remove it making a restore (while saving my data), but http://MBL-IP/public is still accessible, meaning the h5ai is still there… now, I found out that after the resstore, the set up is creating problems to my wd2go remote connection: any way to remove h5ai completely?

any help is greatly appreciated! thanks

Thx! this is cool guide!

but i want separate this, and wd dashboard using port .

i want use this service on port81, 

how can i do?

hm, now i can use change 81port.

add listen 81, and make file  site-enabled/public  

<VirtualHost *:81>
ServerAdmin webmaster@localhost

DocumentRoot /var/www/

<IfModule mod_rewrite.c>

configure landing page for webdav applet

RewriteRule ^/LandingPage /Admin/webapp/htdocs/securityCheck.php [L,R]

additional environment variables to pass to CGI and SSI

any way to use DocumentRoot/DOCUMENT_ROOT???

SetEnv __ADMIN_API_ROOT /var/www/Admin

Options FollowSymLinks AllowOverride None

<Directory /var/www/>
Options -Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all

<Directory /var/www/public/>
DirectoryIndex index.html index.php /_h5ai/server/php/index.php

block application folders from being served

<Directory /var/www/Admin/webapp/config/>
Order deny,allow
Deny from all

<Directory /var/www/Admin/webapp/classes/>
Order deny,allow
Deny from all

<Directory /var/www/Admin/webapp/includes/>
Order deny,allow
Deny from all

#block access protected files (php/ini files)
<Directory “/var/www/Admin/webapp/htdocs/protected”>
AllowOverride None
deny from all

comment this line if remote WebUI access is needed (WAN access)

Include /tmp/allow.conf

<Directory “/var/www/UI”>
RewriteEngine on
RewriteBase /UI/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^$ app/webroot/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) app/webroot/$1 [L]
php_value memory_limit 1G

i can connect mybookip:81 and h5ai is run!

but symbolic link is not work.  and click that, showme permission error page ,

how can i do?

this was funny: I just re-updated for the nth time MBL before getting it bricked… by change I placed the files and folders of the “_h5ai” folder inside a share… then went to the browser and typed http://mybooklive/myshare, inserted the credentials (webDAV credentials, see here how to set them up: http://mybookworld.wikidot.com/forum/t-593394/streaming-ms-office-files-over-remote-mybooklive#post-1627270) and, behold, this was the result:

of course, PHP GD is not installed, as I am coming from a fresh install of the firmware…

it would be interesting if, using this trick, one could access the files inside the shares…