Guess what? Slow transfer speed over GigaBit-LAN

Hey guys

I’m having trouble with my speed too. I get about 3-4MBps wireless and 10-20MBps wired. I read quite a few posts on this, tried all the solutions, but nothing’s working. Here are some numbers:

I’m on a GigaBit network. Router (Linksys E4200) is gigabit, my laptop is gigabit, and Windows confirms the connection is gigabit.  However, after using the LAN Speedtester recommended on one of those posts, it gave me the following results: about 120-140 Mbps upload and 280-290Mbps download. (I’m talking Mb, Megabits here). 

I know that GigaBit connections will only grant you about 120MBps transfers, but I’m getting 120Mbps.

I disabled jumbo transfer, my cables are all Cat 5E (in all honesty, I did pull them out of a box in the attic). 

I’m lost here! I have no idea what else to do to improve my speed. I went through all the options in the WD My Book Live control panel, found nothing of use there. 

Is it possible it’s still the cables? Is it worth buying new Cat 5E/Cat 6 cables just to try?

Can’t wait to hear from you guys.

See if this helps you at all:

1 Like

Thanks a lot for the quick reply, the post helped to some extend.

I ran the error.bat when connected through my router, and when connected directly to my NAS. These were both upload (PC to NAS) tests, since this is the biggest issue. 

The direct connection definitely had a better result: about 61 IPv4 segments retransmitted vs 7 when connected directly.

But, there are two “buts”

  1. Well first off of course, I still get 7 retransmissions when connected directly.

  2. The transfer speed was the same for both set-ups. It was about 13-15MBps in both instances. This makes me think that even though it seems to be my router, it really is not. 

Does this ring any bells for you/anybody else? I’m starting to get more and more desperate :cry:

Dumb question perhaps, but:   Is your PC up to the task?   Open the process manager and see what the CPU utilization is when doing a file copy.

Keep in mind that File copies are SINGLE THREADED.   So you need to look at each CPU individually if you have a multi-core CPU.

So if you open up the Windows Task Manager, click the Performance tab.

On the top row, you’ll see “CPU Usage” which is the average across all cores combined.

Next to that (to the right) you’ll see a graph for each individual core.

If, while doing a copy, any one of those boxes’ graphs get close to the top, you’ve exhausted the CPU on your PC.

Another test you can try is to do TWO copies simultaneously.   Is the combined throughput faster than one?  Or do both copies slow down to roughly half of what ONE copy was before?

since you seem to have all devices connected at 1gig, I would double check again if I were you. BTW… you will never get 125 MB/s. At least not yet.

However, yes, you are limited by the hardware. Here is an easy to read doc, a bit old, but the consept still applies. Hopefully there will be a new one out there, or if someone knows about one, let us know.,2321-3.html

And for wireless:

I think I may have found the culprit. My CPU is fine, although I haven’t been able to split my graphs into two processors (hooray for Windows 8) but my HDD is maxed out at 100% all the time. I’ve noticed my HDD is slow before, so I think that this might be the problem. I guess I’ll have to install a SSD after all.

Perhaps, but possibly not…

Open the Resource Monitor and see what program(s) are maxing out your HDD.

It’s a few processes, all listed as “System”. They vary in performance use.