Grrr MEDIA SCANNING again ? One particular external disk crashes WDMC when plugged in

Trying to plug in a Lacie 3TB externally powered disk, into a high-end also externally powered USB hub, hub being connected to the WDMC and also having one more harddrive connected to it.

Everything works fine, except when this disk is plugged in, everything stops. WDMC is unresponsive until I pull the power plug, detach the offending disk, and restart. Anyway, how real are those warnings about “high risk of losing data if you don’t follow appropriate ejection procedures” ? WDMC in this case offers no “proper” way of doing it anyway (another stroke of genius).


  • reformatted the Lacie disk, NOT quick-format, then copied the entire 3TB back onto it, exactly same result. Took about two days of sustained atttention all up, but that’s ok, WD. 

  • Tried different USB hubs (two or three brands, names escape me atm sorry)

  • Tried ditching the hub and plugging offending drive directly into WDMC

… and I tried a few more things I can’t remember at this hour. Oh yeah, I think I had a friend plug it in for me, so I could IMMEDIATELY use the split-second before the crash to attempt to disable all “media scanning” things from the Dashboard and in Twonky. Played around in Dashboard/Twonky a bit, but useless really because neither of these are accessible soon as the disk is plugged in. 

So, no luck - 

I think I recall hearing about similar problems when I followed the forum more closely last year. 

The disk has about 3TB of music files, MP3s and FLAC, I may be way off but I think it’s something like 250.000 files total.

Could the reason it stops responding is because it is slowly going about it’s business scanning those files ?

So - 3TB, 250.000 files - should I just leave it and hope it comes back ? I REALLY need that disk to work through the WDMC. If I just wait and hope for the best - any idea how long it may take ? It’s all cat6 cables, USB3 cables/ports, brand new disks (all from last six months or so), and internet connection is 55Mbps down / 52Mbps up. 

GREAT MOVE WD, LET’S HAVE THE ENTIRE PRODUCT BREAK DOWN if you use one of it’s sooo-easy-to-implement, lower-profile features such as plugging in an additional HD.

Coincidentally, I just bought the Asus rt ac 68 u Router around the same time as the WDMC. Without me having any idea about it, the two USB ports on the router and the AiCloud system that Asus uses is basically exactly the same as the WDMC - except it has no desktop app and is slightly, but only slightly, trickier to set up that WDMC is SUPPOSED to be, and WAY easier than WDMC actually is to set up :slight_smile:

Hope someone can offer any solutions - thanks!

QUICK EDIT: Error messages are - in Android app “Device not accessible (0)”, through it is “the site is too slow to respond”, the desktop app has never worked and I’m working with customer service on that soon as I can get around to doing the not insignificant diagnostics/data gathering etc. they’ve asked for. 


Hello SophieH, sorry to hear you are having problems. As a troubleshooting step, have you tried using another USB hard drive or memory? 


it may be that you might better need an external power supply for your USB-HDD?




Yes, tried factory reset, tried different USB hubs, all powered - only one “STLab Superspeed USB Hub” USB3 hub has shown any hope of working - still not stable, usually on connecting harddrive (Seagate Fast 4TB USB-powered) the MC drops off and becomes unreachable from anywhere - no dashboard, cannot reach it with install software, nothing.

Using the Fing android app, however, it is able to see the device still, can “ping” it and interact with it in various ways I don’t really understand. But Android MC app does not see it.