Green wd10ears broken -out of a MBWE blue light - trying to recover data

H all,

Must be 4 or 5 months ago now I was copying data between two My Book World Edition when the destination device became unresponsive and all data was unavailable. Unfortunately I had it configured in RAID0. The data is all video content so it isn’t going to be the end of the world if it remains lost but there is about a year and a half of downloads that i am very keen to recover.

The MBWE having two drives, I’ve analysised the HDD using WD data lifeguard and identified the drive that is broken.

I’ve used UFS Explorer to read the EXT3 partitions, I can successfully attach the two drives to a PC and view and read the Linux OS files on the smaller partitions by recreating the array. Of course the 900 and something GB partition where all the data is is not accessible.

I purchased a WD20EARS to dump a partition image to, the backup must have taken two months, that it not a typo! It seemd to finish successfully - it just stopped one day and had not thrown an error. I tried to copy the image to the local C drive but very very frustratingly that new drive then also seemed to fail.

When I try to read from the drive using various recovery software, they all seem to read the first 200,000 or so blocks fine, then it slooooowwwwws right down. The failed drive does not make any strange noises like i thought it would if there was a physical failure which is encouraging!

I really don’t know what it is that has failed on this drive, WD data lifeguard reported an entire drive of bad blocks.

Anybody got a recommendation on how to read data off a stubbirn drive? If I can recover the 900GB partition I should be able to recreate the raid 0 array using ufs explorer and read the data

Thanks in advance,



If the drive is seen by a Linux computer you could try to recover the data, otherwise you need to contact a Data Recovery company.

 Hi, i have a similar problem with a WD10EARS-00Y5B1, windows 7 started to tell me that needed a check, after that some of my big files showed up with 0 kb. I tried various Data Recovery Tools for amost 20 hours, but everithing was slow, after rebooting the system it took almost an hour for windows to start and everithing was sluggish.

I burn up a hiren 14.0 cd and start trying to get mi disk back but tools like Hdd Regenertation or HDAT discovers bad sectors after the first 420 mb and then it comes to be real slow. Some tools says that it will end in 3000+ hours.

i never read about wdidle and IntelliPark, so i didn’t know it could cripple mi disk on the long run. I used this disk for 1.5 years as a secondary storage device.

Tonight i’m gonna use wdidle to see if it speed ups the disk and try recover my data.