Green Caviar: High Load Cycle Cout after short operation time

A quick update since my original post

http://community.wdc.com/t5/Desktop/Green-Caviar-High-Load-Cycle-Cout-after-short-operation-time/m-p/46240#M2346

Since disabling the autoparks with wdidle3, the load cycle rate has greatly dropped.  As many people have said, hitting the 300,000 cycle limit doesn’t neccesarily mean your drives are going to fail, but it certainly makes me feel better to see that this cycle rate has dropped

Thr Sep 30 17:48:21 ADT 2010

for device in a b c d e ; do smartctl -a /dev/sd$device | grep Load_Cycle; done

193 Load_Cycle_Count        0x0032   144   144   000    Old_age   Always       -       169894

193 Load_Cycle_Count        0x0032   144   144   000    Old_age   Always       -       169826

193 Load_Cycle_Count        0x0032   144   144   000    Old_age   Always       -       170142

193 Load_Cycle_Count        0x0032   144   144   000    Old_age   Always       -       170283

193 Load_Cycle_Count        0x0032   144   144   000    Old_age   Always       -       170040

I’ll post back in another month with updates.  Note, these drives are installed in a Synology 1010+, for anyone wondering.

dwight.

supra wrote:

OK.

So you’re confirming that WD Caviar Green drives can NOT have “intelli-park” turned off?


bill_s wrote:

Correct.

Thanx for clear answer. I brought my new WD drive back to shop and change it to Seagate :smileyvery-happy:

Wolfeus wrote:

supra wrote:

 

OK.

So you’re confirming that WD Caviar Green drives can NOT have “intelli-park” turned off?

bill_s wrote:

 

Correct.

 

Thanx for clear answer. I brought my new WD drive back to shop and change it to Seagate :smileyvery-happy:

Funny. I did the same thing - my four WDs went into a backup machine, replaced them with 4 samsungs. No problems with the sammys so far.

Hi, Will the wdidle3 app work on my 808.8gb Green Caviar hard drive? Model number - WD8088AADS Cheers G

So, after another month or so, here is my current Load_Cycle count.  Admittedly, i’m not sure if this cylinder parking is the same “intelli-park” you guys are referring to above, but certainly the increment count on this has gone down greatly since I turned off the feature with the wdidle program

dwight

terra> date

Mon Nov  1 18:06:16 ADT 2010

terra> for device in a b c d e; do smartctl -a /dev/sd$device | grep Load_Cycle; done

193 Load_Cycle_Count        0x0032   144   144   000    Old_age   Always       -       169897

193 Load_Cycle_Count        0x0032   144   144   000    Old_age   Always       -       169829

193 Load_Cycle_Count        0x0032   144   144   000    Old_age   Always       -       170145

193 Load_Cycle_Count        0x0032   144   144   000    Old_age   Always       -       170286

193 Load_Cycle_Count        0x0032   144   144   000    Old_age   Always       -       170043

terra> 

Hello,

just to point that out:

bash-4.1# smartctl -a /dev/sda | grep Load_Cycle
193 Load_Cycle_Count        0x0032   056   056   000    Old_age   Always       -       434823
bash-4.1# smartctl -a /dev/sdb | grep Load_Cycle
193 Load_Cycle_Count        0x0032   058   058   000    Old_age   Always       -       426882
bash-4.1# smartctl -a /dev/sdc | grep Load_Cycle
193 Load_Cycle_Count        0x0032   056   056   000    Old_age   Always       -       434959

Model Family:     Western Digital Caviar Green family
Device Model:     WDC WD5000AADS-00S9B0

All three drives have reached the “minimum”, which is 300 000 for these discs. The Power-On-Hours are around 5770 hours (which is, if i calculated correctly, 240 days, 8 months = less than a year) - However, smart checks show no error, the discs are still running fine.

You might want to add settings like this to your /etc/smartd.conf:

/dev/sda -a -o on -S on -m wdp -s (S/…/…/./07|L/…/…/6/08)
/dev/sdb -a -o on -S on -m wdp -s (S/…/…/./07|L/…/…/6/08)
/dev/sdc -a -o on -S on -m wdp -s (S/…/…/./07|L/…/…/6/08)

just google a bit to see what which params are doing; in general these lines are checking your discs (sda, sdb and sdc in this case) regurlarly. You’ll see something like this if you run smartctl -a, near the bottom of the output:

SMART Self-test log structure revision number 1
Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error

1  Extended offline    Completed without error       00%      5780         -

2  Short offline       Completed without error       00%      5777         -

3  Extended offline    Completed without error       00%      5773         -

4  Short offline       Completed without error       00%      5771         -

So, currently nothing to worry about i guess. However - Just to make sure, you might consider setting up a raid with those discs. I did the wdidle3.exe thing yesterday, worked fine with that discs. So, yes, here it did work with the Green Caviar ones. And another side note: This is not dedicated to WD Discs; some other vendors and especially notebook/netbook discs, show the same behaviour to save power, and the linux kernel (probably, im not sure) due to dirty writeback is waking the discs up every 30 seconds. Remember, these discs are made to be energy-saving/efficient, so your real job is to make your OS to let them save as much power as possible. Means: Enable laptop mode, Disable atimes, set good powersaving, disable frequent logging or put it onto a ramdisc, just try to make your discs as much idle as possible.

So things, which you might also try:

/etc/fstab

take a look at your /etc/fstab and add “noatime” to the disc(s)/partition(s), for example:

/dev/sda5    /    ext4    defaults,noatime       0 0

This won’t update the atimes everytime, thus your disc can sleep longer.

Laptop mode

This will try to merge some writes, thus the chances for your disc to sleep increase.

echo “1” > /proc/sys/vm/laptop_mode

Dirty writeback

This causes the system to clear the cache of the discs (if i understood it correctly) every 5 seconds. Higher it to 10 minutes but be aware: If your system crashes, the last 10 minutes arent saved.

echo “x” > /proc/sys/vm/dirty_writeback_centisecs

replace X with your value (remember, its in centisecs)

Other stuff

disable hal-polling, i saw that the wd discs got a jumper to enable/disable powersaving, maybe you have to set the jumper (if hdparm -B and -S aren’t working) to get more powersaving, put your logs onto a ramdisc, which you write back to the real fs when you reboot or shutdown.

Theres much stuff you can do, to have your discs saving power - Just think about it, the real cause for this problem is that the linux kernel is waking the discs up too often and the wd discs are parking the heads too early. So you can argue both: it’s the linux kernel’s/distributions/package-fault and it’s the fault of wd discs with their (way too) low value of 8 seconds. But: You bought those green stuff to save power, so why aren’t you tuning your system to do so? :slight_smile:

Hello

I changed idle time to 240s, using tutorial by superstar. Now my WD20EARS seems not to park heads at all. Whole day passed and it didn’t park even once. I changed time back do default 8s, but it didn’t affect behaviour of HDD. I use it as external backup disk so it’s not used by system and should go idle quickly, it used to be that way.

Any ideas? :wink:

UPDATE
This is very strange. After running DLGDIAG quick test my HDD started parking after 8s again. So now it seems to be fine. Still I don’t know if I should lenghten idle time with wdidle3 :frowning:

So, how do I run widle3 (assuming I’m brave enough) on a WD15EARS mounted in a ReadyNAS Pro? 

ScottES - be brave - I just pulled the drives out of my ReadyNAS Duo to do this on Friday - no issues.

Basically, you need to pull the drives out of the ReadyNAS and hook up to a PC, boot in DOS mode (use USB key method previously posted by superstar on page 6), and then run wdidle3 - it won’t hurt your data.

I did this on 4 WD 1TB drives I have in the ReadyNAS and a Stora. On the ReadyNAS drives (both WD10EARS) the timeout was set to 8 seconds initially and I disbaled. On the Stora (1 WD10EARS and 1 WD10EAVS) it had been set at 300 seconds (5 minutes) - the EAVS came with the Stora and I purchased the EARS - both 6+ months ago, so maybe that was the setting they were shipping with earlier?

Anyhow, I performed the wdidle3 with each of the drives individually (each part of a mirrored set), put them back into the ReadyNAS and the Stora and there were no issues. On the ReadyNAS, the LCC was 4000 and 4500 on the disks after 6 weeks of intermittent (very low)  use prior to wdidle3, since then it’s only gone 10 higher in 2 days.

I tried various commands with the WDIDLE3 Version 1.05 when i did wdidl3.exe /D the the message was that “IDLE3 THE TIMER IS DISABLED”

then i reset after few seconds and my WD disk WD15EARS-22Z5B1 model began to increase load cycle count and it’s sound was repetitive and it was increasing (before of this i not even knew how the sound of load cycle count was alike)

to more +200 LCC till windows 7 x64 ultimate complete start and startup loading was over, i saw it in HdTune program and i thought to immediately restart windows ,use free dos boot cd  FreeDOS OEM Bootable CD-ROM (i was using a tdk cdrw rewritable for boot) and change the settings to WDIDLE3.EXE /S300  ,(the default settings at the beginning was set to 8.0 seconds), now everythings seems to be ok,  i think is not possible to use the /D  command argument with ‘wd15ears’ model ,you can try … waiting various minutes before restart from that freedos.  i have now 128 start/stop count and 1039 load cycle count (i have this hard disk from more than 4 months) and i think this will be hardly increased. i have to try also an external WD 640gb wd ‘6400aaks’ sata2 16mb caviar blue and to check its LCC count, i don’t know, i use WD15EARS as single only internal harddrive/disk (over a LG cdrw  burner ,both sata2 ) in this pc, and i 'm satisfied of its speed also for games and programs. :smiley:  i hope this problems is resolved. bye

If you want FreeDOS OEM Bootable iso image with WDIDLE3 Version 1.05 inside, i put it to megaupload now then i give to u the link, you’ll have to burn in an empty cdr or cdrw and boot the system from it.

HERE THE LINK : http://www.megaupload.com/?d=L6WMSEVC

i wanted to quote this message :

hogis wrote:

Hello

I changed idle time to 240s, using tutorial by superstar. Now my WD20EARS seems not to park heads at all. Whole day passed and it didn’t park even once. I changed time back do default 8s, but it didn’t affect behaviour of HDD. I use it as external backup disk so it’s not used by system and should go idle quickly, it used to be that way.

Any ideas? :wink:

UPDATE
This is very strange. After running DLGDIAG quick test my HDD started parking after 8s again. So now it seems to be fine. Still I don’t know if I should lenghten idle time with wdidle3 :frowning:

meow81 wrote:

I tried various commands with the WDIDLE3 Version 1.05 when i did wdidl3.exe /D the the message was that “IDLE3 THE TIMER IS DISABLED”

then i reset after few seconds and my WD disk WD15EARS-22Z5B1 model began to increase load cycle count and it’s sound was repetitive and it was increasing (before of this i not even knew how the sound of load cycle count was alike)

to more +200 LCC till windows 7 x64 ultimate complete start and startup loading was over, i saw it in HdTune program and i thought to immediately restart windows ,use free dos boot cd  FreeDOS OEM Bootable CD-ROM (i was using a tdk cdrw rewritable for boot) and change the settings to WDIDLE3.EXE /S300  ,(the default settings at the beginning was set to 8.0 seconds), now everythings seems to be ok,  i think is not possible to use the /D  command argument with ‘wd15ears’ model ,you can try … waiting various minutes before restart from that freedos.  i have now 128 start/stop count and 1039 load cycle count (i have this hard disk from more than 4 months) and i think this will be hardly increased. i have to try also an external WD 640gb wd ‘6400aaks’ sata2 16mb caviar blue and to check its LCC count, i don’t know, i use WD15EARS as single only internal harddrive/disk (over a LG cdrw  burner ,both sata2 ) in this pc, and i 'm satisfied of its speed also for games and programs. :smiley:  i hope this problems is resolved. bye

 

If you want FreeDOS OEM Bootable iso image with WDIDLE3 Version 1.05 inside, i put it to megaupload now then i give to u the link, you’ll have to burn in an empty cdr or cdrw and boot the system from it.

HERE THE LINK : http://www.megaupload.com/?d=L6WMSEVC

 

i wanted to quote this message :

hogis wrote:

Hello

I changed idle time to 240s, using tutorial by superstar. Now my WD20EARS seems not to park heads at all. Whole day passed and it didn’t park even once. I changed time back do default 8s, but it didn’t affect behaviour of HDD. I use it as external backup disk so it’s not used by system and should go idle quickly, it used to be that way.

Any ideas? :wink:

 

UPDATE
This is very strange. After running DLGDIAG quick test my HDD started parking after 8s again. So now it seems to be fine. Still I don’t know if I should lenghten idle time with wdidle3 :frowning:

Thanks for the freedos iso, I have just spent hours trying to create a dos boot disk in mac os x, about to give up, your iso worked perfectly. My WD10EARS load count has stopped climbing, still ticks every 4 seconds or so, not sure if thats important. First one I had I sent back to amazon, it also ticked with the same frequency.

thanks again

with wdidle3.exe /s300 in wd15ears model lcc increases +1 when you switch it off and then switch on, is like start/stop count.

It’s not made by me that the freedos oem bootable image file,I found it on another forum and  i’ve just edited it to include wdidle3 version 1.05 with magic iso maker

meow81 wrote:

with wdidle3.exe /s300 in wd15ears model lcc increases +1 when you switch it off and then switch on, is like start/stop count.

It’s not made by me that the freedos oem bootable image file,I found it on another forum and  i’ve just edited it to include wdidle3 version 1.05 with magic iso maker

Yeah I had trouble extracting dos boot files and adding to them on my mac, sure its possible but beyond me, so appreciated your posting an iso with wdidle3 already added.

I ran wdidle /D which as you say means load cycles appear to be related to booting/sleeping which appears normal.

Ta

Ouch i just read about this at another forum, checked my 1 year old WD Caviar Green 1TB and here is the result:

Hours used:  8197 (almost 24/7)
 

LCC:  217404

LCC/Hours:  26,52 per hour

So if i have read well, my 1 year old HD has already 217k LLC and the life max is 300k, so after a year, this HD is close to the end of it’s life cycle, am i right??

I’m going to apply the fix, but seems it might even be too late for my HD…

Hi,

One question. Can this cause corrupted and then missing SMART information? This cause bios to want press F1 when boot.

I have bought WD20EADS (26.04.2010) and last month it gave corrupted SMART info with full of warnings and errors. After that it won’t give any SMART info.

WDIDLE3 detected that it was using 8s idle time and changed it to 300s.

I usually use Crystal Disk Info to monitor all my HDs.

Icekill no

you can read here http://webdiary.com/i/?tag=idle3

“Although the increase in load/unload cycles is within design margins (drive has been validated to 1 million load/unload cycles without issue) a balance between life of product, logging requirements, and low power consumption can be achieved depending on what is critical to the system. Present SMART normalized values have not been re-normalized to 1 million cycles so advisory reporting on this attribute does not mean failure of product.”

Supra asked a while ago;

“How do you suggest I run the utility on my Mac and will it support a WDxxEARS drive located in an external enclosure connected to the Mac via Firewire or USB?”

I have exactly the same question.

I’ve got 3  laptops - 2 macbooks and 1 windows 7 netbook and no access to a pc’s motherboard.

I’ve bought 2 x 2tb drives to go into my external drive enclosure and would like to sort this first.

Made up a USB key with the application/utility on it, how do I fix the issue?

Can’t say I’m going to be too happy if I’ve spent over £130 on two drives with a fault I can’t fix.

boomhaueruk, I don’t believe it is possible to run WDIDLE on a drive behind a USB/Firewire - SATA bridge. I believe this is because WDIDLE uses WD’s vendor specific ATA commands which would be rejected by the enclosure’s bridge chip. In any case, the external enclosure would require a DOS driver for its USB/Firewire interfaces.

zborgerd said, on beginning of page 7 :

What a strange drive. Considering the fact that it lies about the block size and has such aggressive idle settings, I can't say that I would suggest that non-technical users buy this product.

I do completely agree with that!

But to be correct, it does not “lie”, it just uses what’s called Advanced Format 512e emulation.

The norm is here : https://secure.wikimedia.org/wikipedia/en/wiki/Advanced_Format

Nevertheless, I do agree with you, it would be fine if there would be a way to make it work in 4K native, as described in the above norm.

So now, as I’m considering buying a NAS from a well known vendor and several disks, here are questions to WD officials:

-1) Do you plan any time soon to manufacturer unexpensive (*) drives without the 8 second head park which is clearly a bug (**)

-2) Do you plan any time soon to support the 4K native mode of AF, be it through a jumper change

(*) by unexpensive, I meant that I wouldn’t care buying a blue or black (or any color!) if they had a similar price, seen that only green have the 8s park issue. Unfortunately, blue do not come with the same capacity and black do not come at the same price.

(**) WD official mentioned earlier that removing headpark could cause damage when computer is moved. True. But considering that it is a 3"5 drive, it is mainly meant for desktop (or NAS). So this objection is irrelevant. And to my point of view, the power saving of idle3 is also irrelevant on a desktop that is generally plugged to a power source and which consumption is,  in the average, somewhere between 250 and 750W. Even more, studies prove that the electricity savings between green and black is not more than a few dollars a year.

So, very clearly, this “feature” is a bug!

I have an old WD1T and a WD2T RE4 which were build prior to this bug. I’m very happy with both these drives.

And of course, I do also accept the answer that the new drives are not meant for me.

As WD official said, there are other models… there are other vendors too! :smiley:

its very simple to see the problem ?

what eletricity can you save when the hard drives is allways loading/unloading the heads??´´

i think we can save more energy if the heads have more time in the “load” position