Great disappointment with WD TV Live

I own this [Deleted] since Sept. 2010. Starting with audio issues (btw. not solved until yet) there are network problems since the last firmware update. The network connections is working a few minutes and then is lost.

I am not in the mood anymore to try solving the problem. It’s a tragedy, when a world wide working and selling company isn’t aible to produce a product which only has to play some mp3, avi and connect to the net. 

One more piece to the [Deleted].


Every resolved network issue has been the result of something else wrong with the network, and not the WDTV at all.

The vast majority of users can use networking with no issues, under all firmwares.

If you can’t be bothered to set the network up properly, and/or find the problem, your bound for disappointments.  But WD isn’t really responsible for something wrong on your network and isn’t in a position to fix your network for you.

Have you read my post? My network worked well since september 2010. Starting with the newest firmware the Network works well for the first minutes and then the issues begin. Now you. Where do you think is the problem? In my network or in the Firmware?

I am quite sure RoofingGuy did read your post, and so did I. It was absent of any useful information concerning your network problem.

Unfortunately I let my RMRC (Remote Mind Reading Certification) lapse a few a few years ago so I can no longer practice in that area.

However, we can do it the conventional way by you explaining a few things-

  1. What are the network issues that begin after the first few minutes? 

  2. How are you connected to your network (WiFi, wired)?

  3. Are you observing problems with locally streamed media or Internet media?

  4. How are you streaming your local media, network shares or media server?

  5. What have you changed on your network recently (including routers, switched, server OS or software, etc.)?

1 Like

Even though i won’t use the WD-Live anymore, i will give u some information.

  1. My network hasn’t changed since at leat one year ago.
  2. With one exception ( my iPad) all devices are connected to the network by wire (100 Mb Lan)
  3. Router is an AVM Fritz!Box 7270 (given to me by my cable network internet provider)
  4. The following problem is new since last firware update: after powering on, in most cases i got no problems. I can look on the files on any pc in my house, select files and play them. After some time, for example when i am want search some other files, the network connection get lost and i can’t access any pc anymore.

This behavior in 4. Is totally new since the last firmware update.

Before that i have had no !!! network problems. I could at least hear mp3 (with dropouts indeed, but i can hear).