Got WD Essential II 500 GB 4 hours and can't use it


I just bought a Western Digital Essential II 500 GB new from the shop.

I have Windows Vista Ultimate 64 bit.

When i got it i unpacked it and connected it. I executed on “My Passport (F:)” drive the following file: WD SmartWare.exe. I did this with admin rights.

I came to the main menu and choose:“Install WD SmartWare”

I accepted the EULA

 It started installing but during the install it gave me the following error tekst:

“Can’t find the file C:\Program Files (X86)\Western Digital\ WD Smartware\Front Parlor\WDSmartWare.exe”

Error Message came up and ended the installation.

I went searching and came to this link:

I followed the instruction there.

I made sure my windows was up to date.

I made sure i had the most recent version of Adobe Flash.

I made sure my AVG Virusscanner was diabled.

I downloaded the file:" EssentialElite_FirmwareUpdater_v2.003("

unpacked it and ran the .exe file.

The external drive was connected. I made sure my other external drive (Toshiba) was disconnected.

It was searching for the WD drive and gave me the message that it couldn’t find it. I tried it a few times. It couldn’t find it.

In Windows explorer i could see it and acces it.

I tried the step two on that page and  downloaded the file:“”

I unpacked that file and ran the .exe file.

It said it updated the WD software.

Still no WD software to be found. I tried all these steps with rebooting after every step. Connecting and disconnecting the drive. Nothing is working.

I have this drive now for four hours and allready ready to pack it up and send it back. I hope you can give me advise on how to solve this. If not…then my first try with Western Digital will also be my last.

Kind Regards,


I have the exsact same problem with the "can’t find file… " on my new My  Passport Essential 500GB on a fully updated Windows 7 laptop. Did you find a solution?



I have the same problem. Did you find any solution?


i haven’t found a solution and got no help from Western Digital support. So i returned the disk and told the compagny i ordered it from what is going on.

The accepted it back and refunded me the money.

I now bought a Freecom Mobile Drive XXS 500 gb. That is thing is working awesome and had no problems with software.

So maybe idea to return the drive and order the one i bought.

If not…good luck solving your problem.

Did anyone solve this problem? I have the same, can’t install the SmartWare. If nobody help me to tommorow I will change it for seagate or another

Got the same problem. Does anyone has already found any light in the end of the tunnel?

Have any of you tried contacting Tech Support about your issues? 

To Contact WD for Technical Support

Yes, both me and the first writer contacted Tech Support and got useless standard answers (eg. make sure your windows is uptodate and you have current versions of Adobe) - doh…


The version of Smartware was released this last weekend.  I would advise fully uninstalling the software, rebooting and downloading the latest update from our website. 

1 Like

Well, installing the update completely solved the problem. I can now use smartware to backup and encrypt.