GoFlex Home NAS and external drive: cannot access via WD TV Live Hub using Network Share

I have GoFlex Home NAS (3TB) and external drive (6TB) connected to my PC (and I can see the shared folders there), but I cannot access via WD TV Live Hub using Network Share.

I can see the Home Public contents on the WD TV Live Hub using UPNP-AV , but the external drive contents are truncated at about 7 folders (out of 203). I had the same set up before I moved and always used the Network Share feature on my WD TV Live Hub . Now I can see the GoFlex Home icon, but when I click it, a message appears “Cannot access drives.” One thing that has changed: I had to switch to Time Warner cable modem and a new router at my new house. Obviously, my router is compatible with UPNP or I wouldn’t be seeing the Home Public drive.

Both of the drives show up on the Seagate Share utility, and all folders are listed as “Shared”. Is there something wrong with my WD TV Live Hub set-up? 

I’ve been working on this for days and going mad.


I suggest you to reset the Hub by pressing its reset button for 4 seconds.  If the issue persists it might be related to the new router and modem.  You may try accessing your NAS, having it plugged directly to the Hub by Ethernet, bypassing router and modem.

I tried hitting reset, and initiating reset through the menu: all I succeeded in doing was losing the Music network share I had! (Now, I can’t see my PC on the network!)

Then, I tried plugging the NAS into the HUB via Ethernet and couldn’t find the NAS (by choosing Network Share, UPNP, Local drive, etc. Worse than connecting through my home network.

Anyone with other suggestions?