Glitches of a new owner


#1

So I’m trying to give my new WD TV Live a workout while I can still return it if need be.  So far, I’ve encountered a few minor glitches, all playing directly from a USB-connected hard drive, using the latest firmware (but all issues occurred on the 1.0.17 firmware it was shipped with too).

  1. Playing 1080p h.264 mp4’s with AAC stereo sound causes the audio to glitch whenever the video bitrate is high.  This is too bad, since I had converted a number of my movies to that format so that they could play nicely in Quicktime (mp4s in h.264 with AAC sound are the only ones Quicktime on a Mac will use the GPU to decode).  On the other hand, if I go with WD TV Live, I can leave everything in my original MKV, which plays fine – but it’s still worrisome that this device seems to have problems with AAC sound.  Other posts here seem to suggest this is a known problem.

  2. The WD TV starts up fine, but it takes literally 10-15 minutes before my usb-attached 1TB Western Digital hard drive appears as an accessible local drive.  This means that the effective startup time is over 10 minutes – no good for a media player at all.  This happens whether I have the “Media Library” turned on or not.  Is this a common problem, and is there a solution to this, or do I just have to leave the WD TV on all the time?

  3. Playing high-bitrate 1080p h.264 mkv’s (AC3 sound) occasionally caused the WD TV to stutter and stall altogether when the bitrate spiked (around 30-40 mbps) – a very graceless way to fail, since it should at worst just drop a few frames and keep on going.  After some fiddling around, it appear that the problem is just that when my attached hard drive (finally) appears in the OS, the WD TV is still doing something with the hard drive, so that if I play a movie shortly after it starts up, the movie has to compete with whatever the WD TV is doing, causing stutters.  But if I wait another few minutes, whatever the WD TV is up to finishes, and the movie plays fine.

  4. The WD TV picture as displayed on my TV looks slightly but distinctly inferior to that output by my laptop over DVI to HDMI – the colors are less vibrant and the contrast is lower (the various color settings make no difference that I can see).  This is probably just a settings thing, but it’s a bit frustrating that there’s no way to change such basic things from within the WD TV.  I tweaked the TV set a bit, boosting the contrast and saturation and lowering the brightness, and that brought the WD TV image into rough parity with the laptop output – but I could probably do the same for the TV set’s settings for the laptop input and the weaker image of the WD TV might remain.  

So far, all these glitches are surmountable, but it’s a bit rough for product which essentially replicates what my computer can already do, and whose whole selling point is its convenience.  Any advice about smoothing over these issues is appreciated.


#2

Here’s my take (fwiw):

  1. I think it’s going to be hard to reconcil your MP4s with the Live.  Your AAC problem isn’t the only one people note.    I essentially gave up on that container (I have an AppleTV and hundreds of MP4s that I reconverted).  OTOH, as you note the MKV container plays fine and it has a huge advantage over MP4s (and any Apple device) in that it will pass through 5.1 DTS and AC3 surround sound.  If your setup doesn’t have surround sound that is a null factor, but for me it was the deciding point in dumping my ATV (well, that and the horrendous iTunes transfer system).

  2. That’s very odd.  I’ve heard at least one person complain about network shares taking that long, but this is the first time I’ve seen a local drive delay issue (although I’ve only been reading here for a month or so).  When I had local drives attached it was a matter of 30 seconds or so, even for a few hundred movies.  (And my network shares are even faster, but my local drive DID have the media library turned on, which probably accounted for the 30 second or so delay).  Unless you have literally thousands of items on that drive I would not expect such a delay (if you DO have that many items I’d advise you to delete all but the movies).  That probably could surely be solved by reformatting the drive but it may not need that drastic a solution (although, to be fair, everyone should have such drives backed up so a reformat and reload shouldn’t be a big issue).

  3. This would be solved by the above.

  4. I’m surprised by this as well – on my Samsung 55" LED the image from the Live is actually better than my attached blu-ray player playing the same movie (I rip with Handbrake and even at RF 22 the image is superb).  There are a few settings you can tweak on the Live (like colorspace) but the only thing that really occurs to me is that your image from your laptop is too “hot” (some folks do enjoy a picture that isn’t “true” to the source, and it may well be you’ve gotten used to that inaccurate setting.  I’d compare it with the original DVD/blu-ray and see if maybe it’s your laptop that’s the real problem there).

Hope this helps somewhat.


#3

I have delay issues too with a usb connected drive but it takes more like 2-3 minutes for it to be accessible.

If I disable the networking it comes up instantly.

I reckon it’s stuck doing something on the network before it gets around to scanning for connected usb devices.


#4

I have the same up to 2 min delay with MyBook Elite 1Tb and some cheap 2 Gb usb flash. Also, i’ve found post, here and in other forums, from people complaining about the same usb delay, so maybe this is not so very odd issue.


#5

Thanks for the detailed replies.

I doubt the slow appearance of the USB drive is due to a network issue, since the device isn’t attached to a network at all.  (I thought I’d bring features online one a time precisely to make sure things like the network weren’t affecting the baseline movie-playing ability.)  But it could be that the drive has too much stuff on it; there’s another partition I used as a backup which has lots of junk on it which I could move elsewhere.  But it’s still a bit odd, given than a normal OS can load a drive (I’m just using list view, after all) in a second or two, regardless of the contents.  

As for the color, I expect it’s just that my Mac deliberately puts out a slightly more saturated color, which indeed I do prefer, strict realism or no.  But I’m relieved to hear that this is not an issue others have, so if do “correct” it on the TV end, at least I’m not compensating for some inherent deficiency.

Thanks everyone!