Ghost Files/Folders

This has happened to me a couple of times and I currently have the problem. I use RichCopy to transfer files to my WDTVLH. Because of this, I sometimes transfer multiple files to a single folder then use Windows Explorer to move some of the files to more appropriate folders. When I look at my WDTVLH interface, it looks like the files are still in the original folder. However if I try to play or move them, I am advised that they do not exist on the drive. But I cannot remove the icons for the non-existent files. This happened one time with a sub-folder that I moved. When I deleted the non-existent sub-folder, it deleted the movie files it thought were there but were really in a different folder! It seems that an option to re-read folder contents to update the library would do the job. I think the only option is to reset the entire library which I prefer not to do. So, perhaps someone has a workaround for me? If not, I appreciate the opportunity to rant. Thanks.

Duplicate folders is mentioned in other threads.

But if you select a folder that these items are in and select ‘Rescan’ does this not fix it.

Available in the last two firmwares anyway?

Rescan does not do the trick.

I checked yesterday and the phantoms were still there. I came up with a solution: put dummy files there with the names of the phantoms and use the UI to delete them. Today I went to write down the file names and they were gone. So it took about six weeks but the problem took care of itself. I think my solution would have worked though.

It’s the twonky server that is not working properly. You found a way to fool it. You can also delete the twonky database and do a rescan. This twonky thing was never updated I believe. Even with all the fancy updates of the firmware.

Thanks. I’m not sure what you mean by “delete the twonky database.” Is this clearing the library? Also, I’m not sure my work around will work. I watched the real file that the ghost file mirrors and the little full-moon icon that shows if a file has been watched was toggled for both the actual file and the ghost file. I suspect that if I delete the ghost file, the pointer to the actual file will be gone and it will not be in the library though still physically on the disc. This is kind of what I experienced with the folders in my previous similar problem.

Use your webbrowser while your hub in on, or in standby and connected to your network.

Go to:  http://wdtvlivehub.local./Main.php

There you see an option ‘Media’ , click it. Select Twonky (if it is set to iTunes) Go to Twonkyserver and be sure it is ‘on’. (enabled).

Then Launch Twonky. Probably nothing happens since the twonky part of the hub needs an update (to my opinion)

If nothing happens type:  http://wdtvlivehub.local:9000/

You will tehn enter the twonky browser. Go to the ‘Tools’ sign. You then can rebuild the database.

See if it works!

Thanks for the advice. Though I can navigate the folders of the Hub, I cannot access either of those web pages. I get the message: Server not found. Firefox can’t find the server at wdtvlivehub.local.


Copy and paste one of these into the address bar

You need




But not having used Twonky myself anything after the above I am not sure about.


Thanks. I can access neither of those. They redirect to my DNS server as an error.

Have you tried to power cycle the hub?

Power down by a 5 second hold of the power button.

Leave a minute and then turn back on. I have had a similar problem and this cured it.


okay. I can get there using the Hub’s IP address, 192.168.1.nnn:9000. I just rebuilt the database. Thanks for the help.

Remember the ip adres. You will need it more often since the twonky server is not working as it should I have to do a manual rescan every time I add something to the hub. Even though I have set the scan ‘value’ to -1. This twonky is becomming a pain in the …!