Getting WDTV Live Plus to use my Linksys USB600N


#1

Greetings everyone,

I have a WDTV Live Plus running the latest firmware (1.04.22_B) that I am trying to connect to my home network using a Linksys WUSB600N.  

The WUSB600N doesn’t have a revision number on it - so I have to assume it is V1 (which is on the hardware compatibility list)

The WDTV detects the adaptor with no problem but when I try to connect to two different access points, either using AES2 or no security whatsoever I get an error telling me the device wasn’t assigned an IP.  It isn’t like the WDTV isn’t seeing the APs - it just can’t successfully connect.

I have tried manually assigning an IP to no avail.  Wired networking does work but I want the USB network device to work.  It seems like it should work but it doesn’t.

Has anyone seen this particular issue?  I have been combing the internet for the last week for an answer but I haven’t found one yet. 

Any suggestions would be appreciated.

Thanks!


#2

My friend im in the same boat as you :frowning: same USB wireless dongle :frowning: What happens with me is i can get the IP etc but always fails at DNS. However i connect it to wired and it works right away. Struggling to get this wirless working.


#3

I have fixed my network and confirm usb600n does :slight_smile: and works fantastic :slight_smile: what i had to do is this… in router setup panel… i changed an option called Wi-Fi Protected Setup (also called WCW.2.0) and turned that OFF then i changed my WEP security to WEP KEY 64bit OPEN and no more DNS errors :slight_smile:


#4

Don’t use WEP.   WEP is TERRIBLE, and you also cannot use 802.11n with WEP.   

Use WPA2.   :slight_smile:


#5

Tony is right. Do not use WEP. Try using WPA2-PSK [AES] instead.

I have been using the WUSB600N (although it is a V2) for a long time now without any problems. 


#6

only WEP will let my wdtv connect (aka pass the DNS problem) i have my router filtering Network addresses anyway. So im sure its quite secure.


#7

I could be in your network in about 5 seconds flat.   I can set my WiFi card’s address to match yours, thus bypassing that rule.  :)


#8

well i dont have clue to why i cant get passed the DNS connection stage on WDTV when i change the other router protection from WEP