Getting to the end of my tether!

I bought a WDTVlive Hub 1TB device around 3 months ago.
For the first month or so, it was fine, then issues started occuring.

FIrstly, all my content dissappeared, and the internal drive was not recognised. THis was intermittent at first, then became this way around 50% of the time. SOmeimtes it’s fine, sometimes, it decides in the middle of an operation, the files don’t exist.

THen, then network connection became a little unstable, so I replaced the router, the cables, etc, just in case, but to no avail.
Now the network connection is the same as the disk, half the time it works, half the time it doesn’t.
I’ve tried connection from Linux machines, Windows machines, Tablets, you name it. AL]ll the same.

THen this weekend, it decided that my internal disk needed formatting as it was corrupted, thankfully, dropbox was configured to sync all my important pictures etc, so no great loss of data.

IVe tried many firmware upgrades, downgrades, reupgrades, settings reset, you name it.

I’m just fed up now. I can’t even bear to think about watching a movie on the device any more as Iget so frustrated before it even starts!

HOw can I get the device returned for a warranty repair / investigation, or is there a magic fix somewhere I haven’t tried…?

PLease help before I implode.

Start here

Good luck